UbuntuUpdates.org

Package "postgresql-10"

Name: postgresql-10

Description:

object-relational SQL database, version 10 server

Latest version: 10.21-0ubuntu0.18.04.1
Release: bionic (18.04)
Level: security
Repository: main
Homepage: http://www.postgresql.org/

Links


Download "postgresql-10"


Other versions of "postgresql-10" in Bionic

Repository Area Version
base main 10.3-1
base universe 10.3-1
security universe 10.21-0ubuntu0.18.04.1
updates main 10.21-0ubuntu0.18.04.1
updates universe 10.21-0ubuntu0.18.04.1
PPA: Postgresql 10.8-1.pgdg14.04+1
PPA: Postgresql 10.17-1.pgdg16.04+1
PPA: Postgresql 10.21-1.pgdg22.04+1
PPA: Postgresql 10.21-1.pgdg18.04+1
PPA: Postgresql 10.21-1.pgdg20.04+1

Packages in group

Deleted packages are displayed in grey.


Changelog

Version: 10.14-0ubuntu0.18.04.1 2020-08-25 13:06:22 UTC

  postgresql-10 (10.14-0ubuntu0.18.04.1) bionic-security; urgency=medium

  * New upstream release (LP: #1892335).
    - Set a secure search_path in logical replication walsenders and apply
      workers (Noah Misch)

      A malicious user of either the publisher or subscriber database could
      potentially cause execution of arbitrary SQL code by the role running
      replication, which is often a superuser. Some of the risks here are
      equivalent to those described in CVE-2018-1058, and are mitigated in
      this patch by ensuring that the replication sender and receiver execute
      with empty search_path settings. (As with CVE-2018-1058, that change
      might cause problems for under-qualified names used in replicated
      tables' DDL.) Other risks are inherent in replicating objects that
      belong to untrusted roles; the most we can do is document that there is
      a hazard to consider.
      CVE-2020-14349

    - Make contrib modules' installation scripts more secure (Tom Lane)

      Attacks similar to those described in CVE-2018-1058 could be carried out
      against an extension installation script, if the attacker can create
      objects in either the extension's target schema or the schema of some
      prerequisite extension. Since extensions often require superuser
      privilege to install, this can open a path to obtaining superuser
      privilege. To mitigate this risk, be more careful about the search_path
      used to run an installation script; disable check_function_bodies within
      the script; and fix catalog-adjustment queries used in some contrib
      modules to ensure they are secure. Also provide documentation to help
      third-party extension authors make their installation scripts secure.
      This is not a complete solution; extensions that depend on other
      extensions can still be at risk if installed carelessly.
      CVE-2020-14350

    - Details about these and many further changes can be found at:
      https://www.postgresql.org/docs/10/static/release-10-13.html
      https://www.postgresql.org/docs/10/static/release-10-14.html

 -- Christian Ehrhardt <email address hidden> Thu, 20 Aug 2020 11:29:28 +0200

Source diff to previous version
1892335 New upstream microreleases 9.5.23 10.14 and 12.4
CVE-2018-1058 A flaw was found in the way Postgresql allowed a user to modify the behavior of a query for other users. An attacker with a user account could use th
CVE-2020-14349 It was found that PostgreSQL versions before 12.4, before 11.9 and bef ...
CVE-2020-14350 It was found that some PostgreSQL extensions did not use search_path s ...

Version: 10.12-0ubuntu0.18.04.1 2020-02-18 14:07:43 UTC

  postgresql-10 (10.12-0ubuntu0.18.04.1) bionic-security; urgency=medium

  * New upstream release (LP: #1863108)
    - A dump/restore is not required however, if you use the contrib/intarray
      extension with a GiST index, and you rely on indexed searches for the <@
      operator, see the release notes for details in regard to a related fix.
    - Add missing permissions checks for ALTER ... DEPENDS ON EXTENSION.
      Marking an object as dependent on an extension did not have any
      privilege check whatsoever. This oversight allowed any user to mark
      routines, triggers, materialized views, or indexes as droppable by
      anyone able to drop an extension. Require that the calling user own the
      specified object (and hence have privilege to drop it). (CVE-2020-1720)
    - Details about these and many further changes can be found at:
      https://www.postgresql.org/docs/10/static/release-10-11.html
      https://www.postgresql.org/docs/10/static/release-10-12.html

 -- Christian Ehrhardt <email address hidden> Thu, 13 Feb 2020 15:18:22 +0100

Source diff to previous version
1863108 New upstream microreleases 9.5.21 10.12 11.7 and 12.2

Version: 10.10-0ubuntu0.18.04.1 2019-08-09 00:07:06 UTC

  postgresql-10 (10.10-0ubuntu0.18.04.1) bionic-security; urgency=medium

  * SECURITY UPDATE: New upstream release (LP: #1839058)
    - Require schema qualification to cast to a temporary type when using
      functional cast syntax (CVE-2019-10208)
    - Fix failure of ALTER TABLE ... ALTER COLUMN TYPE when altering multiple
      columns' types in one command. This fixes a regression introduced in the
      most recent minor releases
    - Details about these and many further changes can be found at:
      https://www.postgresql.org/docs/10/static/release-10-10.html

 -- Christian Ehrhardt <email address hidden> Tue, 06 Aug 2019 08:55:10 +0200

Source diff to previous version
1839058 New upstream microreleases 9.5.19 10.10 and 11.5
CVE-2019-10208 postgres: Require schema qualification to cast to a temporary type when using functional cast syntax

Version: 10.9-0ubuntu0.18.04.1 2019-06-20 17:06:23 UTC

  postgresql-10 (10.9-0ubuntu0.18.04.1) bionic-security; urgency=medium

  * New upstream release (LP: #1828012)
    - Fix buffer-overflow hazards in SCRAM verifier parsing and libpq
      CVE-2019-10164
    - Fix failure of ALTER TABLE ... ALTER COLUMN TYPE when the table has
      a partial exclusion constraint
    - Fix failure of COMMENT command for comments on domain constraints
    - Prevent possible memory clobber when there are duplicate columns in
      a hash aggregate's hash key list
    - Details about these and many further changes can be found at:
      https://www.postgresql.org/docs/10/static/release-10-9.html

 -- Christian Ehrhardt <email address hidden> Tue, 18 Jun 2019 13:11:36 +0200

Source diff to previous version
1828012 New upstream microreleases 9.5.17, 10.8 and 11.3
CVE-2019-10164 postgres: Stack-based buffer overflow via setting a password

Version: 10.8-0ubuntu0.18.04.1 2019-05-13 13:07:25 UTC

  postgresql-10 (10.8-0ubuntu0.18.04.1) bionic-security; urgency=medium

  * New upstream release(s) (LP: #1828012)
    - Prevent row-level security policies from being bypassed via
      selectivity estimators.
      CVE-2019-10130
    - Details about these and many further changes can be found at:
      https://www.postgresql.org/docs/10/static/release-10-8.html

 -- Christian Ehrhardt <email address hidden> Tue, 07 May 2019 11:20:35 +0200

1828012 New upstream microreleases 9.5.17, 10.8 and 11.3
CVE-2019-10130 Selectivity estimators bypass row security policies



About   -   Send Feedback to @ubuntu_updates