Package "postgresql-10"

Name: postgresql-10


This package is just an umbrella for a group of other packages, it has no description.
Description samples from packages in group:

  • development files for PostgreSQL 10 server-side programming

Latest version: 10.9-0ubuntu0.18.04.1
Release: bionic (18.04)
Level: security
Repository: universe


Save this URL for the latest version of "postgresql-10": https://www.ubuntuupdates.org/postgresql-10

Other versions of "postgresql-10" in Bionic

Repository Area Version
base main 10.3-1
base universe 10.3-1
security main 10.9-0ubuntu0.18.04.1
updates universe 10.9-0ubuntu0.18.04.1
updates main 10.9-0ubuntu0.18.04.1
PPA: Postgresql 10.8-1.pgdg14.04+1
PPA: Postgresql 10.9-1.pgdg16.04+1
PPA: Postgresql 10.9-1.pgdg18.04+1

Packages in group

Deleted packages are displayed in grey.


Version: 10.9-0ubuntu0.18.04.1 2019-06-20 17:06:25 UTC

  postgresql-10 (10.9-0ubuntu0.18.04.1) bionic-security; urgency=medium

  * New upstream release (LP: #1828012)
    - Fix buffer-overflow hazards in SCRAM verifier parsing and libpq
    - Fix failure of ALTER TABLE ... ALTER COLUMN TYPE when the table has
      a partial exclusion constraint
    - Fix failure of COMMENT command for comments on domain constraints
    - Prevent possible memory clobber when there are duplicate columns in
      a hash aggregate's hash key list
    - Details about these and many further changes can be found at:

 -- Christian Ehrhardt <email address hidden> Tue, 18 Jun 2019 13:11:36 +0200

Source diff to previous version
1828012 New upstream microreleases 9.5.17, 10.8 and 11.3
CVE-2019-10164 postgres: Stack-based buffer overflow via setting a password

Version: 10.8-0ubuntu0.18.04.1 2019-05-13 13:07:26 UTC

  postgresql-10 (10.8-0ubuntu0.18.04.1) bionic-security; urgency=medium

  * New upstream release(s) (LP: #1828012)
    - Prevent row-level security policies from being bypassed via
      selectivity estimators.
    - Details about these and many further changes can be found at:

 -- Christian Ehrhardt <email address hidden> Tue, 07 May 2019 11:20:35 +0200

Source diff to previous version
1828012 New upstream microreleases 9.5.17, 10.8 and 11.3
CVE-2019-10130 Selectivity estimators bypass row security policies

Version: 10.6-0ubuntu0.18.04.1 2018-11-14 20:06:56 UTC

  postgresql-10 (10.6-0ubuntu0.18.04.1) bionic-security; urgency=medium

  * SECURITY UPDATE: Updated to 10.6 to fix security issue.
    - Details about the new release can be found at
    - CVE-2018-16850

 -- Marc Deslauriers <email address hidden> Tue, 13 Nov 2018 15:18:23 -0500

Source diff to previous version
CVE-2018-16850 postgresql before versions 11.1, 10.6 is vulnerable to a to SQL ...

Version: 10.5-0ubuntu0.18.04 2018-08-17 02:33:42 UTC

  postgresql-10 (10.5-0ubuntu0.18.04) bionic-security; urgency=medium

  * New upstream release (LP: #1786938)
    - Fix failure to reset libpq's state fully between connection attempts
      An unprivileged user of dblink or postgres_fdw could bypass the checks
      intended to prevent use of server-side credentials, such as a ~/.pgpass
      file owned by the operating-system user running the server. Servers
      allowing peer authentication on local connections are particularly
      vulnerable. Other attacks such as SQL injection into a postgres_fdw
      session are also possible. Attacking postgres_fdw in this way requires
      the ability to create a foreign server object with selected connection
      parameters, but any user with access to dblink could exploit the
      problem. In general, an attacker with the ability to select the
      connection parameters for a libpq-using application could cause
      mischief, though other plausible attack scenarios are harder to think
      of. Our thanks to Andrew Krasichkov for reporting this issue.
    - Fix INSERT ... ON CONFLICT UPDATE through a view that isn't just SELECT
      FROM ...
      Erroneous expansion of an updatable view could lead to crashes or
      attribute ... has the wrong type errors, if the view's SELECT list
      doesn't match one-to-one with the underlying table's columns.
      Furthermore, this bug could be leveraged to allow updates of columns
      that an attacking user lacks UPDATE privilege for, if that user has
      INSERT and UPDATE privileges for some other column(s) of the table. Any
      user could also use it for disclosure of server memory.
    - d/libecpg-dev.install: Add new pgtypes header.
    - d/libpgtypes3.symbols: Add new pgtypes symbol.
    - d/p/filter-debug-prefix-map: update to match 10.5
    - update maintainers
    - Details about these and other changes can be found at

 -- Christian Ehrhardt <email address hidden> Tue, 14 Aug 2018 14:49:18 +0200

1786938 New upstream microreleases 9.3.24, 9.5.14, and 10.5
CVE-2018-10915 A vulnerability was found in libpq, the default PostgreSQL client library where libpq failed to properly reset its internal state between connections
CVE-2018-10925 It was discovered that PostgreSQL versions before 10.5, 9.6.10, 9.5.14, 9.4.19, and 9.3.24 failed to properly check authorization on certain statemen

About   -   Send Feedback to @ubuntu_updates