UbuntuUpdates.org

Package "postgresql-10"

Name: postgresql-10

Description:

This package is just an umbrella for a group of other packages, it has no description.
Description samples from packages in group:

  • development files for PostgreSQL 10 server-side programming

Latest version: 10.5-0ubuntu0.18.04
Release: bionic (18.04)
Level: security
Repository: universe

Links

Save this URL for the latest version of "postgresql-10": https://www.ubuntuupdates.org/postgresql-10



Other versions of "postgresql-10" in Bionic

Repository Area Version
base main 10.3-1
base universe 10.3-1
security main 10.5-0ubuntu0.18.04
updates universe 10.5-0ubuntu0.18.04
updates main 10.5-0ubuntu0.18.04
PPA: Postgresql 10.6-1.pgdg18.04+1
PPA: Postgresql 10.6-1.pgdg14.04+1
PPA: Postgresql 10.6-1.pgdg16.04+1

Packages in group

Deleted packages are displayed in grey.


Changelog

Version: 10.5-0ubuntu0.18.04 2018-08-17 02:33:42 UTC

  postgresql-10 (10.5-0ubuntu0.18.04) bionic-security; urgency=medium

  * New upstream release (LP: #1786938)
    - Fix failure to reset libpq's state fully between connection attempts
      .
      An unprivileged user of dblink or postgres_fdw could bypass the checks
      intended to prevent use of server-side credentials, such as a ~/.pgpass
      file owned by the operating-system user running the server. Servers
      allowing peer authentication on local connections are particularly
      vulnerable. Other attacks such as SQL injection into a postgres_fdw
      session are also possible. Attacking postgres_fdw in this way requires
      the ability to create a foreign server object with selected connection
      parameters, but any user with access to dblink could exploit the
      problem. In general, an attacker with the ability to select the
      connection parameters for a libpq-using application could cause
      mischief, though other plausible attack scenarios are harder to think
      of. Our thanks to Andrew Krasichkov for reporting this issue.
      (CVE-2018-10915)
    - Fix INSERT ... ON CONFLICT UPDATE through a view that isn't just SELECT
      FROM ...
      .
      Erroneous expansion of an updatable view could lead to crashes or
      attribute ... has the wrong type errors, if the view's SELECT list
      doesn't match one-to-one with the underlying table's columns.
      Furthermore, this bug could be leveraged to allow updates of columns
      that an attacking user lacks UPDATE privilege for, if that user has
      INSERT and UPDATE privileges for some other column(s) of the table. Any
      user could also use it for disclosure of server memory.
      (CVE-2018-10925)
    - d/libecpg-dev.install: Add new pgtypes header.
    - d/libpgtypes3.symbols: Add new pgtypes symbol.
    - d/p/filter-debug-prefix-map: update to match 10.5
    - update maintainers
    - Details about these and other changes can be found at
      https://www.postgresql.org/docs/10/static/release-10-5.html

 -- Christian Ehrhardt <email address hidden> Tue, 14 Aug 2018 14:49:18 +0200

1786938 New upstream microreleases 9.3.24, 9.5.14, and 10.5
CVE-2018-10915 A vulnerability was found in libpq, the default PostgreSQL client library where libpq failed to properly reset its internal state between connections
CVE-2018-10925 It was discovered that PostgreSQL versions before 10.5, 9.6.10, 9.5.14, 9.4.19, and 9.3.24 failed to properly check authorization on certain statemen



About   -   Send Feedback to @ubuntu_updates