UbuntuUpdates.org

Package "postgresql-10"

Name: postgresql-10

Description:

This package is just an umbrella for a group of other packages, it has no description.
Description samples from packages in group:

  • development files for PostgreSQL 10 server-side programming

Latest version: 10.10-0ubuntu0.18.04.1
Release: bionic (18.04)
Level: updates
Repository: universe

Links

Save this URL for the latest version of "postgresql-10": https://www.ubuntuupdates.org/postgresql-10



Other versions of "postgresql-10" in Bionic

Repository Area Version
base main 10.3-1
base universe 10.3-1
security main 10.10-0ubuntu0.18.04.1
security universe 10.10-0ubuntu0.18.04.1
updates main 10.10-0ubuntu0.18.04.1
PPA: Postgresql 10.8-1.pgdg14.04+1
PPA: Postgresql 10.10-1.pgdg16.04+1
PPA: Postgresql 10.10-1.pgdg18.04+1

Packages in group

Deleted packages are displayed in grey.


Changelog

Version: 10.10-0ubuntu0.18.04.1 2019-08-09 00:07:09 UTC

  postgresql-10 (10.10-0ubuntu0.18.04.1) bionic-security; urgency=medium

  * SECURITY UPDATE: New upstream release (LP: #1839058)
    - Require schema qualification to cast to a temporary type when using
      functional cast syntax (CVE-2019-10208)
    - Fix failure of ALTER TABLE ... ALTER COLUMN TYPE when altering multiple
      columns' types in one command. This fixes a regression introduced in the
      most recent minor releases
    - Details about these and many further changes can be found at:
      https://www.postgresql.org/docs/10/static/release-10-10.html

 -- Christian Ehrhardt <email address hidden> Tue, 06 Aug 2019 08:55:10 +0200

Source diff to previous version
1839058 New upstream microreleases 9.5.19 10.10 and 11.5
CVE-2019-10208 postgres: Require schema qualification to cast to a temporary type when using functional cast syntax

Version: 10.9-0ubuntu0.18.04.1 2019-06-20 17:06:27 UTC

  postgresql-10 (10.9-0ubuntu0.18.04.1) bionic-security; urgency=medium

  * New upstream release (LP: #1828012)
    - Fix buffer-overflow hazards in SCRAM verifier parsing and libpq
      CVE-2019-10164
    - Fix failure of ALTER TABLE ... ALTER COLUMN TYPE when the table has
      a partial exclusion constraint
    - Fix failure of COMMENT command for comments on domain constraints
    - Prevent possible memory clobber when there are duplicate columns in
      a hash aggregate's hash key list
    - Details about these and many further changes can be found at:
      https://www.postgresql.org/docs/10/static/release-10-9.html

 -- Christian Ehrhardt <email address hidden> Tue, 18 Jun 2019 13:11:36 +0200

Source diff to previous version
1828012 New upstream microreleases 9.5.17, 10.8 and 11.3
CVE-2019-10164 postgres: Stack-based buffer overflow via setting a password

Version: 10.8-0ubuntu0.18.04.1 2019-05-13 14:06:44 UTC

  postgresql-10 (10.8-0ubuntu0.18.04.1) bionic-security; urgency=medium

  * New upstream release(s) (LP: #1828012)
    - Prevent row-level security policies from being bypassed via
      selectivity estimators.
      CVE-2019-10130
    - Details about these and many further changes can be found at:
      https://www.postgresql.org/docs/10/static/release-10-8.html

 -- Christian Ehrhardt <email address hidden> Tue, 07 May 2019 11:20:35 +0200

Source diff to previous version
1828012 New upstream microreleases 9.5.17, 10.8 and 11.3
CVE-2019-10130 Selectivity estimators bypass row security policies

Version: 10.7-0ubuntu0.18.04.1 2019-04-04 10:06:35 UTC

  postgresql-10 (10.7-0ubuntu0.18.04.1) bionic; urgency=medium

  * New upstream release (LP: #1815665)
    - By default, panic instead of retrying after fsync() failure, to avoid
      possible data corruption. A new server parameter "guc-data-sync-retry"
      has been added to control this;
    - d/p/pg-10-Disallow-setting-client_min_messages-higher-than-ERR.patch:
      to retain SRU stability this patch reverts one of the changes which
      disabled the error suppression by setting client_min_messages to
      fatal or panic. Overall that means no change to the handling of
      client_min_messages due to this upload.
    - d/p/pg-10-Rename-rbtree.c-functions-to-use-rbt-prefix-not-rb-p.patch:
      this change of 10.7 would break an external ABI/API exposed to
      extensions. To avoid breaking those (especially those not in the Ubuntu
      Archive that we can't control) this change of upstreams stable release
      is reverted. Thereby the ABI/API is unchanged in regard to the rb_
      function prefix by this new package upload to Ubuntu.
    - Details about these and many further changes can be found at:
      https://www.postgresql.org/docs/10/static/release-10-7.html

 -- Christian Ehrhardt <email address hidden> Tue, 12 Feb 2019 21:25:34 +0100

Source diff to previous version
1815665 New upstream microreleases 9.5.16, 10.7 and 11.2

Version: 10.6-0ubuntu0.18.04.1 2018-11-14 20:06:56 UTC

  postgresql-10 (10.6-0ubuntu0.18.04.1) bionic-security; urgency=medium

  * SECURITY UPDATE: Updated to 10.6 to fix security issue.
    - Details about the new release can be found at
      https://www.postgresql.org/docs/10/release-10-6.html
    - CVE-2018-16850

 -- Marc Deslauriers <email address hidden> Tue, 13 Nov 2018 15:18:23 -0500

CVE-2018-16850 postgresql before versions 11.1, 10.6 is vulnerable to a to SQL ...



About   -   Send Feedback to @ubuntu_updates