Package "postgresql-10"

Name: postgresql-10


object-relational SQL database, version 10 server

Latest version: 10.8-0ubuntu0.18.04.1
Release: bionic (18.04)
Level: updates
Repository: main
Homepage: http://www.postgresql.org/


Save this URL for the latest version of "postgresql-10": https://www.ubuntuupdates.org/postgresql-10

Download "postgresql-10"

Other versions of "postgresql-10" in Bionic

Repository Area Version
base main 10.3-1
base universe 10.3-1
security main 10.8-0ubuntu0.18.04.1
security universe 10.8-0ubuntu0.18.04.1
updates universe 10.8-0ubuntu0.18.04.1
PPA: Postgresql 10.8-1.pgdg18.04+1
PPA: Postgresql 10.8-1.pgdg14.04+1
PPA: Postgresql 10.8-1.pgdg16.04+1

Packages in group

Deleted packages are displayed in grey.


Version: 10.8-0ubuntu0.18.04.1 2019-05-13 14:06:42 UTC

  postgresql-10 (10.8-0ubuntu0.18.04.1) bionic-security; urgency=medium

  * New upstream release(s) (LP: #1828012)
    - Prevent row-level security policies from being bypassed via
      selectivity estimators.
    - Details about these and many further changes can be found at:

 -- Christian Ehrhardt <email address hidden> Tue, 07 May 2019 11:20:35 +0200

Source diff to previous version
1828012 New upstream microreleases 9.5.17, 10.8 and 11.3
CVE-2019-10130 Selectivity estimators bypass row security policies

Version: 10.7-0ubuntu0.18.04.1 2019-04-04 10:06:31 UTC

  postgresql-10 (10.7-0ubuntu0.18.04.1) bionic; urgency=medium

  * New upstream release (LP: #1815665)
    - By default, panic instead of retrying after fsync() failure, to avoid
      possible data corruption. A new server parameter "guc-data-sync-retry"
      has been added to control this;
    - d/p/pg-10-Disallow-setting-client_min_messages-higher-than-ERR.patch:
      to retain SRU stability this patch reverts one of the changes which
      disabled the error suppression by setting client_min_messages to
      fatal or panic. Overall that means no change to the handling of
      client_min_messages due to this upload.
    - d/p/pg-10-Rename-rbtree.c-functions-to-use-rbt-prefix-not-rb-p.patch:
      this change of 10.7 would break an external ABI/API exposed to
      extensions. To avoid breaking those (especially those not in the Ubuntu
      Archive that we can't control) this change of upstreams stable release
      is reverted. Thereby the ABI/API is unchanged in regard to the rb_
      function prefix by this new package upload to Ubuntu.
    - Details about these and many further changes can be found at:

 -- Christian Ehrhardt <email address hidden> Tue, 12 Feb 2019 21:25:34 +0100

Source diff to previous version
1815665 New upstream microreleases 9.5.16, 10.7 and 11.2

Version: 10.6-0ubuntu0.18.04.1 2018-11-14 20:06:55 UTC

  postgresql-10 (10.6-0ubuntu0.18.04.1) bionic-security; urgency=medium

  * SECURITY UPDATE: Updated to 10.6 to fix security issue.
    - Details about the new release can be found at
    - CVE-2018-16850

 -- Marc Deslauriers <email address hidden> Tue, 13 Nov 2018 15:18:23 -0500

Source diff to previous version
CVE-2018-16850 postgresql before versions 11.1, 10.6 is vulnerable to a to SQL ...

Version: 10.5-0ubuntu0.18.04 2018-08-17 02:33:40 UTC

  postgresql-10 (10.5-0ubuntu0.18.04) bionic-security; urgency=medium

  * New upstream release (LP: #1786938)
    - Fix failure to reset libpq's state fully between connection attempts
      An unprivileged user of dblink or postgres_fdw could bypass the checks
      intended to prevent use of server-side credentials, such as a ~/.pgpass
      file owned by the operating-system user running the server. Servers
      allowing peer authentication on local connections are particularly
      vulnerable. Other attacks such as SQL injection into a postgres_fdw
      session are also possible. Attacking postgres_fdw in this way requires
      the ability to create a foreign server object with selected connection
      parameters, but any user with access to dblink could exploit the
      problem. In general, an attacker with the ability to select the
      connection parameters for a libpq-using application could cause
      mischief, though other plausible attack scenarios are harder to think
      of. Our thanks to Andrew Krasichkov for reporting this issue.
    - Fix INSERT ... ON CONFLICT UPDATE through a view that isn't just SELECT
      FROM ...
      Erroneous expansion of an updatable view could lead to crashes or
      attribute ... has the wrong type errors, if the view's SELECT list
      doesn't match one-to-one with the underlying table's columns.
      Furthermore, this bug could be leveraged to allow updates of columns
      that an attacking user lacks UPDATE privilege for, if that user has
      INSERT and UPDATE privileges for some other column(s) of the table. Any
      user could also use it for disclosure of server memory.
    - d/libecpg-dev.install: Add new pgtypes header.
    - d/libpgtypes3.symbols: Add new pgtypes symbol.
    - d/p/filter-debug-prefix-map: update to match 10.5
    - update maintainers
    - Details about these and other changes can be found at

 -- Christian Ehrhardt <email address hidden> Tue, 14 Aug 2018 14:49:18 +0200

Source diff to previous version
1786938 New upstream microreleases 9.3.24, 9.5.14, and 10.5
CVE-2018-10915 A vulnerability was found in libpq, the default PostgreSQL client library where libpq failed to properly reset its internal state between connections
CVE-2018-10925 It was discovered that PostgreSQL versions before 10.5, 9.6.10, 9.5.14, 9.4.19, and 9.3.24 failed to properly check authorization on certain statemen

Version: 10.4-0ubuntu0.18.04 2018-06-04 09:07:16 UTC

  postgresql-10 (10.4-0ubuntu0.18.04) bionic; urgency=medium

  * New upstream release (LP: #1769888)
    - A dump/restore is not required for those running 10.X.
      However, if you use the adminpack extension, you should update it as
      per the first changelog entry of the changelog.
      Also, if the function marking mistakes mentioned in the first
      changelog entry affect you, you will want to take steps to
      correct your database catalogs.
    - Details about changes can be found at

 -- Christian Ehrhardt <email address hidden> Tue, 08 May 2018 15:17:41 +0200

1769888 New upstream microreleases 9.3.23, 9.5.13, 9.6.9 and 10.4
CVE-2018-1115 postgresql before versions 10.4, 9.6.9 is vulnerable in the adminpack extension, the pg_catalog.pg_logfile_rotate() function doesn't follow the same

About   -   Send Feedback to @ubuntu_updates