UbuntuUpdates.org

Package "openjdk-11-jre-zero"

Name: openjdk-11-jre-zero

Description:

Alternative JVM for OpenJDK, using Zero

Latest version: 11.0.23+9-1ubuntu1
Release: noble (24.04)
Level: base
Repository: universe
Head package: openjdk-lts
Homepage: https://openjdk.java.net/

Links


Download "openjdk-11-jre-zero"


Other versions of "openjdk-11-jre-zero" in Noble

No other version of this package is available in the Noble release.

Changelog

Version: 11.0.23+9-1ubuntu1 2024-04-22 10:07:25 UTC

  openjdk-lts (11.0.23+9-1ubuntu1) noble; urgency=high

  * OpenJDK 11.0.23 release, build 9.
    - CVE-2024-21011, 8319851: Improve exception logging.
    - CVE-2024-21068, 8322122: Enhance generation of addresses.
    - 8318340: Improve RSA key implementations.
    - CVE-2024-21012, 8315708: Enhance HTTP/2 client usage.
    - CVE-2024-21094, 8317507: Already fixed in November 2023:
      C2 compilation fails with "Exceeded _node_regs array".
    - CVE-2024-21085, 8322114: Improve Pack 200 handling.

  [ Pushkar Kulkarni ]
  * Use 64-bit clock_* function on archs like armhf.

 -- Matthias Klose <email address hidden> Wed, 17 Apr 2024 16:23:29 +0200

CVE-2024-21011 Vulnerability in the Oracle Java SE, Oracle GraalVM for JDK, Oracle GraalVM Enterprise Edition product of Oracle Java SE (component: Hotspot). Suppo
CVE-2024-21068 Vulnerability in the Oracle Java SE, Oracle GraalVM for JDK, Oracle GraalVM Enterprise Edition product of Oracle Java SE (component: Hotspot). Suppo
CVE-2024-21012 Vulnerability in the Oracle Java SE, Oracle GraalVM for JDK, Oracle GraalVM Enterprise Edition product of Oracle Java SE (component: Networking). Su
CVE-2024-21094 Vulnerability in the Oracle Java SE, Oracle GraalVM for JDK, Oracle GraalVM Enterprise Edition product of Oracle Java SE (component: Hotspot). Suppo
CVE-2024-21085 Vulnerability in the Oracle Java SE, Oracle GraalVM Enterprise Edition product of Oracle Java SE (component: Concurrency). Supported versions that a



About   -   Send Feedback to @ubuntu_updates