UbuntuUpdates.org

Package "python-cryptography"

Name: python-cryptography

Description:

This package is just an umbrella for a group of other packages, it has no description.
Description samples from packages in group:

  • Python library exposing cryptographic recipes and primitives (documentation)
  • Python library exposing cryptographic recipes and primitives (Python 3)

Latest version: 3.4.8-1ubuntu2.1
Release: jammy (22.04)
Level: security
Repository: main

Links



Other versions of "python-cryptography" in Jammy

Repository Area Version
base main 3.4.8-1ubuntu2
updates main 3.4.8-1ubuntu2.1

Packages in group

Deleted packages are displayed in grey.


Changelog

Version: 3.4.8-1ubuntu2.1 2023-12-06 17:06:57 UTC

  python-cryptography (3.4.8-1ubuntu2.1) jammy-security; urgency=medium

  * SECURITY UPDATE: corrupted output via immutable objects
    - debian/patches/CVE-2023-23931.patch: don't allow update_into to
      mutate immutable objects in tests/hazmat/primitives/test_ciphers.py,
      src/cryptography/hazmat/backends/openssl/ciphers.py.
    - CVE-2023-23931
  * SECURITY UPDATE: DoS via PKCS7 certificate
    - debian/patches/CVE-2023-49083.patch: fix crash when loading a PKCS#7
      bundle with no certificates in
      src/cryptography/hazmat/backends/openssl/backend.py,
      tests/hazmat/primitives/test_pkcs7.py.
    - CVE-2023-49083

 -- Marc Deslauriers <email address hidden> Mon, 04 Dec 2023 14:58:43 -0500

CVE-2023-23931 cryptography is a package designed to expose cryptographic primitives and recipes to Python developers. In affected versions `Cipher.update_into` wou
CVE-2023-49083 cryptography is a package designed to expose cryptographic primitives and recipes to Python developers. Calling `load_pem_pkcs7_certificates` or `loa



About   -   Send Feedback to @ubuntu_updates