UbuntuUpdates.org

Package "postgresql-9.5"

Name: postgresql-9.5

Description:

This package is just an umbrella for a group of other packages, it has no description.
Description samples from packages in group:

  • PL/Perl procedural language for PostgreSQL 9.5
  • PL/Python procedural language for PostgreSQL 9.5
  • PL/Python 3 procedural language for PostgreSQL 9.5
  • PL/Tcl procedural language for PostgreSQL 9.5

Latest version: 9.5.11-0ubuntu0.16.04
Release: xenial (16.04)
Level: updates
Repository: universe

Links

Save this URL for the latest version of "postgresql-9.5": https://www.ubuntuupdates.org/postgresql-9.5



Other versions of "postgresql-9.5" in Xenial

Repository Area Version
base main 9.5.2-1
base universe 9.5.2-1
security main 9.5.11-0ubuntu0.16.04
security universe 9.5.11-0ubuntu0.16.04
updates main 9.5.11-0ubuntu0.16.04
PPA: Postgresql 9.5.7-1.pgdg12.4+1
PPA: Postgresql 9.5.11-1.pgdg16.04+1
PPA: Postgresql 9.5.11-1.pgdg14.04+1

Packages in group

Deleted packages are displayed in grey.

postgresql-plperl-9.5 postgresql-plpython-9.5 postgresql-plpython3-9.5 postgresql-pltcl-9.5 postgresql-server-dev-9.5

Changelog

Version: 9.5.11-0ubuntu0.16.04 2018-02-09 15:06:40 UTC

  postgresql-9.5 (9.5.11-0ubuntu0.16.04) xenial-security; urgency=medium

  * New upstream release (LP: #1747676)
    - Ensure that all temporary files made by pg_upgrade are non-world-readable
      (CVE-2018-1053)
    - Details about other changes at full changelog:
      https://www.postgresql.org/docs/9.5/static/release-9-5-11.html

 -- Christian Ehrhardt <email address hidden> Tue, 06 Feb 2018 15:20:02 +0100

Source diff to previous version
1747676 New upstream microreleases 9.3.21, 9.5.11 and 9.6.7
CVE-2018-1053 Ensure that all temp files made during pg_upgrade are non-world-readable

Version: 9.5.10-0ubuntu0.16.04 2017-11-14 17:06:55 UTC

  postgresql-9.5 (9.5.10-0ubuntu0.16.04) xenial-security; urgency=medium

  * New upstream release (LP: #1730661)
    - Previously, a race condition allowed some table rows to be omitted from
      the index. It may be necessary to reindex existing BRIN indexes to
      recover from past occurrences of this problem.
    - Details about other changes at full changelog:
      https://www.postgresql.org/docs/9.5/static/release-9-5-10.html

 -- Christian Ehrhardt <email address hidden> Tue, 07 Nov 2017 14:33:50 +0100

Source diff to previous version
1730661 New upstream microreleases 9.3.20, 9.5.10 and 9.6.6

Version: 9.5.9-0ubuntu0.16.04 2017-09-28 19:07:18 UTC

  postgresql-9.5 (9.5.9-0ubuntu0.16.04) xenial; urgency=medium

  * New upstream release (LP: #1713979)
    - fix upgrade regressions of the former security release
    - Details about other changes at full changelog:
      https://www.postgresql.org/docs/9.5/static/release-9-5-9.html

 -- Christian Ehrhardt <email address hidden> Wed, 30 Aug 2017 13:01:13 +0200

Source diff to previous version
1713979 New upstream microreleases 9.3.19, 9.5.9 and 9.6.5

Version: 9.5.8-0ubuntu0.16.04.1 2017-08-15 19:06:41 UTC

  postgresql-9.5 (9.5.8-0ubuntu0.16.04.1) xenial-security; urgency=medium

  * SECURITY UPDATE: Update to 9.5.8 to fix security issues
    - Further restrict visibility of pg_user_mappings.umoptions, to protect
      passwords stored as user mapping options (CVE-2017-7547)
    - Disallow empty passwords in all password-based authentication methods
      (CVE-2017-7546)
    - Make lo_put() check for UPDATE privilege on the target large object
      (CVE-2017-7548)

 -- Marc Deslauriers <email address hidden> Mon, 14 Aug 2017 08:45:32 -0400

Source diff to previous version

Version: 9.5.7-0ubuntu0.16.04 2017-05-29 16:06:42 UTC

  postgresql-9.5 (9.5.7-0ubuntu0.16.04) xenial; urgency=medium

  * New upstream release (LP: #1690730)
    - Restrict visibility of pg_user_mappings.umoptions, to protect passwords
      stored as user mapping options (CVE-2017-7486)
    - Prevent exposure of statistical information via leaky operators
      (CVE-2017-7484)
    - Restore libpq's recognition of the PGREQUIRESSL environment variable
      (CVE-2017-7485)

    - A dump/restore is not required for those running 9.5.X.
    - However, if you use foreign data servers that make use of user passwords
      for authentication, see the first changelog entry.
    - Also, if you are using third-party replication tools that depend on
      "logical decoding", see the fourth changelog entry.

    - Details about other changes at full changelog:
      https://www.postgresql.org/docs/9.5/static/release-9-5-7.html

 -- Christian Ehrhardt <email address hidden> Mon, 15 May 2017 08:46:07 +0200

1690730 New upstream microreleases 9.3.17, 9.5.7 and 9.6.3
CVE-2017-7486 PostgreSQL versions 8.4 - 9.6 are vulnerable to information leak in pg_user_mappings view which discloses foreign server passwords to any user having
CVE-2017-7484 It was found that some selectivity estimation functions in PostgreSQL before 9.2.21, 9.3.x before 9.3.17, 9.4.x before 9.4.12, 9.5.x before 9.5.7, an
CVE-2017-7485 In PostgreSQL 9.3.x before 9.3.17, 9.4.x before 9.4.12, 9.5.x before 9.5.7, and 9.6.x before 9.6.3, it was found that the PGREQUIRESSL environment va



About   -   Send Feedback to @ubuntu_updates