UbuntuUpdates.org

Package "postgresql-9.5"

Name: postgresql-9.5

Description:

This package is just an umbrella for a group of other packages, it has no description.
Description samples from packages in group:

  • PL/Perl procedural language for PostgreSQL 9.5
  • PL/Python procedural language for PostgreSQL 9.5
  • PL/Python 3 procedural language for PostgreSQL 9.5
  • PL/Tcl procedural language for PostgreSQL 9.5

Latest version: 9.5.14-0ubuntu0.16.04
Release: xenial (16.04)
Level: security
Repository: universe

Links

Save this URL for the latest version of "postgresql-9.5": https://www.ubuntuupdates.org/postgresql-9.5



Other versions of "postgresql-9.5" in Xenial

Repository Area Version
base main 9.5.2-1
base universe 9.5.2-1
security main 9.5.14-0ubuntu0.16.04
updates main 9.5.14-0ubuntu0.16.04
updates universe 9.5.14-0ubuntu0.16.04
PPA: Postgresql 9.5.7-1.pgdg12.4+1
PPA: Postgresql 9.5.14-1.pgdg14.04+1
PPA: Postgresql 9.5.14-1.pgdg18.04+1
PPA: Postgresql 9.5.14-1.pgdg16.04+1

Packages in group

Deleted packages are displayed in grey.


Changelog

Version: 9.5.14-0ubuntu0.16.04 2018-08-17 02:33:36 UTC

  postgresql-9.5 (9.5.14-0ubuntu0.16.04) xenial-security; urgency=medium

  * New upstream release (LP: #1786938)
    - Fix failure to reset libpq's state fully between connection attempts
      .
      An unprivileged user of dblink or postgres_fdw could bypass the checks
      intended to prevent use of server-side credentials, such as a ~/.pgpass
      file owned by the operating-system user running the server. Servers
      allowing peer authentication on local connections are particularly
      vulnerable. Other attacks such as SQL injection into a postgres_fdw
      session are also possible. Attacking postgres_fdw in this way requires
      the ability to create a foreign server object with selected connection
      parameters, but any user with access to dblink could exploit the
      problem. In general, an attacker with the ability to select the
      connection parameters for a libpq-using application could cause
      mischief, though other plausible attack scenarios are harder to think
      of. Our thanks to Andrew Krasichkov for reporting this issue.
      (CVE-2018-10915)
    - Fix INSERT ... ON CONFLICT UPDATE through a view that isn't just SELECT
      FROM ...
      .
      Erroneous expansion of an updatable view could lead to crashes or
      attribute ... has the wrong type errors, if the view's SELECT list
      doesn't match one-to-one with the underlying table's columns.
      Furthermore, this bug could be leveraged to allow updates of columns
      that an attacking user lacks UPDATE privilege for, if that user has
      INSERT and UPDATE privileges for some other column(s) of the table. Any
      user could also use it for disclosure of server memory.
      (CVE-2018-10925)
    - d/libecpg-dev.install: Add new pgtypes header.
    - d/libpgtypes3.symbols: Add new pgtypes symbol.
    - Details about these and changes can be found at
      https://www.postgresql.org/docs/9.5/static/release-9-5-14.html

 -- Christian Ehrhardt <email address hidden> Tue, 14 Aug 2018 14:49:16 +0200

Source diff to previous version
1786938 New upstream microreleases 9.3.24, 9.5.14, and 10.5
CVE-2018-10915 A vulnerability was found in libpq, the default PostgreSQL client library where libpq failed to properly reset its internal state between connections
CVE-2018-10925 It was discovered that PostgreSQL versions before 10.5, 9.6.10, 9.5.14, 9.4.19, and 9.3.24 failed to properly check authorization on certain statemen

Version: 9.5.12-0ubuntu0.16.04 2018-03-06 17:07:26 UTC

  postgresql-9.5 (9.5.12-0ubuntu0.16.04) xenial-security; urgency=medium

  * New upstream release (LP: #1752271)
    If you run an installation in which not all users are mutually
    trusting, or if you maintain an application or extension that is
    intended for use in arbitrary situations, it is strongly recommended
    that you read the documentation changes described in the first changelog
    entry below, and take suitable steps to ensure that your installation or
    code is secure.

    Also, the changes described in the second changelog entry below may
    cause functions used in index expressions or materialized views to fail
    during auto-analyze, or when reloading from a dump. After upgrading,
    monitor the server logs for such problems, and fix affected functions.

    - Document how to configure installations and applications to guard
      against search-path-dependent trojan-horse attacks from other users

      Using a search_path setting that includes any schemas writable by a
      hostile user enables that user to capture control of queries and then
      run arbitrary SQL code with the permissions of the attacked user. While
      it is possible to write queries that are proof against such hijacking,
      it is notationally tedious, and it's very easy to overlook holes.
      Therefore, we now recommend configurations in which no untrusted schemas
      appear in one's search path.
      (CVE-2018-1058)

    - Avoid use of insecure search_path settings in pg_dump and other client
      programs

      pg_dump, pg_upgrade, vacuumdb and other PostgreSQL-provided applications
      were themselves vulnerable to the type of hijacking described in the
      previous changelog entry; since these applications are commonly run by
      superusers, they present particularly attractive targets. To make them
      secure whether or not the installation as a whole has been secured,
      modify them to include only the pg_catalog schema in their search_path
      settings. Autovacuum worker processes now do the same, as well.

      In cases where user-provided functions are indirectly executed by these
      programs -- for example, user-provided functions in index expressions --
      the tighter search_path may result in errors, which will need to be
      corrected by adjusting those user-provided functions to not assume
      anything about what search path they are invoked under. That has always
      been good practice, but now it will be necessary for correct behavior.
      (CVE-2018-1058)

    - Details about other changes can be found at
      https://www.postgresql.org/docs/9.5/static/release-9-5-12.html

 -- Christian Ehrhardt <email address hidden> Wed, 28 Feb 2018 09:59:08 +0100

Source diff to previous version
1752271 New upstream microreleases 9.3.22, 9.5.12, 9.6.8 and 10.3
CVE-2018-1058 A flaw was found in the way Postgresql allowed a user to modify the behavior of a query for other users. An attacker with a user account could use th

Version: 9.5.11-0ubuntu0.16.04 2018-02-09 14:06:46 UTC

  postgresql-9.5 (9.5.11-0ubuntu0.16.04) xenial-security; urgency=medium

  * New upstream release (LP: #1747676)
    - Ensure that all temporary files made by pg_upgrade are non-world-readable
      (CVE-2018-1053)
    - Details about other changes at full changelog:
      https://www.postgresql.org/docs/9.5/static/release-9-5-11.html

 -- Christian Ehrhardt <email address hidden> Tue, 06 Feb 2018 15:20:02 +0100

Source diff to previous version
1747676 New upstream microreleases 9.3.21, 9.5.11 and 9.6.7
CVE-2018-1053 Ensure that all temp files made during pg_upgrade are non-world-readable

Version: 9.5.10-0ubuntu0.16.04 2017-11-14 14:06:51 UTC

  postgresql-9.5 (9.5.10-0ubuntu0.16.04) xenial-security; urgency=medium

  * New upstream release (LP: #1730661)
    - Previously, a race condition allowed some table rows to be omitted from
      the index. It may be necessary to reindex existing BRIN indexes to
      recover from past occurrences of this problem.
    - Details about other changes at full changelog:
      https://www.postgresql.org/docs/9.5/static/release-9-5-10.html

 -- Christian Ehrhardt <email address hidden> Tue, 07 Nov 2017 14:33:50 +0100

Source diff to previous version
1730661 New upstream microreleases 9.3.20, 9.5.10 and 9.6.6

Version: 9.5.8-0ubuntu0.16.04.1 2017-08-15 18:06:37 UTC

  postgresql-9.5 (9.5.8-0ubuntu0.16.04.1) xenial-security; urgency=medium

  * SECURITY UPDATE: Update to 9.5.8 to fix security issues
    - Further restrict visibility of pg_user_mappings.umoptions, to protect
      passwords stored as user mapping options (CVE-2017-7547)
    - Disallow empty passwords in all password-based authentication methods
      (CVE-2017-7546)
    - Make lo_put() check for UPDATE privilege on the target large object
      (CVE-2017-7548)

 -- Marc Deslauriers <email address hidden> Mon, 14 Aug 2017 08:45:32 -0400




About   -   Send Feedback to @ubuntu_updates