UbuntuUpdates.org

Package "postgresql-14"




Name: postgresql-14

Description:

This package is just an umbrella for a group of other packages, it has no description.
Description samples from packages in group:

  • development files for PostgreSQL 14 server-side programming

Latest version: *DELETED*
Release: jammy (22.04)
Level: proposed
Repository: universe

Links



Other versions of "postgresql-14" in Jammy

Repository Area Version
base universe 14.2-1ubuntu1
base main 14.2-1ubuntu1
security main 14.5-0ubuntu0.22.04.1
security universe 14.5-0ubuntu0.22.04.1
updates universe 14.6-0ubuntu0.22.04.1
updates main 14.6-0ubuntu0.22.04.1
PPA: Postgresql 14.6-1.pgdg20.04+1
PPA: Postgresql 14.6-1.pgdg18.04+1
PPA: Postgresql 14.6-1.pgdg22.04+1

Packages in group

Deleted packages are displayed in grey.


Changelog

Version: *DELETED* 2023-01-18 01:08:06 UTC
No changelog for deleted or moved packages.

Version: 14.6-0ubuntu0.22.04.1 2022-12-13 23:07:18 UTC

  postgresql-14 (14.6-0ubuntu0.22.04.1) jammy; urgency=medium

  * New upstream version (LP: #1996770).

    + A dump/restore is not required for those running 14.X.

    + Also, if you are upgrading from a version earlier than 14.4, see
      those release notes as well please.

    + Disallow rules named _RETURN that are not ON SELECT rules (Tom Lane).

    + Fix use-after-free hazard in string comparisons. (Tom Lane)

    + Details about these and many further changes can be found at:
      https://www.postgresql.org/docs/14/release-14-6.html

 -- Athos Ribeiro <email address hidden> Thu, 17 Nov 2022 17:11:29 -0300

1996770 New upstream microreleases 10.23, 12.13 and 14.6

Version: *DELETED* 2022-07-07 10:06:52 UTC
No changelog for deleted or moved packages.

Version: 14.4-0ubuntu0.22.04.1 2022-06-22 01:06:19 UTC

  postgresql-14 (14.4-0ubuntu0.22.04.1) jammy; urgency=medium

  * New upstream version (LP: #1978249).

    + A dump/restore is not required for those running 14.X.

    + However, if you have any indexes that were created using the
      CONCURRENTLY option under 14.X, you should re-index them after
      updating. See the upstream changelog linked below for further
      information.

    + Also, if you are upgrading from a version earlier than 14.3, see
      those release notes as well please.

    + Prevent possible corruption of indexes created or rebuilt with the
      CONCURRENTLY option (Álvaro Herrera).

      An optimization added in v14 caused CREATE INDEX ... CONCURRENTLY
      and REINDEX ... CONCURRENTLY to sometimes miss indexing rows that were
      updated during the index build. Revert that optimization. It is
      recommended that any indexes made with the CONCURRENTLY option be
      rebuilt after installing this update. (Alternatively, rebuild them
      without CONCURRENTLY.)

    + Details about these and many further changes can be found at:
      https://www.postgresql.org/docs/14/release-14-4.html

 -- Sergio Durigan Junior <email address hidden> Fri, 17 Jun 2022 12:00:44 -0400

1978249 New upstream microrelease 14.4



About   -   Send Feedback to @ubuntu_updates