UbuntuUpdates.org

Package "ubuntu-release-upgrader"

Name: ubuntu-release-upgrader

Description:

This package is just an umbrella for a group of other packages, it has no description.
Description samples from packages in group:

  • manage release upgrades
  • manage release upgrades
  • manage release upgrades

Latest version: 1:18.04.38
Release: bionic (18.04)
Level: updates
Repository: main

Links



Other versions of "ubuntu-release-upgrader" in Bionic

Repository Area Version
base main 1:18.04.17
base universe 1:18.04.17
updates universe 1:18.04.38
proposed main 1:18.04.39
proposed universe 1:18.04.39

Packages in group

Deleted packages are displayed in grey.


Changelog

Version: 1:18.04.38 2020-07-28 18:07:11 UTC

  ubuntu-release-upgrader (1:18.04.38) bionic; urgency=medium

  * Update mirrors data and apt_btrfs_snapshot for the 18.04.5 point release.

 -- Brian Murray <email address hidden> Thu, 09 Jul 2020 15:58:12 -0700

Source diff to previous version

Version: 1:18.04.37 2020-01-30 11:07:08 UTC

  ubuntu-release-upgrader (1:18.04.37) bionic; urgency=medium

  * Update mirrors data and apt_btrfs_snapshot for the 18.04.4 point release.

 -- Brian Murray <email address hidden> Fri, 24 Jan 2020 03:47:07 -0800

Source diff to previous version

Version: 1:18.04.36 2019-11-20 21:07:07 UTC

  ubuntu-release-upgrader (1:18.04.36) bionic; urgency=medium

  * do-release-upgrade: add linux-base to the check for required reboot after
    a kernel upgrade (LP: #1844805).

Source diff to previous version
1844805 virtualbox, virtualbox-dkms, virtualbox-qt fail during upgrade from 19.04 to 19.10

Version: 1:18.04.34 2019-07-01 13:07:42 UTC

  ubuntu-release-upgrader (1:18.04.34) bionic; urgency=medium

  * DistUpgrade/DistUpgradeQuirks.py: only try to install snaps if snapstore
    is reachable. (LP: #1831933)

 -- Dan Streetman <email address hidden> Wed, 19 Jun 2019 12:49:56 -0400

Source diff to previous version
1831933 do-release-upgrade tries to install snaps even if it knows it can't reach the snapstore

Version: 1:18.04.33 2019-05-22 17:06:46 UTC

  ubuntu-release-upgrader (1:18.04.33) bionic; urgency=medium

  * DistUpgrade/DistUpgradeViewNonInteractive.py: when responding to a
    conffile prompt with "n" use bytes not a string. (LP: #1796193)
  * debian/control: add an explicit python3-distro-info dependency to
    python3-distupgrade as it is now required by DistUpgradeController.
    (LP: #1824866)
  * pre-build.sh: stop updating demotions for artful since it is no longer
    available at archive.ubuntu.com and if we do update then demotions becomes
    an empty file which is wrong.

 -- Brian Murray <email address hidden> Wed, 15 May 2019 10:37:15 -0700

1796193 DistUpgradeViewNonInteractive crashes / requires interaction
1824866 python3-distupgrade missing a dep on python3-distro-info



About   -   Send Feedback to @ubuntu_updates