UbuntuUpdates.org

Package "ubuntu-release-upgrader"

Name: ubuntu-release-upgrader

Description:

This package is just an umbrella for a group of other packages, it has no description.
Description samples from packages in group:

  • manage release upgrades

Latest version: 1:18.04.27
Release: bionic (18.04)
Level: updates
Repository: universe

Links

Save this URL for the latest version of "ubuntu-release-upgrader": https://www.ubuntuupdates.org/ubuntu-release-upgrader



Other versions of "ubuntu-release-upgrader" in Bionic

Repository Area Version
base universe 1:18.04.17
base main 1:18.04.17
updates main 1:18.04.27

Packages in group

Deleted packages are displayed in grey.


Changelog

Version: 1:18.04.27 2018-10-17 15:06:29 UTC

  ubuntu-release-upgrader (1:18.04.27) bionic; urgency=medium

  * do-release-upgrade: do not run the release upgrade if either not all
    updates are installed or a reboot is required due to a libc6 upgrade.
    (LP: #1797209)
  * debian/control: change ubuntu-release-upgrader-core to depend on
    ca-certificates (LP: #1796940)
  * Update mirrors data.

 -- Brian Murray <email address hidden> Fri, 12 Oct 2018 11:27:19 -0700

Source diff to previous version
1797209 do-release-upgrade should block release upgrades in some circumstances
1796940 ubuntu-release-upgrader-core missing a dependency

Version: 1:18.04.26 2018-09-28 02:07:12 UTC

  ubuntu-release-upgrader (1:18.04.26) bionic; urgency=medium

  * DistUpgradeController.py: If the attempt to only upgrade libc6 ends up
    creating an issue with apt's problem resolver try the full upgrade. This
    is what would have happened before the fix for bug 1766890. (LP: #1787649)

 -- Brian Murray <email address hidden> Wed, 05 Sep 2018 08:37:51 -0700

Source diff to previous version
1787649 ubuntu-release-upgrader crashed with SystemError: E:Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

Version: 1:18.04.25 2018-08-29 19:06:53 UTC

  ubuntu-release-upgrader (1:18.04.25) bionic; urgency=medium

  * DistUpgradeQuirks.py: if ubuntu-desktop or snapd isn't in the package
    cache don't try and run the quirk for installing or upgrading snaps.
    (LP: #1787668)

 -- Brian Murray <email address hidden> Tue, 28 Aug 2018 15:46:57 -0700

Source diff to previous version
1787668 ubuntu-release-upgrader crashed with KeyError: \

Version: 1:18.04.24 2018-08-13 17:07:09 UTC

  ubuntu-release-upgrader (1:18.04.24) bionic; urgency=medium

  * DistUpgradeController.py: Remove an unnecessary debugging entry when
    calculating the debs to remove.

Source diff to previous version

Version: 1:18.04.22 2018-08-09 17:06:26 UTC

  ubuntu-release-upgrader (1:18.04.22) bionic; urgency=medium

  * DistUpgradeQuirks.py:
    - make sure that snapd is installed before trying to use it.
      (LP: #1783589)
    - update the view with information regarding the progress of snaps being
      installed. (LP: #1783593)
    - when checking for connectivity to the snap store use C.UTF-8 for the
      language so error message matching works. (LP: #1783738)
  * DistUpgradeController.py:
    - Remove debs from apt's "Dir::Cache::archives" folder after the upgrade
      has completed successfully. (LP: #1785096)
    - Add a telemetry marker to report the time to process the migration from
      deb to snaps.

 -- Brian Murray <email address hidden> Thu, 02 Aug 2018 11:20:06 -0700

1783589 ubuntu-release-upgrader crashes if snapd is not installed
1783593 UI frozen and no information when the upgrader is installing snap packages
1783738 _checkStoreConnectivity uses translatable strings for error checking
1785096 dist-upgrader should clean up downloaded debs



About   -   Send Feedback to @ubuntu_updates