UbuntuUpdates.org

Package "libstd-rust-dev"

This package belongs to a PPA: Ubuntu Mozilla Security

Name: libstd-rust-dev

Description:

Rust standard libraries - development files

Latest version: 1.31.0+dfsg1+llvm-2ubuntu1~14.04.1
Release: trusty (14.04)
Level: base
Repository: main
Head package: rustc

Links

Save this URL for the latest version of "libstd-rust-dev": https://www.ubuntuupdates.org/libstd-rust-dev


Download "libstd-rust-dev"


Other versions of "libstd-rust-dev" in Trusty

Repository Area Version
security universe 1.31.0+dfsg1+llvm-2ubuntu1~14.04.1
updates universe 1.31.0+dfsg1+llvm-2ubuntu1~14.04.1

Changelog

Version: 1.31.0+dfsg1+llvm-2ubuntu1~14.04.1 2019-03-15 13:07:53 UTC

 rustc (1.31.0+dfsg1+llvm-2ubuntu1~14.04.1) trusty; urgency=medium
 .
   * Backport 1.30.0 to trusty
   * Relax the gdb build requirement
     - update debian/control
   * Relax the dependency on xz-utils by commenting out some unused code
     - add debian/patches/d-relax-xz-utils-dependency.patch
     - update debian/patches/series
   * Relax dpkg-dev requirement to 1.17.5
    - update debian/control
   * Relax binutils requirement. Even though previous uploads have depended
     on a binutils-2.26, we've never actually used it
     - update debian/control

Source diff to previous version

Version: 1.30.0+dfsg1+llvm-2ubuntu1~14.04.1 2018-12-05 16:08:02 UTC

 rustc (1.30.0+dfsg1+llvm-2ubuntu1~14.04.1) trusty; urgency=medium
 .
   * Backport 1.30.0 to trusty
   * Relax the gdb build requirement
     - update debian/control
   * Relax the dependency on xz-utils by commenting out some unused code
     - add debian/patches/d-relax-xz-utils-dependency.patch
     - update debian/patches/series
   * Relax dpkg-dev requirement to 1.17.5
    - update debian/control
   * Relax binutils requirement. Even though previous uploads have depended
     on a binutils-2.26, we've never actually used it
     - update debian/control

Source diff to previous version

Version: 1.28.0+dfsg1+llvm-0ubuntu1~14.04.1 2018-10-16 18:08:16 UTC

 rustc (1.28.0+dfsg1+llvm-0ubuntu1~14.04.1) trusty; urgency=medium
 .
   * Backport 1.28.0 to trusty
   * Relax the gdb build requirement
     - update debian/control
   * Relax the dependency on xz-utils by commenting out some unused code
     - add debian/patches/d-relax-xz-utils-dependency.patch
     - update debian/patches/series
   * Relax dpkg-dev requirement to 1.17.5
    - update debian/control
   * Relax binutils requirement. Even though previous uploads have depended
     on a binutils-2.26, we've never actually used it
     - update debian/control


Version: *DELETED* 2018-09-17 14:08:49 UTC
No changelog for deleted or moved packages.

Version: 1.25.0+dfsg1+llvm-0ubuntu1~14.04.1 2018-07-03 10:09:30 UTC

 rustc (1.25.0+dfsg1+llvm-0ubuntu1~14.04.1) trusty; urgency=medium
 .
   * Backport 1.25.0 to trusty
   * Relax the gdb requirement and don't build-conflict on gdb-minimal
     - update debian/control
   * Relax the dependency on xz-utils by commenting out some unused code
     - add debian/patches/d-relax-xz-utils-dependency.patch
     - update debian/patches/series
     - update debian/rules
   * Relax dpkg-dev requirement to 1.17.5
    - update debian/control
   * Relax binutils requirement. Even though previous uploads have depended
     on a binutils-2.26, we've never actually used it
     - update debian/rules
   * Don't compile with -Wno-misleading-indentation, which doesn't exist in
     GCC 4.8
   * Don't pass -march=native to GCC on Aarch64, as it's not supported with
     GCC 4.8
     - add debian/patches/d-dont-pass-march-native-on-aarch64.patch
     - update debian/patches/series




About   -   Send Feedback to @ubuntu_updates