UbuntuUpdates.org

Package "rustc"

This package belongs to a PPA: Ubuntu Mozilla Security

Name: rustc

Description:

Rust systems programming language

Latest version: 1.24.1+dfsg1+llvm-0ubuntu1~14.04.1
Release: trusty (14.04)
Level: base
Repository: main

Links

Save this URL for the latest version of "rustc": https://www.ubuntuupdates.org/rustc


Download "rustc"


Other versions of "rustc" in Trusty

Repository Area Version
security universe 1.24.1+dfsg1+llvm-0ubuntu1~14.04.1
updates universe 1.24.1+dfsg1+llvm-0ubuntu1~14.04.1

Packages in group

Deleted packages are displayed in grey.

libstd-rust-1.15 libstd-rust-1.17 libstd-rust-1.19 libstd-rust-1.21 libstd-rust-1.22
libstd-rust-1.24 libstd-rust-dev rust-doc rust-gdb rust-lldb
rust-src

Changelog

Version: 1.24.1+dfsg1+llvm-0ubuntu1~14.04.1 2018-05-09 20:08:54 UTC

 rustc (1.24.1+dfsg1+llvm-0ubuntu1~14.04.1) trusty; urgency=medium
 .
   * Backport 1.24.1 to trusty
   * Relax the gdb requirement and don't build-conflict on gdb-minimal
     - update debian/control
   * Relax the dependency on xz-utils by commenting out some unused code
     - add debian/patches/d-relax-xz-utils-dependency.patch
     - update debian/patches/series
     - update debian/rules
   * Relax dpkg-dev requirement to 1.17.5
    - update debian/control
   * Relax binutils requirement. Even though previous uploads have depended
     on a binutils-2.26, we've never actually used it
     - update debian/rules
   * Don't compile with -Wno-misleading-indentation, which doesn't exist in
     GCC 4.8
   * Revert "Create xz/gz files in parallel" in rust-installer to fix "capacity
     overflow" panic on 32-bit builds
     - add debian/patches/d-no-parallel-tarball-generation.patch
     - update debian/patches/series
   * Don't pass -march=native to GCC on Aarch64, as it's not supported with
     GCC 4.8
     - add debian/patches/d-dont-pass-march-native-on-aarch64.patch
     - update debian/patches/series

Source diff to previous version

Version: 1.22.1+dfsg1+llvm-0ubuntu2~14.04.2 2018-03-13 00:08:31 UTC

 rustc (1.22.1+dfsg1+llvm-0ubuntu2~14.04.2) trusty; urgency=medium
 .
   * Backport 1.22.1 to trusty
   * Build-depend on rustc <= 1.22.1++
   * Relax the gdb requirement and don't build-conflict on gdb-minimal
     - update debian/control
   * Relax the dependency on xz-utils by commenting out some unused code
     - add debian/patches/d-relax-xz-utils-dependency.patch
     - update debian/patches/series
     - update debian/rules
   * Relax dpkg-dev requirement to 1.17.5
    - update debian/control
   * Relax binutils requirement. Even though previous uploads have depended
     on a binutils-2.26, we've never actually used it
     - update debian/rules

Source diff to previous version

Version: 1.21.0+dfsg1+llvm-0ubuntu3~14.04.5 2018-01-22 22:08:23 UTC

 rustc (1.21.0+dfsg1+llvm-0ubuntu3~14.04.5) trusty; urgency=medium
 .
   * Backport 1.21.0 to trusty
 .
   * Relax the gdb requirement and don't build-conflict on gdb-minimal
     - update debian/control
   * Relax the dependency on xz-utils by commenting out some unused code
     - add debian/patches/d-relax-xz-utils-dependency.patch
     - update debian/patches/series
     - update debian/rules
   * Relax dpkg-dev requirement to 1.17.5
    - update debian/control
   * Relax binutils requirement. Even though previous uploads have depended
     on a binutils-2.26, we've never actually used it
     - update debian/rules
   * Set build.full-bootstrap to true to work-around a runtime link failure
     when we're bootstrapping from the same rust version
     - update debian/config.toml.in
   * Don't build with debuginfo for now, to avoid running out of address space
     on x86
     - update debian/config.toml.in

Source diff to previous version

Version: 1.19.0+dfsg3-3ubuntu1~14.04.1 2017-11-09 23:08:49 UTC

 rustc (1.19.0+dfsg3-3ubuntu1~14.04.1) trusty; urgency=medium
 .
   * Backport 1.19.0 to xenial
   * Relax llvm-toolchain-4.0 build dependency
   * Relax the gdb requirement and don't build-conflict on gdb-minimal
   * Relax the dependency on xz-utils by commenting out some unused code
     - add debian/patches/d-relax-xz-utils-dependency.patch
     - update debian/patches/series
     - update debian/rules
   * Relax dpkg-dev requirement to 1.17.5
   * Don't build-Depend on nodejs on arm64, as it doesn't exist
   * Build-depend on libllvm4.0v4 rather than libllvm4.0
   * Make rustc depend on binutils-2.26

Source diff to previous version

Version: 1.17.0+dfsg2-8~ubuntu0.14.04.3 2017-09-21 23:08:56 UTC

 rustc (1.17.0+dfsg2-8~ubuntu0.14.04.3) trusty; urgency=medium
 .
   * Backport 1.17.0 to trusty
   * Relax llvm-toolchain-3.9 requirement to 1:3.9.1-4~
   * Relax the gdb requirement and don't build-conflict on gdb-minimal
   * Relax dpkg-dev requirement to 1.17.5
   * Don't build-Depend on nodejs on arm64, as it doesn't exist
   * Make rustc depend on binutils-2.26
   * Build-depend on libllvm3.9v4 rather than libllvm3.9




About   -   Send Feedback to @ubuntu_updates