UbuntuUpdates.org

Package "samba"

Name: samba

Description:

SMB/CIFS file, print, and login server for Unix

Latest version: 2:4.3.11+dfsg-0ubuntu0.16.04.13
Release: xenial (16.04)
Level: updates
Repository: main
Homepage: http://www.samba.org

Links

Save this URL for the latest version of "samba": https://www.ubuntuupdates.org/samba


Download "samba"


Other versions of "samba" in Xenial

Repository Area Version
base main 2:4.3.8+dfsg-0ubuntu1
base universe 2:4.3.8+dfsg-0ubuntu1
security main 2:4.3.11+dfsg-0ubuntu0.16.04.13
security universe 2:4.3.11+dfsg-0ubuntu0.16.04.13
updates universe 2:4.3.11+dfsg-0ubuntu0.16.04.13

Packages in group

Deleted packages are displayed in grey.

libnss-winbind libpam-winbind libparse-pidl-perl libsmbclient libsmbclient-dev
libwbclient-dev libwbclient0 python-samba samba-common samba-common-bin
samba-dbg samba-dev samba-dsdb-modules samba-libs samba-vfs-modules
smbclient winbind

Changelog

Version: 2:4.3.11+dfsg-0ubuntu0.16.04.13 2018-03-13 15:06:21 UTC

  samba (2:4.3.11+dfsg-0ubuntu0.16.04.13) xenial-security; urgency=medium

  * SECURITY UPDATE: Denial of Service Attack on external print server
    - debian/patches/CVE-2018-1050.patch: protect against null pointer
      derefs in source3/rpc_server/spoolss/srv_spoolss_nt.c.
    - CVE-2018-1050
  * SECURITY UPDATE: Authenticated users can change other users password
    - debian/patches/CVE-2018-1057-*.patch: fix password changing logic.
    - CVE-2018-1057

 -- Marc Deslauriers <email address hidden> Tue, 06 Mar 2018 16:49:12 +0100

Source diff to previous version

Version: 2:4.3.11+dfsg-0ubuntu0.16.04.12 2017-11-21 16:07:02 UTC

  samba (2:4.3.11+dfsg-0ubuntu0.16.04.12) xenial-security; urgency=medium

  * SECURITY UPDATE: Use-after-free vulnerability
    - debian/patches/CVE-2017-14746.patch: fix use-after-free crash bug in
      source3/smbd/process.c, source3/smbd/reply.c.
    - CVE-2017-14746
  * SECURITY UPDATE: Server heap memory information leak
    - debian/patches/CVE-2017-15275.patch: zero out unused grown area in
      source3/smbd/srvstr.c.
    - CVE-2017-15275

 -- Marc Deslauriers <email address hidden> Wed, 15 Nov 2017 15:40:44 -0500

Source diff to previous version
CVE-2017-14746 Use-after-free vulnerability
CVE-2017-15275 Server heap memory information leak

Version: 2:4.3.11+dfsg-0ubuntu0.16.04.11 2017-09-21 20:06:21 UTC
No changelog available yet.
Source diff to previous version

Version: 2:4.3.11+dfsg-0ubuntu0.16.04.10 2017-08-31 20:07:10 UTC
No changelog available yet.
Source diff to previous version

Version: 2:4.3.11+dfsg-0ubuntu0.16.04.9 2017-07-14 22:07:09 UTC

  samba (2:4.3.11+dfsg-0ubuntu0.16.04.9) xenial-security; urgency=medium

  * SECURITY UPDATE: KDC-REP service name impersonation
    - debian/patches/CVE-2017-11103.patch: use encrypted service
      name rather than unencrypted (and therefore spoofable) version
      in heimdal
    - CVE-2017-11103

 -- Steve Beattie <email address hidden> Thu, 13 Jul 2017 14:03:40 -0700

CVE-2017-1110 RESERVED



About   -   Send Feedback to @ubuntu_updates