UbuntuUpdates.org

Package "dovecot"

Name: dovecot

Description:

This package is just an umbrella for a group of other packages, it has no description.
Description samples from packages in group:

  • secure POP3/IMAP server - core files
  • secure POP3/IMAP server - debug symbols
  • secure POP3/IMAP server - header files
  • secure POP3/IMAP server - IMAP daemon

Latest version: 1:2.2.22-1ubuntu2.13
Release: xenial (16.04)
Level: updates
Repository: main

Links



Other versions of "dovecot" in Xenial

Repository Area Version
base main 1:2.2.22-1ubuntu2
base universe 1:2.2.22-1ubuntu2
security universe 1:2.2.22-1ubuntu2.13
security main 1:2.2.22-1ubuntu2.13
updates universe 1:2.2.22-1ubuntu2.13

Packages in group

Deleted packages are displayed in grey.


Changelog

Version: 1:2.2.22-1ubuntu2.13 2020-08-12 15:07:08 UTC

  dovecot (1:2.2.22-1ubuntu2.13) xenial-security; urgency=medium

  * SECURITY UPDATE: DoS via deeply nested MIME parts
    - debian/patches/CVE-2020-12100/*.patch: backports of upstream patches
      to fix the issue.
    - CVE-2020-12100
  * SECURITY UPDATE: DoS via incorrect NTLM message buffer size
    - debian/patches/CVE-2020-12673/*.patch: check buffer length in
      src/lib-ntlm/ntlm-message.c.
    - CVE-2020-12673
  * SECURITY UPDATE: DoS via zero-length message
    - debian/patches/CVE-2020-12674/*.patch: fail on zero-length buffer in
      src/auth/mech-rpa.c.
    - CVE-2020-12674

 -- Marc Deslauriers <email address hidden> Thu, 06 Aug 2020 09:40:07 -0400

Source diff to previous version

Version: 1:2.2.22-1ubuntu2.12 2019-08-28 22:07:05 UTC

  dovecot (1:2.2.22-1ubuntu2.12) xenial-security; urgency=medium

  * SECURITY REGRESSION: updating CVE-2019-11500-3.patch with the right check

 -- <email address hidden> (Leonidas S. Barbosa) Wed, 28 Aug 2019 13:23:21 -0300

Source diff to previous version

Version: 1:2.2.22-1ubuntu2.11 2019-08-28 15:07:01 UTC

  dovecot (1:2.2.22-1ubuntu2.11) xenial-security; urgency=medium

  * SECURITY UPDATE: IMAP do not properly handled NULL byte - bounds
    heap memory writes
    - debian/patches/CVE-2019-11500-*.patch: doesn't accept strings with
      NULs in src/lib-imap/imap-parser.c and
      pigeonhole/src/lib-managesieve/managesieve-parser.c,
      make sure str_unescape won't be writing past allocated memory
      in src/lib-imap/imap-parser.c and
      pieonhole/src/lig-managesieve/managesieve-parser.c.
    - CVE-2019-11500

 -- <email address hidden> (Leonidas S. Barbosa) Wed, 14 Aug 2019 13:19:55 -0300

Source diff to previous version

Version: 1:2.2.22-1ubuntu2.10 2019-04-01 14:06:16 UTC

  dovecot (1:2.2.22-1ubuntu2.10) xenial-security; urgency=medium

  * SECURITY UPDATE: stack overflow when reading FTS or POP3-UIDL header
    - debian/patches/CVE-2019-7524-2.patch: fix buffer overflow when
      reading oversized fts header in src/plugins/fts/fts-api.c.
    - CVE-2019-7524

 -- Marc Deslauriers <email address hidden> Fri, 29 Mar 2019 08:02:32 -0400

Source diff to previous version
CVE-2019-7524 In Dovecot before 2.2.36.3 and 2.3.x before 2.3.5.1, a local attacker can cause a buffer overflow in the indexer-worker process, which can be used to

Version: 1:2.2.22-1ubuntu2.9 2019-02-05 15:06:59 UTC

  dovecot (1:2.2.22-1ubuntu2.9) xenial-security; urgency=medium

  * SECURITY UPDATE: incorrect client certificate validation
    - debian/patches/CVE-2019-3814-1.patch: do not import empty certificate
      username in src/auth/auth-request.c.
    - debian/patches/CVE-2019-3814-2.patch: fail authentication if
      certificate username was unexpectedly missing in
      src/auth/auth-request-handler.c.
    - debian/patches/CVE-2019-3814-3.patch: ensure we get username from
      certificate in src/login-common/sasl-server.c.
    - CVE-2019-3814

 -- Marc Deslauriers <email address hidden> Mon, 28 Jan 2019 08:53:15 -0500

CVE-2019-3814 Suitable client certificate can be used to login as other user



About   -   Send Feedback to @ubuntu_updates