UbuntuUpdates.org

Package "glib2.0"

Name: glib2.0

Description:

This package is just an umbrella for a group of other packages, it has no description.
Description samples from packages in group:

  • GLib library of C routines
  • Debugging symbols for the GLib libraries
  • Programs for the GLib library
  • Common files for GLib library

Latest version: 2.48.2-0ubuntu4.5
Release: xenial (16.04)
Level: proposed
Repository: main

Links

Save this URL for the latest version of "glib2.0": https://www.ubuntuupdates.org/glib2.0



Other versions of "glib2.0" in Xenial

Repository Area Version
base main 2.48.0-1ubuntu4
base universe 2.48.0-1ubuntu4
security main 2.48.2-0ubuntu4.4
security universe 2.48.2-0ubuntu4.4
updates universe 2.48.2-0ubuntu4.4
updates main 2.48.2-0ubuntu4.4
proposed universe 2.48.2-0ubuntu4.5

Packages in group

Deleted packages are displayed in grey.


Changelog

Version: 2.48.2-0ubuntu4.5 2019-11-22 14:07:04 UTC

  glib2.0 (2.48.2-0ubuntu4.5) xenial; urgency=medium

  * d/p/gcredentialsprivate-Document-the-various-private-macros.patch,
    d/p/credentials-Invalid-Linux-struct-ucred-means-no-informati.patch,
    d/p/GDBus-prefer-getsockopt-style-credentials-passing-APIs.patch:
    - Ensure libdbus clients can authenticate with a GDBusServer like
      the one in ibus. The patches cherry picked from 2.62.2-2 in focal
      in order to allow the ibus fix of CVE-2019-14822 to be re-enabled
      without breaking ibus for Qt applications (LP: #1844853).

 -- Gunnar Hjalmarsson <email address hidden> Thu, 31 Oct 2019 00:48:00 +0100

1844853 IBus no longer works in Qt applications after upgrade
CVE-2019-14822 missing authorization flaw

Version: *DELETED* 2018-08-04 17:07:20 UTC
No changelog for deleted or moved packages.

Version: 2.48.2-0ubuntu4 2018-07-31 07:06:40 UTC

  glib2.0 (2.48.2-0ubuntu4) xenial; urgency=medium

  * Add a versioned Pre-Depends for dpkg because the libglib2.0-0 -await
    trigger requires a newer dpkg than the one in Ubuntu 14.04. (LP: #1784065)

 -- Brian Murray <email address hidden> Mon, 30 Jul 2018 08:29:26 -0700

1784065 upgrade from 14.04 to 16.04 fails due to `interest-await' in trigger

Version: *DELETED* 2018-07-30 11:06:39 UTC
No changelog for deleted or moved packages.

Version: 2.48.2-0ubuntu3 2018-07-16 19:06:45 UTC

  glib2.0 (2.48.2-0ubuntu3) xenial; urgency=medium

  * tests-gdatetime-Use-a-real-rather-than-invented-timezone.patch:
    Cherry-pick upstream fix to make glib2.0 build again and tests
    run again with time zone changes.




About   -   Send Feedback to @ubuntu_updates