UbuntuUpdates.org

Package "rustc"

Name: rustc

Description:

Rust systems programming language

Latest version: 1.31.0+dfsg1+llvm-2ubuntu1~14.04.1
Release: trusty (14.04)
Level: updates
Repository: universe
Homepage: http://www.rust-lang.org/

Links

Save this URL for the latest version of "rustc": https://www.ubuntuupdates.org/rustc


Download "rustc"


Other versions of "rustc" in Trusty

Repository Area Version
security universe 1.31.0+dfsg1+llvm-2ubuntu1~14.04.1
PPA: Ubuntu Mozilla Security 1.31.0+dfsg1+llvm-2ubuntu1~14.04.1

Packages in group

Deleted packages are displayed in grey.


Changelog

Version: 1.31.0+dfsg1+llvm-2ubuntu1~14.04.1 2019-03-25 13:06:26 UTC

  rustc (1.31.0+dfsg1+llvm-2ubuntu1~14.04.1) trusty; urgency=medium

  * Backport 1.30.0 to trusty
  * Relax the gdb build requirement
    - update debian/control
  * Relax the dependency on xz-utils by commenting out some unused code
    - add debian/patches/d-relax-xz-utils-dependency.patch
    - update debian/patches/series
  * Relax dpkg-dev requirement to 1.17.5
   - update debian/control
  * Relax binutils requirement. Even though previous uploads have depended
    on a binutils-2.26, we've never actually used it
    - update debian/control

 -- Michael Hudson-Doyle <email address hidden> Wed, 23 Jan 2019 12:11:37 +1300

Source diff to previous version

Version: 1.30.0+dfsg1+llvm-2ubuntu1~14.04.1 2018-12-11 23:07:13 UTC

  rustc (1.30.0+dfsg1+llvm-2ubuntu1~14.04.1) trusty; urgency=medium

  * Backport 1.30.0 to trusty
  * Relax the gdb build requirement
    - update debian/control
  * Relax the dependency on xz-utils by commenting out some unused code
    - add debian/patches/d-relax-xz-utils-dependency.patch
    - update debian/patches/series
  * Relax dpkg-dev requirement to 1.17.5
   - update debian/control
  * Relax binutils requirement. Even though previous uploads have depended
    on a binutils-2.26, we've never actually used it
    - update debian/control

 -- Michael Hudson-Doyle <email address hidden> Tue, 13 Nov 2018 11:42:07 +1300

Source diff to previous version

Version: 1.28.0+dfsg1+llvm-0ubuntu1~14.04.1 2018-10-24 16:07:08 UTC

  rustc (1.28.0+dfsg1+llvm-0ubuntu1~14.04.1) trusty; urgency=medium

  * Backport 1.28.0 to trusty
  * Relax the gdb build requirement
    - update debian/control
  * Relax the dependency on xz-utils by commenting out some unused code
    - add debian/patches/d-relax-xz-utils-dependency.patch
    - update debian/patches/series
  * Relax dpkg-dev requirement to 1.17.5
   - update debian/control
  * Relax binutils requirement. Even though previous uploads have depended
    on a binutils-2.26, we've never actually used it
    - update debian/control

 -- Chris Coulson <email address hidden> Wed, 15 Aug 2018 18:12:04 +0100

Source diff to previous version

Version: 1.25.0+dfsg1+llvm-0ubuntu1~14.04.1 2018-07-05 17:07:11 UTC

  rustc (1.25.0+dfsg1+llvm-0ubuntu1~14.04.1) trusty; urgency=medium

  * Backport 1.25.0 to trusty
  * Relax the gdb requirement and don't build-conflict on gdb-minimal
    - update debian/control
  * Relax the dependency on xz-utils by commenting out some unused code
    - add debian/patches/d-relax-xz-utils-dependency.patch
    - update debian/patches/series
    - update debian/rules
  * Relax dpkg-dev requirement to 1.17.5
   - update debian/control
  * Relax binutils requirement. Even though previous uploads have depended
    on a binutils-2.26, we've never actually used it
    - update debian/rules
  * Don't compile with -Wno-misleading-indentation, which doesn't exist in
    GCC 4.8
  * Don't pass -march=native to GCC on Aarch64, as it's not supported with
    GCC 4.8
    - add debian/patches/d-dont-pass-march-native-on-aarch64.patch
    - update debian/patches/series

 -- Chris Coulson <email address hidden> Mon, 23 Apr 2018 16:40:31 +0100

Source diff to previous version

Version: 1.24.1+dfsg1+llvm-0ubuntu1~14.04.1 2018-05-11 02:07:55 UTC

  rustc (1.24.1+dfsg1+llvm-0ubuntu1~14.04.1) trusty; urgency=medium

  * Backport 1.24.1 to trusty
  * Relax the gdb requirement and don't build-conflict on gdb-minimal
    - update debian/control
  * Relax the dependency on xz-utils by commenting out some unused code
    - add debian/patches/d-relax-xz-utils-dependency.patch
    - update debian/patches/series
    - update debian/rules
  * Relax dpkg-dev requirement to 1.17.5
   - update debian/control
  * Relax binutils requirement. Even though previous uploads have depended
    on a binutils-2.26, we've never actually used it
    - update debian/rules
  * Don't compile with -Wno-misleading-indentation, which doesn't exist in
    GCC 4.8
  * Revert "Create xz/gz files in parallel" in rust-installer to fix "capacity
    overflow" panic on 32-bit builds
    - add debian/patches/d-no-parallel-tarball-generation.patch
    - update debian/patches/series
  * Don't pass -march=native to GCC on Aarch64, as it's not supported with
    GCC 4.8
    - add debian/patches/d-dont-pass-march-native-on-aarch64.patch
    - update debian/patches/series

 -- Chris Coulson <email address hidden> Mon, 19 Mar 2018 11:50:48 +0000




About   -   Send Feedback to @ubuntu_updates