UbuntuUpdates.org

Package "bash"

Name: bash

Description:

GNU Bourne Again SHell

Latest version: 4.3-7ubuntu1.7
Release: trusty (14.04)
Level: updates
Repository: main
Homepage: http://tiswww.case.edu/php/chet/bash/bashtop.html

Links


Download "bash"


Other versions of "bash" in Trusty

Repository Area Version
base main 4.3-6ubuntu1
base universe 4.3-6ubuntu1
security universe 4.3-7ubuntu1.7
security main 4.3-7ubuntu1.7
updates universe 4.3-7ubuntu1.7
PPA: Mint Upstream 4.3+linuxmint5
PPA: Mint Upstream 4.3+linuxmint5

Packages in group

Deleted packages are displayed in grey.


Changelog

Version: 4.3-7ubuntu1.2 2014-09-25 23:06:57 UTC

  bash (4.3-7ubuntu1.2) trusty-security; urgency=medium

  * SECURITY UPDATE: incomplete fix for CVE-2014-6271
    - debian/patches/CVE-2014-7169.diff: fix logic in parse.y.
    - CVE-2014-7169
 -- Marc Deslauriers <email address hidden> Thu, 25 Sep 2014 02:06:49 -0400

Source diff to previous version
CVE-2014-6271 GNU Bash through 4.3 processes trailing strings after function ...
CVE-2014-7169 GNU Bash through 4.3 bash43-025 processes trailing strings after ...

Version: 4.3-7ubuntu1.1 2014-09-24 17:07:27 UTC

  bash (4.3-7ubuntu1.1) trusty-security; urgency=medium

  * SECURITY UPDATE: incorrect function parsing
    - debian/patches/CVE-2014-6271.diff: fix function parsing in
      builtins/common.h, builtins/evalstring.c, subst.c, variables.c.
    - CVE-2014-6271
 -- Marc Deslauriers <email address hidden> Mon, 22 Sep 2014 15:26:16 -0400

Source diff to previous version

Version: 4.3-7ubuntu1 2014-04-26 06:06:36 UTC

  bash (4.3-7ubuntu1) trusty-proposed; urgency=medium

  * Merge with Debian, replacing local with upstream patches. LP: #1294669.

1294669 bash crashed with SIGABRT in programming_error()



About   -   Send Feedback to @ubuntu_updates