UbuntuUpdates.org

Package "libreoffice-librelogo"

Name: libreoffice-librelogo

Description:

Logo-like programming language for LibreOffice

Latest version: 1:7.3.7-0ubuntu0.22.04.5
Release: jammy (22.04)
Level: updates
Repository: universe
Head package: libreoffice
Homepage: http://librelogo.org

Links


Download "libreoffice-librelogo"


Other versions of "libreoffice-librelogo" in Jammy

Repository Area Version
base universe 1:7.3.2-0ubuntu2
security universe 1:7.3.7-0ubuntu0.22.04.5
backports universe 4:7.6.7-0ubuntu0.23.10.1~bpo22.04.1
PPA: LibreOffice 4:24.2.5~rc2-0ubuntu0.22.04.1~lo1

Changelog

Version: 1:7.3.7-0ubuntu0.22.04.5 2024-05-28 15:07:10 UTC

  libreoffice (1:7.3.7-0ubuntu0.22.04.5) jammy-security; urgency=medium

  * SECURITY UPDATE: Graphic on-click binding allows unchecked script
     execution
    - debian/patches/CVE-2024-3044.patch: add notify for script use
    - CVE-2024-3044

 -- Rico Tzschichholz <email address hidden> Wed, 15 May 2024 09:06:02 +0200

Source diff to previous version
CVE-2024-3044 Unchecked script execution in Graphic on-click binding in affected LibreOffice versions allows an attacker to create a document which without prompt

Version: 1:7.3.7-0ubuntu0.22.04.4 2023-12-14 16:07:07 UTC

  libreoffice (1:7.3.7-0ubuntu0.22.04.4) jammy-security; urgency=medium

  * SECURITY UPDATE: Improper input validation enabling arbitrary Gstreamer
     pipeline injection
    - debian/patches/CVE-2023-6185.patch: escape url passed to gstreamer
    - CVE-2023-6185
  * SECURITY UPDATE: Link targets allow arbitrary script execution
    - debian/patches/CVE-2023-6186-*.patch: multiple commits to fix
      security issues.
    - CVE-2023-6186
  * patches/CppunitTest_desktop_lib-adjust-asserts-so-this-works.patch:
    - Usage of expired certificates in CppunitTest_desktop_lib:
      adjust asserts so this works again

 -- Rico Tzschichholz <email address hidden> Mon, 11 Dec 2023 15:19:13 +0100

Source diff to previous version
CVE-2023-6185 Improper input validation enabling arbitrary Gstreamer pipeline injection
CVE-2023-6186 Link targets allow arbitrary script execution

Version: 1:7.3.7-0ubuntu0.22.04.3 2023-06-07 09:07:32 UTC

  libreoffice (1:7.3.7-0ubuntu0.22.04.3) jammy-security; urgency=high

  * SECURITY UPDATE: Remote documents loaded without prompt via IFrame
    - debian/patches/CVE-2023-2255-*.patch: multiple commits to fix
      security issues.
    - CVE-2023-2255
  * SECURITY UPDATE: Array Index UnderFlow in Calc Formula Parsing
    - debian/patches/CVE-2023-0950.patch: Obtain actual 0-parameter count
      for OR(), AND() and 1-parameter functions
    - CVE-2023-0950

 -- Rico Tzschichholz <email address hidden> Thu, 25 May 2023 22:52:23 +0200

Source diff to previous version
CVE-2023-2255 Improper access control in editor components of The Document Foundation LibreOffice allowed an attacker to craft a document that would cause external
CVE-2023-0950 Improper Validation of Array Index vulnerability in the spreadsheet component of The Document Foundation LibreOffice allows an attacker to craft a sp

Version: 1:7.3.7-0ubuntu0.22.04.2 2023-03-01 07:06:58 UTC

  libreoffice (1:7.3.7-0ubuntu0.22.04.2) jammy; urgency=medium

  * Cherry picked bug fixes release (LP: #2003335)

  * Don’t set language to none on defined styles (tdf#126657, tdf#145104)
    - ubuntu-0002-tdf-126657-tdf-145104-Don-t-set-language-to-none-on-.patch
  * Fix bug in copying table where we need to create a primary key
    - ubuntu-0003-Fix-bug-in-copying-table-where-we-need-to-create-a-p.patch
    - ubuntu-0004-error-when-copying-table-and-the-copy-table-wizard-c.patch
    - ubuntu-0005-make-ValueTransfer-easier-to-understand.patch
  * Switch default currency HRK Croatian Kuna to EUR Euro
    - ubuntu-0006-Related-tdf-150011-Add-HRK-Croatian-Kuna-to-Euro-con.patch
    - ubuntu-0007-Resolves-tdf-150011-Switch-default-currency-HRK-Croa.patch

 -- Rico Tzschichholz <email address hidden> Thu, 02 Feb 2023 12:42:49 +0100

Source diff to previous version
2003335 [SRU] libreoffice 7.3.7 updates for jammy

Version: 1:7.3.7-0ubuntu0.22.04.1 2022-11-15 17:06:30 UTC

  libreoffice (1:7.3.7-0ubuntu0.22.04.1) jammy; urgency=medium

  * New upstream release (LP: #1995054)

  [ Rico Tzschichholz ]
  * Bump yaru source to "2022-09-04"

  [ Rene Engelhard ]
  * debian/rules:
    - add missing >&3 to ufcq calls in bug scripts
    - fix build-depends-on-obsolete-package
      (s/libfreetype6-dev/libfreetype-dev/,
      s/libfontconfig1-dev/libfontconfig-dev/)
    - don't add Graphics; to draws .desktop, it's already there

 -- Rico Tzschichholz <email address hidden> Thu, 27 Oct 2022 12:34:13 +0200

1995054 [SRU] libreoffice 7.3.7 for jammy



About   -   Send Feedback to @ubuntu_updates