UbuntuUpdates.org

Package "ubuntu-release-upgrader"

Name: ubuntu-release-upgrader

Description:

This package is just an umbrella for a group of other packages, it has no description.
Description samples from packages in group:

  • manage release upgrades
  • manage release upgrades
  • manage release upgrades

Latest version: 1:22.04.14
Release: jammy (22.04)
Level: updates
Repository: main

Links



Other versions of "ubuntu-release-upgrader" in Jammy

Repository Area Version
base main 1:22.04.10
base universe 1:22.04.10
updates universe 1:22.04.14

Packages in group

Deleted packages are displayed in grey.


Changelog

Version: 1:22.04.14 2022-09-12 16:06:20 UTC

  ubuntu-release-upgrader (1:22.04.14) jammy; urgency=medium

  * When upgrading from Ubuntu 20.04 or Ubuntu 20.10 require a version of apt
    which fixed a bug in apt (LP: 1871268) and prevents an early failure to
    upgrade. (LP: #1987452)
  * In the nvidia driver quirk handle the case where ubuntu-drivers-common is
    not installed on the system to be upgraded. (LP: #1985253)
  * Run pre-build.sh: updating mirrors and translations.

 -- Brian Murray <email address hidden> Tue, 23 Aug 2022 16:25:59 -0700

Source diff to previous version
1987452 do-release-upgrade without the latest version of apt in focal or groovy will crash
1985253 In a new 20.04 LXD container, do-release-upgrade crashes as lspci cannot be found

Version: 1:22.04.13 2022-08-08 19:06:17 UTC

  ubuntu-release-upgrader (1:22.04.13) jammy; urgency=medium

  [ Simon Chopin ]
  * Add a quirk to resolve an issue where the nvidia driver would get
    suggested for autoremoval. (LP: #1955047)

  [ Steve Langasek ]
  * On upgrade to 22.04, detect the presence of pam_tally* in /etc/pam.d and
    block the upgrade early, to avoid an abort from libpam-modules in the
    middle of the apt upgrade. LP: #1977493.
  * Run pre-build.sh: updating mirrors and translations.

 -- Steve Langasek <email address hidden> Tue, 02 Aug 2022 17:15:07 -0700

Source diff to previous version
1955047 Nvidia drivers are marked as \
1977493 Upgrade from Ubuntu 21.10 to 22.04 fails - unmet dependencies: libpam-modules

Version: 1:22.04.12 2022-07-26 13:06:16 UTC

  ubuntu-release-upgrader (1:22.04.12) jammy; urgency=medium

  [ Brian Murray ]
  * Add support for upgrading from End of Life releases (Ubuntu 20.10 and
    Ubuntu 21.04) to Ubuntu 22.04. (LP: #1975533)
  * DistUpgrade: Do not attempt to reboot in WSL. (LP: #1958668)
  * DistUpgrade/deb2snap.json: gnome-3-34-1804 is no longer a seeded snap and
    should not be refreshed. (LP: #1981485)
  * Run pre-build.sh: updating mirrors, demotions, and translations.

  [ William 'jawn-smith' Wilson ]
  * tests/test_quirks.py: Remove declaration of unused variables

 -- Brian Murray <email address hidden> Tue, 19 Jul 2022 06:52:28 -0700

Source diff to previous version
1975533 No longer possible to use do-release-upgrade on Groovy
1958668 Do not propose to reboot on WSL
1981485 deb2snap.json contains gnome-3-34-1804 in the seeded section

Version: 1:22.04.11 2022-06-07 01:06:22 UTC

  ubuntu-release-upgrader (1:22.04.11) jammy; urgency=medium

  [ William 'jawn-smith' Wilson ]
  * DistUpgrade/DistUpgradeQuirks.py: Remove section of netplan
    config that is installed by default on Raspberry Pi and
    causes netplan failures after upgrade to jammy (LP: #1970761)

  [ Nick Rosbrook ]
  * DistUpgrade: Gracefully handle missing dbus module (LP: #1965568).
  * DistUpgrade: Do not show lock screen error if XDG_SESSION_TYPE is
    tty (LP: #1973785).
  * DistUpgrade: Add deb2snap entry for snapd-desktop-integration (LP: #1975747).
  * Run pre-build.sh: updating mirrors, demotions, and translations.

 -- Nick Rosbrook <email address hidden> Thu, 26 May 2022 10:49:26 -0400

1970761 Upgrades to 22.04 can cause netplan failures on Raspi
1965568 missing dependency on python3-dbus
1973785 lock screen message appeared during an SSH upgrade
1975747 snapd-desktop-integration not installed on upgrade to Jammy



About   -   Send Feedback to @ubuntu_updates