UbuntuUpdates.org

Package "openjdk-lts"

Name: openjdk-lts

Description:

This package is just an umbrella for a group of other packages, it has no description.
Description samples from packages in group:

  • Java runtime based on OpenJDK (debugging symbols)
  • OpenJDK Development Kit (JDK) documentation
  • OpenJDK Development Kit (JDK)
  • OpenJDK Development Kit (JDK) (headless)

Latest version: 11.0.21+9-0ubuntu1~22.04
Release: jammy (22.04)
Level: security
Repository: main

Links



Other versions of "openjdk-lts" in Jammy

Repository Area Version
base main 11.0.14.1+1-0ubuntu1
base universe 11.0.14.1+1-0ubuntu1
security universe 11.0.21+9-0ubuntu1~22.04
updates main 11.0.21+9-0ubuntu1~22.04
updates universe 11.0.21+9-0ubuntu1~22.04

Packages in group

Deleted packages are displayed in grey.


Changelog

Version: 11.0.21+9-0ubuntu1~22.04 2023-11-29 09:06:55 UTC

  openjdk-lts (11.0.21+9-0ubuntu1~22.04) jammy-security; urgency=medium

  * OpenJDK 11.0.21 release, build 9.
    - CVE-2023-22081.
    - Release notes:
      https://mail.openjdk.org/pipermail/jdk-updates-dev/2023-October/026351.html
  * d/source/lintian.overrides: use openjdk-lts package name.
  * Merge changes from openjdk-11 11.0.21+9-1 (LP: #2039754).
    - d/test: update problemlist.
    - d/p: drop exclude-broken-tests.patch.
    - d/p/reproducible-properties-timestamp.diff: use the privileged action
      to read the system property (JDK-8272157, 914278).
    - d/copyright: remove liblcms from excluded files.
    - d/t/jtreg-autopkgtest.{sh,in}: JDK-8232153 - set NSS_DEFAULT_DB_TYPE
      to let sun/security/pkcs11/Secmod/AddTrustedCert.java pass.

      [ Matthias Klose ]
    - Build using GCC 13 on development versions.
    - Explicitly configure --without-jtreg with the nocheck profile

      [ Pushkar Kulkarni ]
    - Handle limited ECC capabilities of NSS on older releases.

  [ Vladimir Petko ]
  * Upload to Ubuntu 22.04.

 -- Vladimir Petko <email address hidden> Thu, 19 Oct 2023 20:55:21 +1300

Source diff to previous version
2039754 please merge openjdk-11 11.0.21+9-1 from Debian unstable
CVE-2023-22081 Vulnerability in the Oracle Java SE, Oracle GraalVM for JDK product of Oracle Java SE (component: JSSE). Supported versions that are affected are Or

Version: 11.0.20.1+1-0ubuntu1~22.04 2023-08-30 12:08:25 UTC

  openjdk-lts (11.0.20.1+1-0ubuntu1~22.04) jammy-security; urgency=medium

  * Upload to Ubuntu 22.04.

Source diff to previous version

Version: 11.0.20+8-1ubuntu1~22.04 2023-07-31 17:07:12 UTC

  openjdk-lts (11.0.20+8-1ubuntu1~22.04) jammy-security; urgency=high

  * Upload to Ubuntu 22.04.
  * d/t/jtreg-autopkgtest.{sh,in}: JDK-8232153 - set NSS_DEFAULT_DB_TYPE
    to let sun/security/pkcs11/Secmod/AddTrustedCert.java pass.

Source diff to previous version

Version: 11.0.19+7~us1-0ubuntu1~22.04.1 2023-05-16 17:11:44 UTC

  openjdk-lts (11.0.19+7~us1-0ubuntu1~22.04.1) jammy-security; urgency=medium

  * Upload to Ubuntu 22.04.

Source diff to previous version

Version: 11.0.18+10-0ubuntu1~22.04 2023-02-28 05:22:10 UTC

  openjdk-lts (11.0.18+10-0ubuntu1~22.04) jammy-security; urgency=medium

  * Upload to Ubuntu 22.04.




About   -   Send Feedback to @ubuntu_updates