UbuntuUpdates.org

Package "rustc"

Name: rustc

Description:

Rust systems programming language

Latest version: 1.74.1+dfsg0ubuntu1~bpo0-0ubuntu0.20.04.1
Release: focal (20.04)
Level: security
Repository: universe
Homepage: http://www.rust-lang.org/

Links


Download "rustc"


Other versions of "rustc" in Focal

Repository Area Version
base universe 1.41.0+dfsg1+llvm-0ubuntu2
updates universe 1.74.1+dfsg0ubuntu1~bpo0-0ubuntu0.20.04.1
PPA: Ubuntu Mozilla Security 1.70.0+dfsg0ubuntu1~bpo2-0ubuntu0.20.04

Packages in group

Deleted packages are displayed in grey.


Changelog

Version: 1.74.1+dfsg0ubuntu1~bpo0-0ubuntu0.20.04.1 2024-02-29 09:06:48 UTC

  rustc (1.74.1+dfsg0ubuntu1~bpo0-0ubuntu0.20.04.1) focal; urgency=medium

  * Backport to Focal (LP: #2040340)
    - d/p/ubuntu-backport-disable-newer-tests.patch: add a patch to disable
      newer tests that can't pass on older Ubuntu series
    - Re-enable libgit2 vendoring:
      - d/control: remove libgit2-dev and libhttp-parser-dev from B-D
    - Re-enable LLVM vendoring (LLVM 17)
    - d/p/ubuntu-backport-disable-newer-tests.patch: disable tests that
      can't pass on older series
    - d/control: Comment out the Vendored-Sources-Rust support as it's not
      available in older releases
    - Downgrade debhelper requirements and adapt the build files to
      older debhelper standards

 -- Zixing Liu <email address hidden> Wed, 17 Jan 2024 13:44:02 -0700

Source diff to previous version
2040340 Upgrade Rust to 1.73.0

Version: 1.73.0+dfsg0ubuntu1~bpo0-0ubuntu0.20.04.1 2024-02-27 10:06:50 UTC

  rustc (1.73.0+dfsg0ubuntu1~bpo0-0ubuntu0.20.04.1) focal; urgency=medium

  * Backport to Focal (LP: #2040340)
    - d/p/ubuntu-backport-disable-newer-tests.patch: add a patch to disable
      newer tests that can't pass on older Ubuntu series
    - Re-enable libgit2 vendoring:
      - d/control: remove libgit2-dev and libhttp-parser-dev from B-D
    - Re-enable LLVM vendoring (LLVM 17)
    - d/p/ubuntu-backport-disable-newer-tests.patch: disable tests that
      can't pass on older series
    - d/control: Comment out the Vendored-Sources-Rust support as it's not
      available in older releases
    - Downgrade debhelper requirements and adapt the build files to
      older debhelper standards
    - d/control: Use backported cmake-mozilla so that LLVM 17 can be built
      correctly
    - d/p/ubuntu-jammy-skip-gdb-tests-on-armhf.patch: also disable for ppc64
    - d/p/ubuntu-llvm-riscv-disable-zicsr.patch: fix build on RISC-V

 -- Zixing Liu <email address hidden> Mon, 16 Jan 2024 16:47:11 -0700

Source diff to previous version
2040340 Upgrade Rust to 1.73.0

Version: 1.72.1+dfsg0ubuntu1~bpo0-0ubuntu0.20.04 2024-02-05 04:07:10 UTC

  rustc (1.72.1+dfsg0ubuntu1~bpo0-0ubuntu0.20.04) focal; urgency=medium

  * Backport to Jammy (LP: #2040339)
    - Re-enable libgit2 vendoring:
      - d/control: remove libgit2-dev and libhttp-parser-dev from B-D
    - d/patches: Remove libgit2 system patches
    - Use bundled LLVM 16
    - d/p/ubuntu-backport-disable-newer-tests.patch: disable tests that
      can't pass on older series
    - d/control: Comment out the Vendored-Sources-Rust support as it's not
      available in older releases
    - Downgrade debhelper requirements and adapt the build files to
      older debhelper standards

 -- Zixing Liu <email address hidden> Mon, 15 Jan 2024 16:27:11 -0700

Source diff to previous version
2040339 Upgrade Rust to 1.72.1

Version: 1.71.1+dfsg0ubuntu3~bpo0-0ubuntu0.20.04 2024-01-29 06:09:22 UTC

  rustc (1.71.1+dfsg0ubuntu3~bpo0-0ubuntu0.20.04) focal; urgency=medium

  * Backport to Focal (LP: #2041325)
    - d/patches: Remove libgit2 system patches
    - Use bundled LLVM 16
    - d/p/ubuntu-backport-disable-newer-tests.patch: disable tests that
      can't pass on older series
    - d/control: Comment out the Vendored-Sources-Rust support as it's not
      available in older releases
    - Downgrade debhelper requirements and adapt the build files to
      older debhelper standards
    - d/control: relax lldb requirements on older series
    - d/rules: remove build artifacts to save disk space

 -- Zixing Liu <email address hidden> Wed, 01 Nov 2023 13:40:56 -0600

Source diff to previous version
2041325 Merge Debian changes into Ubuntu Rust 1.71

Version: 1.70.0+dfsg0ubuntu1~bpo2-0ubuntu0.20.04.1 2023-11-27 06:06:49 UTC

  rustc (1.70.0+dfsg0ubuntu1~bpo2-0ubuntu0.20.04.1) focal; urgency=medium

  * Backport to Jammy (LP: #2027639)
    - d/patches: Remove libgit2 system patches
    - Use bundled LLVM 16
    - d/p/ubuntu-backport-disable-newer-tests.patch: disable tests that
      can't pass on older series
    - Downgrade debhelper requirements and adapt the build files to
      older debhelper standards

 -- Zixing Liu <email address hidden> Wed, 18 Oct 2023 13:56:26 -0600

2027639 Upgrade Rust to 1.70.0



About   -   Send Feedback to @ubuntu_updates