UbuntuUpdates.org

Package "ubuntu-drivers-common"




Name: ubuntu-drivers-common

Description:

This package is just an umbrella for a group of other packages, it has no description.
Description samples from packages in group:

  • debhelper extension for scanning kernel module aliases
  • transitional package for ubuntu-drivers-common

Latest version: *DELETED*
Release: focal (20.04)
Level: proposed
Repository: universe

Links



Other versions of "ubuntu-drivers-common" in Focal

Repository Area Version
base main 1:0.8.1
base universe 1:0.8.1
updates main 1:0.9.0~0.20.04.1
updates universe 1:0.9.0~0.20.04.1
PPA: Mint Upstream 1:0.4.17.2linuxmint1
PPA: Mint Upstream 1:0.4.17.2linuxmint1
PPA: Mint Upstream 1:0.4.17.2linuxmint1
PPA: Mint Upstream 1:0.4.17.3linuxmint1

Packages in group

Deleted packages are displayed in grey.


Changelog

Version: *DELETED* 2021-07-16 21:06:24 UTC
No changelog for deleted or moved packages.

Version: 1:0.9.0~0.20.04.1 2021-07-02 14:06:29 UTC

  ubuntu-drivers-common (1:0.9.0~0.20.04.1) focal; urgency=medium

  [ Alberto Milone ]
  * gpu-manager.c:
    - Make sure to also search the signed modules (LP: #1931514).
      Credit goes to Bin Li for the first version of this patch.
  * debian/tests/control:
    - Add dependency on alsa-utils, since the autopkgtest requires it
      for the sl-modem detection plugin.
  * ubuntu-drivers:
    - Do not install recommended dependencies when calling
      "install --gpgpu" (LP: #1898601). The whole point of
      having --gpgpu was to reduce the amount of the
      installed dependencies.

  [ Michael Hudson-Doyle ]
  * debian/control:
    - Drop dependency on alsa-utils as we want to start using ubuntu-drivers in
      the server installer but do not want alsa-utils there. The code using
      aplay to detect certain kinds of modem will fail to detect them if aplay
      is not installed but will not crash. As alsa-utils is in the
      desktop-common seed there should be no loss of functionality anywhere
      ubuntu-drivers is used today.

 -- Alberto Milone <email address hidden> Thu, 24 Jun 2021 16:22:54 +0200

1931514 SRU: The NVIDIA X server Settings is blank when under Intel mode
1898601 'ubuntu-drivers --gpgpu install' installs a lot of unnecessary packages, including a full desktop environment on Ubuntu Server

Version: *DELETED* 2021-02-08 12:07:04 UTC
No changelog for deleted or moved packages.

Version: 1:0.8.6.5~0.20.04.1 2021-02-03 20:06:51 UTC

  ubuntu-drivers-common (1:0.8.6.5~0.20.04.1) focal; urgency=medium

  * tests/test_ubuntu_drivers.py:
    - Add testcase for list-oem --package-list (LP: #1914051).
  * UbuntuDrivers/detect.py:
    - Fix the way we validate the nvidia modules metapackages
      (LP: #1914374).

 -- Alberto Milone <email address hidden> Wed, 03 Feb 2021 19:23:18 +0100

Source diff to previous version
1914051 `ubuntu-drivers list-oem --package-list` is broken
1914374 Multiple issues on HP ZBook 15 G7 after installing 20.04.2 image

Version: 1:0.8.6.4~0.20.04.1 2021-02-01 21:06:40 UTC

  ubuntu-drivers-common (1:0.8.6.4~0.20.04.1) focal; urgency=medium

  * ubuntu-drivers:
    - Don't error out when failing to write to /run without
      root privileges (LP: #1913651), since package
      installation will fail later.
    - Restore "--package-list" for list-oem, which was supported
      but accidentally not exposed in the transition to click.
      (LP: #1914051).

 -- Alberto Milone <email address hidden> Mon, 01 Feb 2021 18:49:18 +0100

1913651 /usr/bin/ubuntu-drivers:PermissionError:/usr/bin/ubuntu-drivers@480:__call__:main:invoke:invoke:invoke:new_func:invoke:autoinstall:command_install
1914051 `ubuntu-drivers list-oem --package-list` is broken



About   -   Send Feedback to @ubuntu_updates