UbuntuUpdates.org

Package "nvidia-kernel-common-440"

Name: nvidia-kernel-common-440

Description:

Shared files used with the kernel module

Latest version: 440.82+really.440.64-0ubuntu6
Release: focal (20.04)
Level: base
Repository: restricted
Head package: nvidia-graphics-drivers-440
Homepage: http://www.nvidia.com

Links


Download "nvidia-kernel-common-440"


Other versions of "nvidia-kernel-common-440" in Focal

Repository Area Version
security restricted 450.102.04-0ubuntu0.20.04.1
updates restricted 450.102.04-0ubuntu0.20.04.1
proposed restricted 450.102.04-0ubuntu0.20.04.2
PPA: Canonical Kernel Team 440.100-0ubuntu0.20.04.1

Changelog

Version: 440.82+really.440.64-0ubuntu6 2020-04-22 08:06:43 UTC

  nvidia-graphics-drivers-440 (440.82+really.440.64-0ubuntu6) focal; urgency=medium

  * Bump the hard-coded dependency version for lrm to match what's currently
    in the archive.

 -- Steve Langasek <email address hidden> Tue, 21 Apr 2020 20:18:26 -0700

Source diff to previous version

Version: 440.82+really.440.64-0ubuntu5 2020-04-21 19:06:17 UTC

  nvidia-graphics-drivers-440 (440.82+really.440.64-0ubuntu5) focal; urgency=medium

  * Reverse the order of the versions of nvidia-dkms-440 in the dependency
    list, so that apt will default to the real package instead of picking an
    lrm package at "random" which won't necessarily match the target kernel.
    LP: #1873867.

 -- Steve Langasek <email address hidden> Tue, 21 Apr 2020 08:17:20 -0700

Source diff to previous version

Version: 440.82+really.440.64-0ubuntu4 2020-04-17 10:06:35 UTC

  nvidia-graphics-drivers-440 (440.82+really.440.64-0ubuntu4) focal; urgency=medium

  * roll back to 440.64 to match the linux-restricted-modules in the release
    pocket.
  * manually change the dependency to nvidia-dkms-440 (= 440.64-0ubuntu3)
    | nvidia-dkms-440 (= 440.82+really.440.64-0ubuntu4) for compatibility.

 -- Steve Langasek <email address hidden> Thu, 16 Apr 2020 14:38:55 -0700

Source diff to previous version

Version: 440.82-0ubuntu1 2020-04-15 00:06:41 UTC

  nvidia-graphics-drivers-440 (440.82-0ubuntu1) focal; urgency=medium

  * debian/templates/dkms_nvidia.conf.in:
    - Disable buildfix_kernel_5.6.patch.
  * New upstream release:
    - Added a workaround for Steam Play title DOOM Eternal, which
      overrides application requested memory locations, to ensure
      performance-critical resources be placed in video memory.
    - Allow presenting from queue families which only expose
      VK_QUEUE_COMPUTE_BIT when using XCB in addition to Xlib
      surfaces.
    - Fixed a bug that caused render-offloaded applications to crash
      on exit.
    - Fixed a driver installation failure on Linux kernel 5.6 release
      candidates, where the NVIDIA kernel module failed to build with
      error "implicit declaration of function 'timespec_to_ns'".
    - Fixed a driver installation failure on Linux kernel 5.6 release
      candidates, where the NVIDIA kernel module failed to build with
      error "implicit declaration of function 'getrawmonotonic'".
    - Fixed a driver installation failure on Linux kernel 5.6 release
      candidates, where the NVIDIA kernel module failed to build with
      error "implicit declaration of function 'timespec_to_ns'".
    - Fixed a driver installation failure on Linux kernel 5.6 release
      candidates, where the NVIDIA kernel module failed to build with
      error "implicit declaration of function 'getrawmonotonic'".
    - Fixed a driver installation failure on Linux kernel 5.6 release
      candidates, where the NVIDIA kernel module failed to build with
      error "implicit declaration of function 'getnstimeofday'".
    - Fixed a driver installation failure on Linux kernel 5.6 release
      candidates, where the NVIDIA kernel module failed to build with
      error "dereferencing pointer to incomplete type 'struct
      timeval'".
    - Fixed a driver installation failure on Linux kernel 5.6 release
      candidates, where the NVIDIA kernel module failed to build with
      error "implicit declaration of function 'jiffies_to_timespec'".
    - Fixed driver installation failure on Linux kernel 5.6 release
      candidates, where the NVIDIA kernel module failed to build with
      error "passing argument 4 of 'proc_create_data' from
      incompatible pointer type".

 -- Alberto Milone <email address hidden> Wed, 08 Apr 2020 13:16:19 +0200




About   -   Send Feedback to @ubuntu_updates