UbuntuUpdates.org

Package "cinder-common"

Name: cinder-common

Description:

Cinder storage service - common files

Latest version: 2:16.4.2-0ubuntu2.5
Release: focal (20.04)
Level: updates
Repository: main
Head package: cinder
Homepage: https://launchpad.net/cinder

Links


Download "cinder-common"


Other versions of "cinder-common" in Focal

Repository Area Version
base main 2:16.0.0~b3~git2020041012.eb915e2db-0ubuntu1
security main 2:16.4.2-0ubuntu2.4
proposed main 2:16.4.2-0ubuntu2.6

Changelog

Version: 2:16.4.2-0ubuntu2.5 2024-05-29 00:07:05 UTC

  cinder (2:16.4.2-0ubuntu2.5) focal; urgency=medium

  [ Heather Lemon ]
  * Start cinder-volume.service after tgt.service started (LP: #1987663)
    - d/cinder-volume.service.conf: drop-in with 'After=' and 'Wants='
    ('Wants=' is not generated by pkgos-gen-systemd-unit currently).
    - d/cinder-volume.install: ship the systemd service drop-in file.

 -- Mauricio Faria de Oliveira <email address hidden> Fri, 19 Apr 2024 11:24:33 -0300

Source diff to previous version

Version: 2:16.4.2-0ubuntu2.4 2023-05-23 15:07:16 UTC

  cinder (2:16.4.2-0ubuntu2.4) focal-security; urgency=medium

  * SECURITY REGRESSION: Regressions in other projects (LP: #2020111)
    - debian/patches/series: Do not apply CVE-2023-2088.patch until
      patches are ready for all upstream OpenStack projects.
    - CVE-2023-2088

 -- Corey Bryant <email address hidden> Thu, 18 May 2023 11:30:20 -0400

Source diff to previous version
CVE-2023-2088 OSSA-2023-003: Unauthorized volume access through deleted volume attachments

Version: 2:16.4.2-0ubuntu2.3 2023-05-11 20:07:13 UTC

  cinder (2:16.4.2-0ubuntu2.3) focal-security; urgency=medium

  * SECURITY UPDATE: Unauthorized File Access
    - debian/patches/CVE-2023-2088.patch: Reject unsafe delete
      attachment calls.
    - debian/patches/move-unit-test-code-under-tests-unit.patch: Required
      for CVE-2023-2088.patch.
    - CVE-2023-2088

 -- Corey Bryant <email address hidden> Tue, 09 May 2023 08:42:36 -0400

Source diff to previous version
CVE-2023-2088 OSSA-2023-003: Unauthorized volume access through deleted volume attachments

Version: 2:16.4.2-0ubuntu2.2 2023-02-09 15:07:07 UTC

  cinder (2:16.4.2-0ubuntu2.2) focal-security; urgency=medium

  * SECURITY UPDATE: incorrect VMDK subformat check
    - debian/patches/use_json_format.patch: switch qemu_img_info to json
      format or the format_specific attribute will always be empty,
      resulting in check_vmdk_image() always returning an error.

 -- Marc Deslauriers <email address hidden> Tue, 07 Feb 2023 17:11:18 -0500

Source diff to previous version

Version: 2:16.4.2-0ubuntu2.1 2023-01-31 16:07:16 UTC

  cinder (2:16.4.2-0ubuntu2.1) focal-security; urgency=medium

  * SECURITY UPDATE: Arbitrary file access
    - debian/patches/CVE-2022-47951.patch: Check VMDK subformat
      against an allowed list.
    - CVE-2022-47951

 -- Corey Bryant <email address hidden> Sun, 29 Jan 2023 11:10:33 -0500

CVE-2022-47951 An issue was discovered in OpenStack Cinder before 19.1.2, 20.x before 20.0.2, and 21.0.0; Glance before 23.0.1, 24.x before 24.1.1, and 25.0.0; and



About   -   Send Feedback to @ubuntu_updates