UbuntuUpdates.org

Package "gnutls28"

Name: gnutls28

Description:

This package is just an umbrella for a group of other packages, it has no description.
Description samples from packages in group:

  • GNU TLS library - commandline utilities

Latest version: 3.5.18-1ubuntu1.4
Release: bionic (18.04)
Level: updates
Repository: universe

Links



Other versions of "gnutls28" in Bionic

Repository Area Version
base universe 3.5.18-1ubuntu1
base main 3.5.18-1ubuntu1
security universe 3.5.18-1ubuntu1.3
security main 3.5.18-1ubuntu1.3
updates main 3.5.18-1ubuntu1.4

Packages in group

Deleted packages are displayed in grey.


Changelog

Version: 3.5.18-1ubuntu1.4 2020-07-02 15:07:54 UTC

  gnutls28 (3.5.18-1ubuntu1.4) bionic; urgency=medium

  * d/p/50_Update-session_ticket.c-to-add-support-for-zero-leng.patch:
    - add support for zero length session tickets returned from the server,
      thanks Rod for the backport and testing! (lp: #1876286)

 -- Sebastien Bacher <email address hidden> Wed, 17 Jun 2020 12:03:27 +0200

Source diff to previous version

Version: 3.5.18-1ubuntu1.3 2020-01-23 19:06:26 UTC

  gnutls28 (3.5.18-1ubuntu1.3) bionic-security; urgency=medium

  * SECURITY UPDATE: Allow re-enabling SHA1 for certificate signing with a
    priority string (LP: #1860656)
    - debian/patches/allow_broken_priority_string.patch: introduce the
      %VERIFY_ALLOW_BROKEN priority string option.
    - debian/patches/allow_sha1_priority_string.patch: introduce the
      %VERIFY_ALLOW_SIGN_WITH_SHA1 priority string option.

 -- Marc Deslauriers <email address hidden> Thu, 23 Jan 2020 08:39:38 -0500

Source diff to previous version
1860656 SHA1 security update regression prohibits connectivity

Version: 3.5.18-1ubuntu1.2 2020-01-10 16:25:42 UTC

  gnutls28 (3.5.18-1ubuntu1.2) bionic-security; urgency=medium

  * SECURITY UPDATE: Mark SHA1 as insecure for certificate signing
    - debian/patches/insecuresha1-*.patch: backport upstream patches to
      allow marking SHA1 as insecure, but only for certificate signing.
    - debian/libgnutls30.symbols: added new symbol.

 -- Marc Deslauriers <email address hidden> Wed, 08 Jan 2020 10:39:00 -0500

Source diff to previous version

Version: 3.5.18-1ubuntu1.1 2019-05-30 15:06:56 UTC

  gnutls28 (3.5.18-1ubuntu1.1) bionic-security; urgency=medium

  * SECURITY UPDATE: Lucky-13 issues
    - debian/patches/CVE-2018-1084x-1.patch: correctly account the length
      field in SHA384 HMAC in lib/algorithms/mac.c, lib/cipher.c.
    - debian/patches/CVE-2018-1084x-2.patch: always hash the same amount of
      blocks that would have been on minimum pad in lib/cipher.c.
    - debian/patches/CVE-2018-1084x-3.patch: require minimum padding under
      SSL3.0 in lib/cipher.c.
    - debian/patches/CVE-2018-1084x-4.patch: hmac-sha384 and sha256
      ciphersuites were removed from defaults in lib/priority.c,
      tests/dtls1-2-mtu-check.c, tests/priorities.c.
    - debian/patches/CVE-2018-1084x-5.patch: fix test for SHA512 in
      tests/pkcs12_encode.c.
    - CVE-2018-10844
    - CVE-2018-10845
    - CVE-2018-10846
  * SECURITY UPDATE: double free in cert verification API
    - debian/patches/CVE-2019-3829-1.patch: automatically NULLify after
      gnutls_free() in lib/includes/gnutls/gnutls.h.in.
    - debian/patches/CVE-2019-3829-2.patch: fix some casts in
      lib/extensions.c.
    - debian/patches/CVE-2019-3829-3.patch: fix dereference of NULL pointer
      in lib/x509/x509.c.
    - CVE-2019-3829

 -- Marc Deslauriers <email address hidden> Tue, 28 May 2019 13:18:12 -0400

CVE-2018-1084 corosync before version 2.4.4 is vulnerable to an integer overflow in exec/totemcrypto.c.
CVE-2018-10844 It was found that the GnuTLS implementation of HMAC-SHA-256 was vulnerable to a Lucky thirteen style attack. Remote attackers could use this flaw to
CVE-2018-10845 It was found that the GnuTLS implementation of HMAC-SHA-384 was vulnerable to a Lucky thirteen style attack. Remote attackers could use this flaw to
CVE-2018-10846 A cache-based side channel in GnuTLS implementation that leads to plain text recovery in cross-VM attack setting was found. An attacker could use a c
CVE-2019-3829 A vulnerability was found in gnutls versions from 3.5.8 before 3.6.7. A memory corruption (double free) vulnerability in the certificate verification



About   -   Send Feedback to @ubuntu_updates