UbuntuUpdates.org

Package "virtualbox"

Name: virtualbox

Description:

x86 virtualization solution - base binaries

Latest version: 5.2.32-dfsg-0~ubuntu18.04.1
Release: bionic (18.04)
Level: updates
Repository: multiverse
Homepage: https://www.virtualbox.org

Links

Save this URL for the latest version of "virtualbox": https://www.ubuntuupdates.org/virtualbox


Download "virtualbox"


Other versions of "virtualbox" in Bionic

Repository Area Version
base multiverse 5.2.10-dfsg-6
security multiverse 5.2.18-dfsg-2~ubuntu18.04.5
PPA: Mint upstream 4.3.18-dfsg-1~ubuntu1~trusty1
PPA: Mint upstream 5.0.4-dfsg-2

Packages in group

Deleted packages are displayed in grey.


Changelog

Version: 5.2.32-dfsg-0~ubuntu18.04.1 2019-08-03 22:07:01 UTC

  virtualbox (5.2.32-dfsg-0~ubuntu18.04.1) bionic; urgency=medium

  * SRU the latest package for bionic (LP: #1835576, LP: #1829248)
  [ Connor Kuehl ]
  * Fix build for Linux 5.0 (LP: #1835576)
    - debian/patches/ubuntu-0001-linux-5.0-compat.patch
    - debian/patches/ubuntu-0002-linux-5.0-move-ms-remount.patch
    - debian/patches/ubuntu-0003-linux-5.0-make-driver-work-with-Linux-5.0.patch
    - debian/patches/ubuntu-0004-drop-FBINFO_CAN_FORCE_OUTPUT-flag.patch
    - debian/patches/ubuntu-0005-switch-to-drm_get-drm_put-helpers.patch
    - debian/patches/ubuntu-0006-fixup-vboxvideo-module-include.patch
    - debian/patches/ubuntu-0007-update-connector-functions.patch

  [ Gianfranco Costamagna ]
  * Do not apply patches ubuntu-000{1,2,3,4,5,7], because they are included in
    this upstream release
  * New upstream release, update postinst.
  * CVE fixes
    - CVE-2019-2656
    - CVE-2019-2680
    - CVE-2019-2696
    - CVE-2019-2703
    - CVE-2019-2721
    - CVE-2019-2722
    - CVE-2019-2723
    - CVE-2019-2657
    - CVE-2019-2690
    - CVE-2019-2679
    - CVE-2019-2678
    - CVE-2019-2574
  * Drop patches useless with this new upstream release:
    - 18-system-xorg.patch
    - new-gcc.patch
    - kernel-4.18.patch
    - fix-guest-to-host-escape-vulnerability.patch
  * Cherry-pick some fixes from Debian git master branch
    - Enable full hardening
    - automatically detect wsimport from the system
    - bump std-version to 4.3.0
    - Add suid bit to VBoxNetNat to make it work (LP: #1805651)
    - Finally relax dh_strip hack
    - Relax some version constraints, already fullfilled since o-o-stable
    - use cafe instead of beef, to detect if we are inside a VM to fix
      copy-paste.
    - Start VBoxClient too, with the right --vmsvga flag, to fix screen resize
    - Switch to java11, that changed everything (Closes: #920723)
      - add new jaxw dependencies.
    - Switch from iasl to the new acpica-tools name
    - Implement DEB_BUILD_OPTIONS=parallel=n handling during build
      (Closes: #924302)

 -- Gianfranco Costamagna <email address hidden> Thu, 18 Apr 2019 09:30:21 +0200

Source diff to previous version
1835576 virtualbox-guest-dkms-hwe 5.2.18-dfsg-3~ubuntu18.04.3 fails to build on 5.0 based kernels [In function \u2018VBoxGuest_RTR0MemUserIsValidAddr\u2019:
1829248 v5.2.18 dkms fails to build with 5.0 kernel on bionic
1805651 VBoxNetNAT is missing suid bit
920723 virtualbox: Build-Depends on openjdk-8 which will not be in buster - Debian Bug report logs
924302 virtualbox: ignores parallel=n setting in DEB_BUILD_OPTIONS - Debian Bug report logs
CVE-2019-2656 Vulnerability in the Oracle VM VirtualBox component of Oracle Virtualization (subcomponent: Core). Supported versions that are affected are Prior to
CVE-2019-2680 Vulnerability in the Oracle VM VirtualBox component of Oracle Virtualization (subcomponent: Core). Supported versions that are affected are Prior to
CVE-2019-2696 Vulnerability in the Oracle VM VirtualBox component of Oracle Virtualization (subcomponent: Core). Supported versions that are affected are Prior to
CVE-2019-2703 Vulnerability in the Oracle VM VirtualBox component of Oracle Virtualization (subcomponent: Core). Supported versions that are affected are Prior to
CVE-2019-2721 Vulnerability in the Oracle VM VirtualBox component of Oracle Virtualization (subcomponent: Core). Supported versions that are affected are Prior to
CVE-2019-2722 Vulnerability in the Oracle VM VirtualBox component of Oracle Virtualization (subcomponent: Core). Supported versions that are affected are Prior to
CVE-2019-2723 Vulnerability in the Oracle VM VirtualBox component of Oracle Virtualization (subcomponent: Core). Supported versions that are affected are Prior to
CVE-2019-2657 Vulnerability in the Oracle VM VirtualBox component of Oracle Virtualization (subcomponent: Core). Supported versions that are affected are Prior to
CVE-2019-2690 Vulnerability in the Oracle VM VirtualBox component of Oracle Virtualization (subcomponent: Core). Supported versions that are affected are Prior to
CVE-2019-2679 Vulnerability in the Oracle VM VirtualBox component of Oracle Virtualization (subcomponent: Core). Supported versions that are affected are Prior to
CVE-2019-2678 Vulnerability in the Oracle VM VirtualBox component of Oracle Virtualization (subcomponent: Core). Supported versions that are affected are Prior to
CVE-2019-2574 Vulnerability in the Oracle VM VirtualBox component of Oracle Virtualization (subcomponent: Core). Supported versions that are affected are Prior to

Version: 5.2.18-dfsg-2~ubuntu18.04.5 2019-04-16 18:07:31 UTC

  virtualbox (5.2.18-dfsg-2~ubuntu18.04.5) bionic; urgency=medium

  * LP: #1814133.
  * Fixup java breakage and switch to java11 (this fixes a build failure).

 -- Gianfranco Costamagna <email address hidden> Fri, 08 Mar 2019 19:20:35 +0100

Source diff to previous version

Version: 5.2.18-dfsg-2~ubuntu18.04.3 2019-01-22 23:06:18 UTC

  virtualbox (5.2.18-dfsg-2~ubuntu18.04.3) bionic-security; urgency=medium

  * debian/patches/fix-for-guest-to-host-escape-vulnerability.patch:
    - Apply patch for guest-to-host escape vulnerability (LP: #1809156)
    - CVE-2018-3294

 -- Martin Konrad <email address hidden> Wed, 26 Dec 2018 19:41:57 -0500

Source diff to previous version
1809156 E1000 guest to host escape
CVE-2018-3294 Vulnerability in the Oracle VM VirtualBox component of Oracle Virtualization (subcomponent: Core). The supported version that is affected is Prior to

Version: 5.2.18-dfsg-2~ubuntu18.04.1 2018-11-26 10:06:52 UTC

  virtualbox (5.2.18-dfsg-2~ubuntu18.04.1) bionic; urgency=medium

  * SRU the latest cosmic package for bionic (LP: #1796543)

Source diff to previous version
1796543 [SRU] virtualbox-dkms 5.2.10-dfsg-6ubuntu18.04.1: virtualbox kernel module failed to build [error: implicit declaration of function \u2018pci_get_bus

Version: 5.2.10-dfsg-6ubuntu18.04.1 2018-06-28 09:07:11 UTC

  virtualbox (5.2.10-dfsg-6ubuntu18.04.1) bionic; urgency=medium

   * Fix modifyvm --audioout behaviour (LP: #1777079)
    - cherry-pick upstream changeset 72143

 -- Gianfranco Costamagna <email address hidden> Fri, 15 Jun 2018 18:14:07 +0200

1777079 [SRU] Command VBoxManage modifyvm \



About   -   Send Feedback to @ubuntu_updates