UbuntuUpdates.org

Package "nvidia-graphics-drivers-340"

Name: nvidia-graphics-drivers-340

Description:

This package is just an umbrella for a group of other packages, it has no description.
Description samples from packages in group:

  • Transitional package for libcuda1-340
  • Transitional package for libcuda1-340
  • Transitional package for libcuda1-340
  • Transitional package for nvidia-libopencl1-340

Latest version: 340.108-0ubuntu0.18.04.1
Release: bionic (18.04)
Level: proposed
Repository: multiverse

Links

Save this URL for the latest version of "nvidia-graphics-drivers-340": https://www.ubuntuupdates.org/nvidia-graphics-drivers-340



Other versions of "nvidia-graphics-drivers-340" in Bionic

Repository Area Version
updates multiverse 340.107-0ubuntu0.18.04.4
updates restricted 340.107-0ubuntu0.18.04.4
proposed restricted 340.108-0ubuntu0.18.04.1

Packages in group

Deleted packages are displayed in grey.


Changelog

Version: 340.108-0ubuntu0.18.04.1 2020-01-29 16:07:11 UTC

  nvidia-graphics-drivers-340 (340.108-0ubuntu0.18.04.1) bionic; urgency=medium

  * New upstream release (LP: #1854485):
    - Updated the nvidia-drm kernel module for compatibility with the
      removal of the DRIVER_PRIME flag in recent Linux kernel
      versions.
    - Updated nvidia-bug-report.sh to search the systemd journal for
      gdm-x-session logs.
    - Fixed a bug that could prevent nvidia-xconfig from disabling
      the X Composite extension on version 1.20 of the X.org X
      server.
    - Fixed a build failure, "too many arguments to function
      'get_user_pages'", when building the NVIDIA kernel module for
      Linux kernel v4.4.168.
    - Fixed a build failure, "implicit declaration of function
      do_gettimeofday", when building the NVIDIA kernel module for
      Linux kernel 5.0 release candidates.
  * debian/templates/dkms_nvidia.conf.in:
    - Drop the following patches (no longer needed in 340.108):
      buildfix_kernel_5.0.patch, buildfix_kernel_5.3.patch.
    - Fall back on /usr/bin/gcc when cc is not available.
  * debian/dkms_nvidia/patches/buildfix_kernel_4.11.patch,
    debian/dkms_nvidia/patches/do-not-call-pci_save_state.patch,
    debian/dkms_nvidia/patches/use-kmem_cache_create_usercopy-on-4.16.patch,
    debian/dkms_nvidia/patches/buildfix_kernel_5.2.patch:
    - Refresh patches.
  * debian/dkms_nvidia/patches/disable_fstack-clash-protection_fcf-protection.patch,
    debian/dkms_nvidia/patches/do-not-call-pci_save_state.patch:
    - Do not call pci_save_state (as the more recent driver series do).
    - Detect and disable the fstack-clash-protection fcf-protection flags.

 -- Alberto Milone <email address hidden> Mon, 27 Jan 2020 16:53:38 +0100


Version: *DELETED* 2019-11-25 14:06:33 UTC
No changelog for deleted or moved packages.

Version: 340.107-0ubuntu0.18.04.4 2019-11-18 20:07:17 UTC

  nvidia-graphics-drivers-340 (340.107-0ubuntu0.18.04.4) bionic; urgency=medium

  * debian/templates/dkms_nvidia.conf.in:
    debian/patches/buildfix_kernel_5.3.patch:
    - Backport kernel compatibility fixes (LP: #1853015).

 -- Alberto Milone <email address hidden> Mon, 18 Nov 2019 16:11:16 +0100

1853015 nvidia-340 fails to build against linux 5.3.0-23-generic

Version: *DELETED* 2019-08-08 09:06:59 UTC
No changelog for deleted or moved packages.

Version: 340.107-0ubuntu0.18.04.3 2019-07-30 23:07:04 UTC

  nvidia-graphics-drivers-340 (340.107-0ubuntu0.18.04.3) bionic; urgency=medium

  * debian/templates/dkms_nvidia.conf.in:
    debian/patches/buildfix_kernel_5.0.patch,
    debian/patches/buildfix_kernel_5.2.patch,
    debian/patches/use-kmem_cache_create_usercopy-on-4.16.patch:
    - Backport kernel compatibility fixes (LP: #1837834).

 -- Alberto Milone <email address hidden> Thu, 25 Jul 2019 07:06:45 +0200

1837834 Add support for Linux 5.0-5.2



About   -   Send Feedback to @ubuntu_updates