UbuntuUpdates.org

Package "software-properties"

Name: software-properties

Description:

This package is just an umbrella for a group of other packages, it has no description.
Description samples from packages in group:

  • manage the repositories that you install software from
  • manage the repositories that you install software from (common)
  • manage the repositories that you install software from (gtk)

Latest version: 0.96.24.32.14
Release: bionic (18.04)
Level: updates
Repository: main

Links



Other versions of "software-properties" in Bionic

Repository Area Version
base main 0.96.24.32.1
base universe 0.96.24.32.1
security main 0.96.24.32.14
security universe 0.96.24.32.14
updates universe 0.96.24.32.14

Packages in group

Deleted packages are displayed in grey.


Changelog

Version: 0.96.24.32.14 2020-08-12 16:06:22 UTC

  software-properties (0.96.24.32.14) bionic-security; urgency=medium

  * SECURITY UPDATE: malicious repo could send ANSI sequences to terminal
    (LP: #1890286)
    - add-apt-repository: strip ANSI sequences from the description.
    - CVE-2020-15709

 -- Marc Deslauriers <email address hidden> Fri, 07 Aug 2020 10:07:43 -0400

Source diff to previous version
1890286 ansi escape sequence injection in add-apt-repository

Version: 0.96.24.32.13 2020-06-03 04:07:17 UTC

  software-properties (0.96.24.32.13) bionic; urgency=medium

  * softwareproperties/gtk/SoftwarePropertiesGtk.py:
    - Gtk is doing something that takes a lock while processing checkbox
      toggled events, the polkit auth dialog can't be displayed in return,
      we don't have a proper fix and it might require GTK changes,
      meanwhile we want a working interface so workaround with a sleep
      (lp: #1727908)

 -- Sebastien Bacher <email address hidden> Fri, 08 May 2020 16:47:19 +0200

Source diff to previous version
1727908 Software \u0026 Updates application does not permit changes on the \

Version: 0.96.24.32.12 2019-12-19 11:06:43 UTC

  software-properties (0.96.24.32.12) bionic; urgency=medium

  * cloudarchive: Enable support for the Ussuri Ubuntu Cloud Archive on
    18.04 (LP: #1852489).

 -- Corey Bryant <email address hidden> Mon, 02 Dec 2019 09:21:38 -0500

Source diff to previous version
1852489 [SRU] Enable support for Ussuri Cloud Archive

Version: 0.96.24.32.11 2019-08-13 17:06:31 UTC

  software-properties (0.96.24.32.11) bionic; urgency=medium

  * cloudarchive: Update outdated WEB_LINK that is presented when
    cloud archive is enabled (LP: #1836258).

 -- Corey Bryant <email address hidden> Fri, 12 Jul 2019 10:10:04 -0400

Source diff to previous version
1836258 Update hyperlink when enabling UCA

Version: 0.96.24.32.9 2019-05-30 18:06:57 UTC

  software-properties (0.96.24.32.9) bionic; urgency=medium

  * debian/control:
    - required snapd-glib 1.42 (lp: #1830353)

  [ Iain Lane ]
  * softwareproperties/gtk/LivepatchPage.py:
    - livepatch: Always pass a string to SetLivePatchEnabled (lp: #1830348)

  [ Corey Bryant ]
  * cloudarchive: Enable support for the Train Ubuntu Cloud Archive on
    18.04 (LP: #1829017).

 -- Sebastien Bacher <email address hidden> Fri, 24 May 2019 17:03:01 +0200

1830353 /usr/bin/software-properties-gtk:AttributeError:_update_availability:\u003clambda\u003e:get_status:_get_raw_snap
1830348 /usr/bin/software-properties-gtk:TypeError:msg_reply_handler:_enabled_reply_handler:__call__:call_async
1829017 [SRU] Enable support for Train Cloud Archive



About   -   Send Feedback to @ubuntu_updates