UbuntuUpdates.org

Package "libwebkit2gtk-4.0-37"

Name: libwebkit2gtk-4.0-37

Description:

Web content engine library for GTK+

Latest version: 2.26.4-0ubuntu0.18.04.1
Release: bionic (18.04)
Level: updates
Repository: main
Head package: webkit2gtk
Homepage: https://webkitgtk.org/

Links

Save this URL for the latest version of "libwebkit2gtk-4.0-37": https://www.ubuntuupdates.org/libwebkit2gtk-4.0-37


Download "libwebkit2gtk-4.0-37"


Other versions of "libwebkit2gtk-4.0-37" in Bionic

Repository Area Version
base main 2.20.1-1
security main 2.26.4-0ubuntu0.18.04.1

Changelog

Version: 2.26.4-0ubuntu0.18.04.1 2020-02-18 15:07:11 UTC

  webkit2gtk (2.26.4-0ubuntu0.18.04.1) bionic-security; urgency=medium

  * Updated to 2.26.4 to fix security issues.
    - CVE-2020-3862, CVE-2020-3864, CVE-2020-3865, CVE-2020-3867,
      CVE-2020-3868

 -- Marc Deslauriers <email address hidden> Fri, 14 Feb 2020 14:25:54 -0500

Source diff to previous version

Version: 2.26.3-0ubuntu0.18.04.1 2020-01-29 21:07:22 UTC

  webkit2gtk (2.26.3-0ubuntu0.18.04.1) bionic-security; urgency=medium

  * Updated to 2.26.3 to fix security issues.
    - CVE-2019-8835, CVE-2019-8844, CVE-2019-8846

 -- Marc Deslauriers <email address hidden> Tue, 28 Jan 2020 12:57:43 -0500

Source diff to previous version

Version: 2.26.2-0ubuntu0.18.04.1 2019-11-12 21:06:23 UTC

  webkit2gtk (2.26.2-0ubuntu0.18.04.1) bionic-security; urgency=medium

  * Updated to 2.26.2 to fix security issues.
    - CVE-2019-8812, CVE-2019-8814

 -- Marc Deslauriers <email address hidden> Fri, 08 Nov 2019 12:16:03 -0500

Source diff to previous version
CVE-2019-8812 RESERVED
CVE-2019-8814 RESERVED

Version: 2.26.1-0ubuntu0.18.04.1 2019-11-07 15:06:55 UTC

  webkit2gtk (2.26.1-0ubuntu0.18.04.1) bionic-security; urgency=medium

  * Updated to 2.26.1 to fix security issues.
    - CVE-2019-8625, CVE-2019-8720, CVE-2019-8769, CVE-2019-8771
  * debian/patches/*patch: Refreshed patches from 2.26.1-2.
  * debian/libwebkit2gtk-4.0-37.symbols: Updated for new version.
  * debian/patches/force-single-process.patch: add workaround for geary and
    evolution.
  * debian/rules: build with -DUSE_WPE_RENDERER=OFF and
    -DENABLE_BUBBLEWRAP_SANDBOX=OFF as required dependencies are not
    available.
  * Remove gtk2 support no longer available
    - debian/control: remove libgtk2.0-dev from Build-Depends, switch
      libwebkit2gtk-4.0-37-gtk2 to a transitional package.
    - debian/libwebkit2gtk-4.0-37-gtk2.NEWS: added information.
    - debian/libwebkit2gtk-4.0-37-gtk2.install: removed.

 -- Marc Deslauriers <email address hidden> Mon, 04 Nov 2019 14:37:08 -0500

Source diff to previous version

Version: 2.24.4-0ubuntu0.18.04.1 2019-09-11 19:07:21 UTC
No changelog available yet.



About   -   Send Feedback to @ubuntu_updates