UbuntuUpdates.org

Package "libsoup2.4"

Name: libsoup2.4

Description:

This package is just an umbrella for a group of other packages, it has no description.
Description samples from packages in group:

  • GObject introspection data for the libsoup HTTP library
  • HTTP library implementation in C -- GNOME support library
  • HTTP library implementation in C -- GNOME support development files
  • HTTP library implementation in C -- Shared library

Latest version: 2.62.1-1ubuntu0.4
Release: bionic (18.04)
Level: security
Repository: main

Links

Save this URL for the latest version of "libsoup2.4": https://www.ubuntuupdates.org/libsoup2.4



Other versions of "libsoup2.4" in Bionic

Repository Area Version
base main 2.62.1-1
updates main 2.62.1-1ubuntu0.4

Packages in group

Deleted packages are displayed in grey.


Changelog

Version: 2.62.1-1ubuntu0.4 2019-10-09 19:06:53 UTC

  libsoup2.4 (2.62.1-1ubuntu0.4) bionic-security; urgency=medium

  * SECURITY UPDATE: heap over-read in soup_ntlm_parse_challenge()
    - debian/patches/CVE-2019-17266.patch: avoid a potential heap buffer
      overflow in v2 authentication in libsoup/soup-auth-ntlm.c.
    - CVE-2019-17266

 -- Marc Deslauriers <email address hidden> Wed, 09 Oct 2019 10:37:09 -0400

Source diff to previous version
CVE-2019-17266 libsoup through 2.68.1 has a heap-based buffer over-read because soup_ntlm_parse_challenge() in soup-auth-ntlm.c does not properly check an NTLM mess

Version: 2.62.1-1ubuntu0.1 2018-07-03 19:07:32 UTC

  libsoup2.4 (2.62.1-1ubuntu0.1) bionic-security; urgency=medium

  * SECURITY UPDATE: Fail to handle empty hostnames
    - debian/patches/CVE-2018-12910.patch: fix in libsoup/soup-cookie-jar.c.
    - CVE-2018-12910

 -- <email address hidden> (Leonidas S. Barbosa) Mon, 02 Jul 2018 12:42:47 -0300




About   -   Send Feedback to @ubuntu_updates