UbuntuUpdates.org

Package "openssl"

Name: openssl

Description:

Secure Sockets Layer toolkit - cryptographic utility

Latest version: 1.1.1-1ubuntu2.1~18.04.4
Release: bionic (18.04)
Level: proposed
Repository: main
Homepage: https://www.openssl.org/

Links

Save this URL for the latest version of "openssl": https://www.ubuntuupdates.org/openssl


Download "openssl"


Other versions of "openssl" in Bionic

Repository Area Version
base main 1.1.0g-2ubuntu4
security main 1.1.0g-2ubuntu4.3
updates main 1.1.1-1ubuntu2.1~18.04.3

Packages in group

Deleted packages are displayed in grey.


Changelog

Version: 1.1.1-1ubuntu2.1~18.04.4 2019-06-20 23:06:22 UTC

  openssl (1.1.1-1ubuntu2.1~18.04.4) bionic; urgency=medium

  * Import libraries/restart-without-asking as used in postinst, to
    prevent failure to configure the package without debconf database.
    LP: #1832919

 -- Dimitri John Ledkov <email address hidden> Thu, 20 Jun 2019 18:36:28 +0100

Source diff to previous version
1832919 installed libssl1.1:amd64 package post-installation script subprocess returned error exit status 10

Version: 1.1.1-1ubuntu2.1~18.04.3 2019-06-14 20:07:01 UTC

  openssl (1.1.1-1ubuntu2.1~18.04.3) bionic; urgency=medium

  * Fix path to Xorg for reboot notifications on desktop. LP: #1832421
  * Cherrypick upstream fix to allow succesful init of libssl and
    libcrypto using separate calls with different options. LP: #1832659

 -- Dimitri John Ledkov <email address hidden> Fri, 14 Jun 2019 13:50:28 +0100

Source diff to previous version
1832421 openssl reboot needed message using incorrect path to X server
1832659 openssl 1.1.1-1ubuntu2.1~18.04.1 contains upstream bug 7350

Version: 1.1.1-1ubuntu2.1~18.04.2 2019-06-12 19:06:59 UTC

  openssl (1.1.1-1ubuntu2.1~18.04.2) bionic; urgency=medium

  * Cherrypick upstream patch to fix ca -spkac output to be text again.
    LP: #1828215
  * Cherrypick upstream patch to prevent over long nonces in ChaCha20-Poly1305
    CVE-2019-1543
  * Bump major version of OpenSSL in postinst to trigger services restart
    upon upgrade. Many services listed there must be restarted when
    upgrading 1.1.0 to 1.1.1. LP: #1832522

 -- Dimitri John Ledkov <email address hidden> Wed, 12 Jun 2019 00:12:47 +0100

1828215 openssl ca -spkac output regressed
1832522 openssl maintainer scripts do not trigger services restart
CVE-2019-1543 ChaCha20-Poly1305 is an AEAD cipher, and requires a unique nonce input for every encryption operation. RFC 7539 specifies that the nonce value (IV) s

Version: *DELETED* 2019-06-11 23:06:25 UTC
No changelog for deleted or moved packages.

Version: 1.1.1-1ubuntu2.1~18.04.1 2019-04-04 01:06:49 UTC

  openssl (1.1.1-1ubuntu2.1~18.04.1) bionic; urgency=medium

  * Backport OpenSSL 1.1.1 to 18.04 LTS. LP: #1797386
  * Adjust Breaks on versions published in bionic-release.




About   -   Send Feedback to @ubuntu_updates