UbuntuUpdates.org

Package "netplan.io"

Name: netplan.io

Description:

YAML network configuration abstraction for various backends

Latest version: 0.98-0ubuntu1~18.04.1
Release: bionic (18.04)
Level: proposed
Repository: main
Homepage: https://netplan.io/

Links

Save this URL for the latest version of "netplan.io": https://www.ubuntuupdates.org/netplan.io


Download "netplan.io"


Other versions of "netplan.io" in Bionic

Repository Area Version
security main 0.40.1~18.04.4
updates main 0.97-0ubuntu1~18.04.1

Packages in group

Deleted packages are displayed in grey.


Changelog

Version: 0.98-0ubuntu1~18.04.1 2019-08-28 00:06:59 UTC

  netplan.io (0.98-0ubuntu1~18.04.1) bionic; urgency=medium

  * Backport netplan.io 0.98 to 18.04. (LP: #1840832)
  * Keep patches specific to 18.04 support:
    - disable-networkd-tunnels-ipip-gre.patch: disable tests for unsupported
      tunnel types (ipip and gre) in the 18.04 version of systemd-networkd.
  * Drop debian/patches/glib_changes.patch: No longer necessary, changes were
    made upstream to better account for the changes in HashTable.
  * debian/netplan.io.install: add /usr/share/dbus-1

1840832 Update to netplan.io 0.98 release

Version: *DELETED* 2019-05-20 13:07:06 UTC
No changelog for deleted or moved packages.

Version: 0.97-0ubuntu1~18.04.1 2019-05-09 23:07:17 UTC

  netplan.io (0.97-0ubuntu1~18.04.1) bionic; urgency=medium

  * Backport netplan.io 0.97 to 18.04. (LP: #1828299)
  * Keep patches specific to 18.04 support:
    - glib_changes.patch: fixes for older GLib version
    - disable-networkd-tunnels-ipip-gre.patch: disable tests for unsupported
      tunnel types (ipip and gre) in the 18.04 version of systemd-networkd.

1828299 update to netplan.io 0.97

Version: *DELETED* 2019-05-09 12:07:39 UTC
No changelog for deleted or moved packages.

Version: 0.96-0ubuntu0.18.04.4 2019-05-01 10:06:25 UTC

  netplan.io (0.96-0ubuntu0.18.04.4) bionic; urgency=medium

  * debian/patches/git_revert_explicit_renderer_def_ebc212a.patch: revert
    commit ebc212a: make renderer values explicit at the end of each parsing
    pass; it breaks "default" renderer behavior when multiple files may set
    a global renderer and expect the last to take effect globally.
    (LP: #1825206)
  * debian/patches/git_reorg_netdef_validation_181b583.patch: correct the
    fallout from the above change: validate netdefs in a single pass at the
    very end of parsing, once we know which is the applicable renderer. This
    makes sure tunnels get validated correctly.

1825206 No wifi adapter present in Gnome after upgrade to 0.96-0ubuntu0.18.10.2



About   -   Send Feedback to @ubuntu_updates