UbuntuUpdates.org

Package "netplan.io"

Name: netplan.io

Description:

YAML network configuration abstraction for various backends

Latest version: 0.99-0ubuntu3~18.04.1
Release: bionic (18.04)
Level: updates
Repository: main
Homepage: https://netplan.io/

Links

Save this URL for the latest version of "netplan.io": https://www.ubuntuupdates.org/netplan.io


Download "netplan.io"


Other versions of "netplan.io" in Bionic

Repository Area Version
security main 0.40.1~18.04.4
proposed main 0.99-0ubuntu3~18.04.2

Packages in group

Deleted packages are displayed in grey.


Changelog

Version: 0.99-0ubuntu3~18.04.1 2020-05-13 03:06:40 UTC

  netplan.io (0.99-0ubuntu3~18.04.1) bionic; urgency=medium

  * Backport netplan.io 0.99 to 18.04. (LP: #1871825)
  * Keep patches specific to 18.04 support:
    - disable-networkd-tunnels-ipip-gre.patch: disable tests for unsupported
      tunnel types (ipip and gre) in the 18.04 version of systemd-networkd.
  * debian/control: introduce dependecies on libnetplan0

 -- Lukas Märdian <email address hidden> Mon, 04 May 2020 09:51:02 +0200

Source diff to previous version
1871825 [FFe] Update to netplan.io 0.99

Version: 0.98-0ubuntu1~18.04.1 2019-10-03 00:07:00 UTC

  netplan.io (0.98-0ubuntu1~18.04.1) bionic; urgency=medium

  * Backport netplan.io 0.98 to 18.04. (LP: #1840832)
  * Keep patches specific to 18.04 support:
    - disable-networkd-tunnels-ipip-gre.patch: disable tests for unsupported
      tunnel types (ipip and gre) in the 18.04 version of systemd-networkd.
  * Drop debian/patches/glib_changes.patch: No longer necessary, changes were
    made upstream to better account for the changes in HashTable.
  * debian/netplan.io.install: add /usr/share/dbus-1

Source diff to previous version
1840832 Update to netplan.io 0.98 release

Version: 0.97-0ubuntu1~18.04.1 2019-05-20 10:07:08 UTC

  netplan.io (0.97-0ubuntu1~18.04.1) bionic; urgency=medium

  * Backport netplan.io 0.97 to 18.04. (LP: #1828299)
  * Keep patches specific to 18.04 support:
    - glib_changes.patch: fixes for older GLib version
    - disable-networkd-tunnels-ipip-gre.patch: disable tests for unsupported
      tunnel types (ipip and gre) in the 18.04 version of systemd-networkd.

Source diff to previous version
1828299 update to netplan.io 0.97

Version: 0.96-0ubuntu0.18.04.4 2019-05-08 02:06:46 UTC

  netplan.io (0.96-0ubuntu0.18.04.4) bionic; urgency=medium

  * debian/patches/git_revert_explicit_renderer_def_ebc212a.patch: revert
    commit ebc212a: make renderer values explicit at the end of each parsing
    pass; it breaks "default" renderer behavior when multiple files may set
    a global renderer and expect the last to take effect globally.
    (LP: #1825206)
  * debian/patches/git_reorg_netdef_validation_181b583.patch: correct the
    fallout from the above change: validate netdefs in a single pass at the
    very end of parsing, once we know which is the applicable renderer. This
    makes sure tunnels get validated correctly.

Source diff to previous version
1825206 No wifi adapter present in Gnome after upgrade to 0.96-0ubuntu0.18.10.2

Version: 0.40.1~18.04.4 2019-01-10 21:06:33 UTC

  netplan.io (0.40.1~18.04.4) bionic-security; urgency=medium

  * No change rebuild in -security pocket to fix dependency issue
    (LP: #1811210)

 -- Marc Deslauriers <email address hidden> Thu, 10 Jan 2019 12:03:08 -0500

1811210 intramfs-tools 0.130ubuntu3.3 in bionic-security breaks netplan.io in -security or in release



About   -   Send Feedback to @ubuntu_updates