UbuntuUpdates.org

Package "software-properties"

Name: software-properties

Description:

This package is just an umbrella for a group of other packages, it has no description.
Description samples from packages in group:

  • manage the repositories that you install software from
  • manage the repositories that you install software from (qt)

Latest version: 0.96.20.10
Release: xenial (16.04)
Level: updates
Repository: universe

Links



Other versions of "software-properties" in Xenial

Repository Area Version
base main 0.96.20
base universe 0.96.20
security main 0.96.20.10
security universe 0.96.20.10
updates main 0.96.20.10

Packages in group

Deleted packages are displayed in grey.


Changelog

Version: 0.96.20.10 2020-08-12 16:06:21 UTC

  software-properties (0.96.20.10) xenial-security; urgency=medium

  * SECURITY UPDATE: malicious repo could send ANSI sequences to terminal
    (LP: #1890286)
    - add-apt-repository: strip ANSI sequences from the description.
    - CVE-2020-15709

 -- Marc Deslauriers <email address hidden> Fri, 07 Aug 2020 10:08:35 -0400

Source diff to previous version
1890286 ansi escape sequence injection in add-apt-repository

Version: 0.96.20.9 2019-08-13 17:06:29 UTC

  software-properties (0.96.20.9) xenial; urgency=medium

  * cloudarchive: Update outdated WEB_LINK that is presented when
    cloud archive is enabled (LP: #1836258).

 -- Corey Bryant <email address hidden> Fri, 12 Jul 2019 10:15:23 -0400

Source diff to previous version
1836258 Update hyperlink when enabling UCA

Version: 0.96.20.8 2019-01-08 19:06:28 UTC

  software-properties (0.96.20.8) xenial; urgency=medium

  * SoftwarePropertiesGtk.py: when checking a package's depends for DKMS also
    pass on an AttributeError (LP: #1807373)

 -- Brian Murray <email address hidden> Mon, 17 Dec 2018 11:21:26 -0800

Source diff to previous version
1807373 /usr/bin/software-properties-gtk:AttributeError:on_driver_selection_changed

Version: 0.96.20.7 2017-05-17 07:06:48 UTC

  software-properties (0.96.20.7) xenial; urgency=medium

  * software-properties-gtk:
    - fix the backend code to set the gnome debconf frontend, without which
      libgtk2-perl goes unused.
    - depend on libgtk2-perl to ensure it's available, since it was not seeded
      on the desktop at release time. This is only a Recommends: in zesty,
      but we need to ensure this isn't ignored on upgrade.
    LP: #1679784.

 -- Steve Langasek <email address hidden> Thu, 27 Apr 2017 16:21:42 -0700

Source diff to previous version
1679784 Changing from Xorg video driver to NVIDIA driver using Software \u0026 Updates does not display debconf prompt

Version: 0.96.20.6 2017-04-28 02:06:51 UTC

  software-properties (0.96.20.6) xenial; urgency=medium

  * Add knowledge of OpenStack releases Pike and Queens. (LP: #1670385)

  [ Scott Moser & Dimitri John Ledkov ]
  * When failing to retrieve a GPG key, raise an exception such that
    e.g. add-apt-repository can fail when it did not manage to retrieve a
    GPG key for the shortcut repository. LP: #1532855

 -- Scott Moser <email address hidden> Mon, 06 Mar 2017 16:56:40 -0500

1670385 Add knowledge of openstack releases Pike and Queens
1532855 add-apt-repository exits with 0 even when adding key failed



About   -   Send Feedback to @ubuntu_updates