UbuntuUpdates.org

Package "packagekit"

Name: packagekit

Description:

This package is just an umbrella for a group of other packages, it has no description.
Description samples from packages in group:

  • Plugin to install missing plugins using PackageKit
  • GStreamer plugin to install codecs using PackageKit
  • Smart backend for PackageKit
  • Debugging symbols for PackageKit

Latest version: 0.8.17-4ubuntu6~gcc5.4ubuntu1.5
Release: xenial (16.04)
Level: updates
Repository: universe

Links



Other versions of "packagekit" in Xenial

Repository Area Version
base universe 0.8.17-4ubuntu6~gcc5.4ubuntu1
base main 0.8.17-4ubuntu6~gcc5.4ubuntu1
security main 0.8.17-4ubuntu6~gcc5.4ubuntu1.5
security universe 0.8.17-4ubuntu6~gcc5.4ubuntu1.5
updates main 0.8.17-4ubuntu6~gcc5.4ubuntu1.5
PPA: Kubuntu-ppa Backports 1.1.1-1ubuntu1~ubuntu16.04~ppa1

Packages in group

Deleted packages are displayed in grey.


Changelog

Version: 0.8.17-4ubuntu6~gcc5.4ubuntu1.5 2020-09-24 15:06:21 UTC

  packagekit (0.8.17-4ubuntu6~gcc5.4ubuntu1.5) xenial-security; urgency=medium

  * SECURITY UPDATE: information disclosure (LP: #1888887)
    - debian/patches/CVE-2020-16121.patch: hide failures behind a single
      error message in src/pk-transaction.c.
    - CVE-2020-16121
  * SECURITY UPDATE: untrusted local file installation (LP: #1882098)
    - debian/patches/CVE-2020-16122.patch: do not trust local packages in
      backends/aptcc/apt-intf.cpp.
    - CVE-2020-16122

 -- Marc Deslauriers <email address hidden> Wed, 23 Sep 2020 13:23:04 -0400

Source diff to previous version
1888887 Reading local files as root leads to sensitive information disclosure
1882098 Packagekit lets user install untrusted local packages in Bionic and Focal

Version: 0.8.17-4ubuntu6~gcc5.4ubuntu1.4 2018-10-25 17:06:18 UTC

  packagekit (0.8.17-4ubuntu6~gcc5.4ubuntu1.4) xenial; urgency=medium

   * debian/patches/frontend-locking.diff:
     Implement frontend locking in a simple way. Will need some more
     work to upstream, and possibly some error checking. (LP: #1795614)
   * Bump libapt-pkg-dev build-dep to >= 1.2.28~ for frontend locking

 -- Julian Andres Klode <email address hidden> Tue, 02 Oct 2018 16:13:24 +0200

Source diff to previous version
1795614 packagekit frontend locking

Version: 0.8.17-4ubuntu6~gcc5.4ubuntu1.3 2018-07-26 11:06:56 UTC

  packagekit (0.8.17-4ubuntu6~gcc5.4ubuntu1.3) xenial; urgency=medium

  * Convert triggers to noawait (LP: #1780996)

 -- Julian Andres Klode <email address hidden> Tue, 10 Jul 2018 22:18:21 +0200

Source diff to previous version

Version: 0.8.17-4ubuntu6~gcc5.4ubuntu1.2 2017-09-04 17:07:04 UTC

  packagekit (0.8.17-4ubuntu6~gcc5.4ubuntu1.2) xenial; urgency=medium

  * Add fix-update-detail-crash.patch: Fix GetUpdateDetail() crashing
    immediately with aptcc. Backport fix from upstream commit 18c56fa520.
    (LP: #1689820)
  * Drop browser-plugin-packagekit binary package. It cannot be built any more
    as current firefox dropped NPAPI. Backported from Debian packaging git
    commit b98a97832275.

 -- Martin Pitt <email address hidden> Tue, 08 Aug 2017 13:00:44 +0000

Source diff to previous version

Version: 0.8.17-4ubuntu6~gcc5.4ubuntu1.1 2016-05-26 23:06:46 UTC

  packagekit (0.8.17-4ubuntu6~gcc5.4ubuntu1.1) xenial; urgency=medium

  * Fix segfault on AptIntf::init() (LP: #1569292)
    aptcc: Don't ask about config changes if we are not interactive
    aptcc: Always respect the noninteractive flag
    aptcc: Fix several compiler warnings
    aptcc: Ensure proxy and frontend-socket aren't used if they are NULL

 -- Seyeong Kim <email address hidden> Tue, 10 May 2016 16:20:37 +0200

1569292 Can't join to AD domain



About   -   Send Feedback to @ubuntu_updates