UbuntuUpdates.org

Package "gnutls28"

Name: gnutls28

Description:

This package is just an umbrella for a group of other packages, it has no description.
Description samples from packages in group:

  • GNU TLS library - commandline utilities
  • GNU TLS library - GNU Guile bindings

Latest version: 3.4.10-4ubuntu1.8
Release: xenial (16.04)
Level: updates
Repository: universe

Links



Other versions of "gnutls28" in Xenial

Repository Area Version
base main 3.4.10-4ubuntu1
base universe 3.4.10-4ubuntu1
security main 3.4.10-4ubuntu1.7
security universe 3.4.10-4ubuntu1.7
updates main 3.4.10-4ubuntu1.8

Packages in group

Deleted packages are displayed in grey.


Changelog

Version: 3.4.10-4ubuntu1.8 2020-07-02 17:06:51 UTC

  gnutls28 (3.4.10-4ubuntu1.8) xenial; urgency=medium

  * d/p/50_Update-session_ticket.c-to-add-support-for-zero-leng.patch:
    - add support for zero length session tickets returned from the server,
      thanks Rod for the backport and testing! (lp: #1876286)

 -- Sebastien Bacher <email address hidden> Wed, 17 Jun 2020 23:06:13 +0200

Source diff to previous version

Version: 3.4.10-4ubuntu1.7 2020-01-23 19:06:23 UTC

  gnutls28 (3.4.10-4ubuntu1.7) xenial-security; urgency=medium

  * SECURITY UPDATE: Allow re-enabling SHA1 for certificate signing with a
    priority string (LP: #1860656)
    - debian/patches/allow_broken_priority_string.patch: introduce the
      %VERIFY_ALLOW_BROKEN priority string option.
    - debian/patches/allow_sha1_priority_string.patch: introduce the
      %VERIFY_ALLOW_SIGN_WITH_SHA1 priority string option.

 -- Marc Deslauriers <email address hidden> Thu, 23 Jan 2020 08:47:43 -0500

Source diff to previous version
1860656 SHA1 security update regression prohibits connectivity

Version: 3.4.10-4ubuntu1.6 2020-01-10 16:25:31 UTC

  gnutls28 (3.4.10-4ubuntu1.6) xenial-security; urgency=medium

  * SECURITY UPDATE: Mark SHA1 as insecure for certificate signing
    - debian/patches/insecuresha1-*.patch: backport upstream patches to
      allow marking SHA1 as insecure, but only for certificate signing.
    - debian/libgnutls30.symbols: added new symbol.

 -- Marc Deslauriers <email address hidden> Wed, 08 Jan 2020 12:52:12 -0500

Source diff to previous version

Version: 3.4.10-4ubuntu1.5 2019-05-30 15:06:50 UTC

  gnutls28 (3.4.10-4ubuntu1.5) xenial-security; urgency=medium

  * SECURITY UPDATE: Lucky-13 issues
    - debian/patches/CVE-2018-1084x-1.patch: correctly account the length
      field in SHA384 HMAC in lib/algorithms/mac.c, lib/gnutls_cipher.c.
    - debian/patches/CVE-2018-1084x-2.patch: always hash the same amount of
      blocks that would have been on minimum pad in lib/gnutls_cipher.c.
    - debian/patches/CVE-2018-1084x-3.patch: require minimum padding under
      SSL3.0 in lib/gnutls_cipher.c.
    - debian/patches/CVE-2018-1084x-4.patch: hmac-sha384 and sha256
      ciphersuites were removed from defaults in lib/gnutls_priority.c,
      tests/priorities.c.
    - debian/patches/CVE-2018-1084x-5.patch: fix test for SHA512 in
      tests/pkcs12_encode.c.
    - CVE-2018-10844
    - CVE-2018-10845
    - CVE-2018-10846

 -- Marc Deslauriers <email address hidden> Tue, 28 May 2019 13:32:56 -0400

Source diff to previous version
CVE-2018-1084 corosync before version 2.4.4 is vulnerable to an integer overflow in exec/totemcrypto.c.
CVE-2018-10844 It was found that the GnuTLS implementation of HMAC-SHA-256 was vulnerable to a Lucky thirteen style attack. Remote attackers could use this flaw to
CVE-2018-10845 It was found that the GnuTLS implementation of HMAC-SHA-384 was vulnerable to a Lucky thirteen style attack. Remote attackers could use this flaw to
CVE-2018-10846 A cache-based side channel in GnuTLS implementation that leads to plain text recovery in cross-VM attack setting was found. An attacker could use a c

Version: 3.4.10-4ubuntu1.4 2017-10-26 19:06:40 UTC

  gnutls28 (3.4.10-4ubuntu1.4) xenial; urgency=medium

  * use_normal_priority_for_openssl_sslv23.diff by Andreas Metzler:
    OpenSSL wrapper: SSLv23_*_method translates to NORMAL GnuTLS priority,
    which includes TLS1.2 support. (LP: #1709193)

 -- Simon Deziel <email address hidden> Mon, 07 Aug 2017 23:04:43 +0000

1709193 Unable to use TLSv1.1 or 1.2 with OpenSSL compat layer



About   -   Send Feedback to @ubuntu_updates