UbuntuUpdates.org

Package "mariadb-plugin-connect"

Name: mariadb-plugin-connect

Description:

Connect storage engine for MariaDB

Latest version: 10.0.38-0ubuntu0.16.04.1
Release: xenial (16.04)
Level: security
Repository: universe
Head package: mariadb-10.0
Homepage: http://mariadb.org/

Links

Save this URL for the latest version of "mariadb-plugin-connect": https://www.ubuntuupdates.org/mariadb-plugin-connect


Download "mariadb-plugin-connect"


Other versions of "mariadb-plugin-connect" in Xenial

Repository Area Version
base universe 10.0.24-7
updates universe 10.0.38-0ubuntu0.16.04.1

Changelog

Version: 10.0.29-0ubuntu0.16.04.1 2017-01-25 14:06:49 UTC

  mariadb-10.0 (10.0.29-0ubuntu0.16.04.1) xenial-security; urgency=high

  * SECURITY UPDATE: New upstream release 10.0.29. Includes fixes for the
    following security vulnerabilities (LP: #1657594):
    - CVE-2017-3318
    - CVE-2017-3317
    - CVE-2017-3312
    - CVE-2017-3291
    - CVE-2017-3265
    - CVE-2017-3258
    - CVE-2017-3257
    - CVE-2017-3244
    - CVE-2017-3243
    - CVE-2017-3238
    - CVE-2016-6664

 -- Otto Kekäläinen <email address hidden> Thu, 19 Jan 2017 08:58:35 +0200

Source diff to previous version
1657594 USN-3174-1: partially applies to MariaDB too
CVE-2016-6664 mysqld_safe in Oracle MySQL through 5.5.51, 5.6.x through 5.6.32, and 5.7.x through 5.7.14; MariaDB; Percona Server before 5.5.51-38.2, 5.6.x before

Version: 10.0.28-0ubuntu0.16.04.1 2016-12-08 04:07:10 UTC

  mariadb-10.0 (10.0.28-0ubuntu0.16.04.1) xenial-security; urgency=low

  * SECURITY UPDATE: New upstream release 10.0.28. Includes fixes for the
    following security vulnerabilities (LP: #1638125):
    - CVE-2016-8283
    - CVE-2016-7440
    - CVE-2016-6663
    - CVE-2016-5629
    - CVE-2016-5626
    - CVE-2016-5624
    - CVE-2016-5616
    - CVE-2016-5584
    - CVE-2016-3492
  * Update old changelog entries to include new CVE identifiers

 -- Otto Kekäläinen <email address hidden> Mon, 31 Oct 2016 22:34:22 +0200

Source diff to previous version
1638125 USN-3109-1: MySQL vulnerabilities partially applies to MariaDB too
CVE-2016-8283 Unspecified vulnerability in Oracle MySQL 5.5.51 and earlier, 5.6.32 and earlier, and 5.7.14 and earlier allows remote authenticated users to affect
CVE-2016-5629 Unspecified vulnerability in Oracle MySQL 5.5.51 and earlier, 5.6.32 and earlier, and 5.7.14 and earlier allows remote administrators to affect avail
CVE-2016-5626 Unspecified vulnerability in Oracle MySQL 5.5.51 and earlier, 5.6.32 and earlier, and 5.7.14 and earlier allows remote authenticated users to affect
CVE-2016-5624 Unspecified vulnerability in Oracle MySQL 5.5.51 and earlier allows remote authenticated users to affect availability via vectors related to DML.
CVE-2016-5616 Unspecified vulnerability in Oracle MySQL 5.5.51 and earlier, 5.6.32 and earlier, and 5.7.14 and earlier allows local users to affect confidentiality
CVE-2016-5584 Unspecified vulnerability in Oracle MySQL 5.5.52 and earlier, 5.6.33 and earlier, and 5.7.15 and earlier allows remote administrators to affect confi
CVE-2016-3492 Unspecified vulnerability in Oracle MySQL 5.5.51 and earlier, 5.6.32 and earlier, and 5.7.14 and earlier allows remote authenticated users to affect

Version: 10.0.27-0ubuntu0.16.04.1 2016-09-19 20:06:30 UTC

  mariadb-10.0 (10.0.27-0ubuntu0.16.04.1) xenial-security; urgency=low

  * SECURITY UPDATE: New upstream release 10.0.27. Includes fixes for the
    following security vulnerabilities (LP: #1605493):
    - CVE-2016-6662
  * Previous release 10.0.26 included included fixes for
    the following security vulnerabilities:
    - CVE-2016-3615
    - CVE-2016-3521
    - CVE-2016-3477
  * Update old changelog entries to include new CVE identifiers

 -- Otto Kekäläinen <email address hidden> Wed, 14 Sep 2016 22:30:17 +0300

Source diff to previous version
1605493 USN-3040-1: MySQL vulnerabilities partially applies to MariaDB too
CVE-2016-6662 privilege escalation through ld_preload hijacking and my.cnf rewrite
CVE-2016-3615 Unspecified vulnerability in Oracle MySQL 5.5.49 and earlier, 5.6.30 and earlier, and 5.7.12 and earlier and MariaDB before 5.5.50, 10.0.x before 10.
CVE-2016-3521 Unspecified vulnerability in Oracle MySQL 5.5.49 and earlier, 5.6.30 and earlier, and 5.7.12 and earlier and MariaDB before 5.5.50, 10.0.x before 10.
CVE-2016-3477 Unspecified vulnerability in Oracle MySQL 5.5.49 and earlier, 5.6.30 and earlier, and 5.7.12 and earlier and MariaDB before 5.5.50, 10.0.x before 10.

Version: 10.0.25-0ubuntu0.16.04.1 2016-06-09 12:06:29 UTC

  mariadb-10.0 (10.0.25-0ubuntu0.16.04.1) xenial-security; urgency=low

  * SECURITY UPDATE: New upstream release 10.0.25. Includes fixes for the
    following security vulnerabilities (LP: #1589302):
    - CVE-2016-0666
    - CVE-2016-0655
    - CVE-2016-0648
    - CVE-2016-0647
    - CVE-2016-0643
  * Includes fixes done in 10.0.24 for the following security vulnerabilities:
    - CVE-2016-0668
    - CVE-2016-0650
    - CVE-2016-0649
    - CVE-2016-0646
    - CVE-2016-0644
    - CVE-2016-0641
    - CVE-2016-0640
  * Updated old changelog entries to include new CVE identifiers.
  * Upstream included changes to logrotate script that supports systems that
    has multiple mysqld processes running (Closes: #810968).
  * Upstream included bugfix to mariadb-server-10.0 postinstall.
  * Update Maintainer in d/control to match Ubuntu conventions.

 -- Otto Kekäläinen <email address hidden> Wed, 08 Jun 2016 11:31:46 -0400

1589302 USN-2953-1: MySQL vulnerabilities partially applies to MariaDB too
810968 mariadb-server-10.0: Logrotate exists 1 if a non-debian mysqld is running (e.g. containerized mysqld) - Debian Bug report logs
CVE-2016-0666 Unspecified vulnerability in Oracle MySQL 5.5.48 and earlier, 5.6.29 ...
CVE-2016-0655 Unspecified vulnerability in Oracle MySQL 5.6.29 and earlier and ...
CVE-2016-0648 Unspecified vulnerability in Oracle MySQL 5.5.48 and earlier, 5.6.29 ...
CVE-2016-0647 Unspecified vulnerability in Oracle MySQL 5.5.48 and earlier, 5.6.29 ...
CVE-2016-0643 Unspecified vulnerability in Oracle MySQL 5.5.48 and earlier, 5.6.29 ...
CVE-2016-0668 Unspecified vulnerability in Oracle MySQL 5.6.28 and earlier and ...
CVE-2016-0650 Unspecified vulnerability in Oracle MySQL 5.5.47 and earlier, 5.6.28 ...
CVE-2016-0649 Unspecified vulnerability in Oracle MySQL 5.5.47 and earlier, 5.6.28 ...
CVE-2016-0646 Unspecified vulnerability in Oracle MySQL 5.5.47 and earlier, 5.6.28 ...
CVE-2016-0644 Unspecified vulnerability in Oracle MySQL 5.5.47 and earlier, 5.6.28 ...
CVE-2016-0641 Unspecified vulnerability in Oracle MySQL 5.5.47 and earlier, 5.6.28 ...
CVE-2016-0640 Unspecified vulnerability in Oracle MySQL 5.5.47 and earlier, 5.6.28 ...



About   -   Send Feedback to @ubuntu_updates