UbuntuUpdates.org

Package "python-pip"

Name: python-pip

Description:

alternative Python package installer

Latest version: 8.1.1-2ubuntu0.5
Release: xenial (16.04)
Level: proposed
Repository: universe
Homepage: https://pip.pypa.io/en/stable/

Links


Download "python-pip"


Other versions of "python-pip" in Xenial

Repository Area Version
base universe 8.1.1-2
updates universe 8.1.1-2ubuntu0.4

Packages in group

Deleted packages are displayed in grey.


Changelog

Version: 8.1.1-2ubuntu0.5 2020-05-13 14:07:26 UTC

  python-pip (8.1.1-2ubuntu0.5) xenial; urgency=medium

  * d/patches/requires-python.patch: Add support for Requires-Python,
    backported from 9.0.0. virtualenv is installing setuptools 45.0.0 into
    Python 2.7 virtualenvs, which leaves broken virtualenvs.
    As libraries drop Python 2.7 support, this becomes more and more useful
    for 2.7 users to continue to use older versions of the libraries.
    (LP: #1864766)

 -- Stefano Rivera <email address hidden> Tue, 25 Feb 2020 16:17:00 -0800

1864766 [SRU] pip in xenial is installing packages incompatible with Python 2.7 (and those are becoming common)

Version: *DELETED* 2016-11-21 17:06:53 UTC
No changelog for deleted or moved packages.

Version: 8.1.1-2ubuntu0.4 2016-11-10 12:06:43 UTC

  python-pip (8.1.1-2ubuntu0.4) xenial; urgency=medium

  * d/patches/lp1626258.patch: Fix AttibuteError when accessing
    Requirement.project_name instead of Requirement.name. (LP: #1626258)
  * d/tests:
    - control: Add needs-recommends restriction.
    - pip2-*.sh: Install world 3.1, it's the latest version compatible
      with python2.

 -- Felipe Reyes <email address hidden> Wed, 21 Sep 2016 17:43:32 -0300

Source diff to previous version
1626258 [SRU] AttributeError: 'Requirement' object has no attribute 'project_name'

Version: 8.1.1-2ubuntu0.3 2016-09-27 11:06:41 UTC

  python-pip (8.1.1-2ubuntu0.3) xenial; urgency=medium

  * d/patches/lp1626258-do-not-use-project_name.patch when accessing
    Requirement.project_name instead of Requirement.name. (LP: #1626258)

 -- Felipe Reyes <email address hidden> Thu, 22 Sep 2016 16:07:55 +0200

1626258 [SRU] AttributeError: 'Requirement' object has no attribute 'project_name'

Version: *DELETED* 2016-08-22 21:06:41 UTC
No changelog for deleted or moved packages.



About   -   Send Feedback to @ubuntu_updates