UbuntuUpdates.org

Package "nvidia-graphics-drivers-304"

Name: nvidia-graphics-drivers-304

Description:

This package is just an umbrella for a group of other packages, it has no description.
Description samples from packages in group:

  • NVIDIA OpenCL Driver and ICD Loader library
  • Transitional package for nvidia-libopencl1-304

Latest version: 304.135-0ubuntu0.16.04.3
Release: xenial (16.04)
Level: updates
Repository: multiverse

Links

Save this URL for the latest version of "nvidia-graphics-drivers-304": https://www.ubuntuupdates.org/nvidia-graphics-drivers-304



Other versions of "nvidia-graphics-drivers-304" in Xenial

Repository Area Version
base restricted 304.131-0ubuntu3
base multiverse 304.131-0ubuntu3
security restricted 304.135-0ubuntu0.16.04.1
security multiverse 304.135-0ubuntu0.16.04.1
updates restricted 304.135-0ubuntu0.16.04.3

Packages in group

Deleted packages are displayed in grey.


Changelog

Version: 304.135-0ubuntu0.16.04.3 2019-03-15 12:06:54 UTC

  nvidia-graphics-drivers-304 (304.135-0ubuntu0.16.04.3) xenial; urgency=medium

  * debian/dkms_nvidia/patches/buildfix_kernel_4.10.patch:
    - Remove part that affected get_user_pages.
  * debian/dkms_nvidia/patches/buildfix_kernel_4.4_get_user_pages.patch:
   - Add support for backported 7 argument linux get_user_pages call (LP: #1573508).

 -- Alberto Milone <email address hidden> Mon, 04 Mar 2019 12:55:36 +0100

Source diff to previous version
1573508 SRU Request: nvidia-*: nvidia-* kernel module failed to build [error: too many arguments to function \u2018get_user_pages\u2019]

Version: 304.135-0ubuntu0.16.04.2 2018-01-18 20:06:40 UTC

  nvidia-graphics-drivers-304 (304.135-0ubuntu0.16.04.2) xenial; urgency=medium

  * Support for kernel 4.11 and 4.12. (LP: #1724871)
    - debian/dkms/patches/buildfix_kernel_4.11.patch
    - debian/dkms/patches/buildfix_kernel_4.12.patch

 -- Marcelo Henrique Cerri <email address hidden> Wed, 01 Nov 2017 16:57:45 -0200

Source diff to previous version
1724871 nvidia-graphics-drivers-304 304.135-0ubuntu0.16.04.1 ADT test failure with linux-hwe-edge 4.13.0-16.19~16.04.3

Version: 304.135-0ubuntu0.16.04.1 2017-03-21 01:06:50 UTC

  nvidia-graphics-drivers-304 (304.135-0ubuntu0.16.04.1) xenial; urgency=medium

  * SECURITY UPDATE:
    - CVE-2017-0318 (LP: #1659586).
  * New upstream release.
  * debian/dkms_nvidia/patches/buildfix_kernel_4.9.patch,
    debian/dkms_nvidia/patches/buildfix_kernel_4.10.patch,
    debian/templates/dkms_nvidia.conf.in:
    - Add support for Linux 4.9 and 4.10.

 -- Alberto Milone <email address hidden> Wed, 08 Mar 2017 15:02:55 +0100

Source diff to previous version
CVE-2017-0318 All versions of NVIDIA Linux GPU Display Driver contain a vulnerability in the kernel mode layer handler where improper validation of an input parame

Version: 304.134-0ubuntu0.16.04.1 2017-01-18 02:07:10 UTC

  nvidia-graphics-drivers-304 (304.134-0ubuntu0.16.04.1) xenial; urgency=medium

  * New upstream release.
  * debian/substvars:
     - Add support for X ABI 23.

 -- Robert Hooker <email address hidden> Thu, 15 Dec 2016 12:01:16 -0500

Source diff to previous version

Version: 304.132-0ubuntu0.16.04.2 2016-11-03 18:06:39 UTC

  nvidia-graphics-drivers-304 (304.132-0ubuntu0.16.04.2) xenial-security; urgency=medium

  * SECURITY UPDATE:
    - CVE-2016-7382, 2016-7389 (LP: #1627055).
  * New upstream release:
    - Added /var/log/dmesg to the list of paths which are searched by
      nvidia-bug-report.sh for kernel messages.
    - Fixed a bug that caused kernel panics when using the NVIDIA
      driver on v4.5 and newer Linux kernels built with
      CONFIG_DEBUG_VM_PGFLAGS.
  * debian/templates/control.in:
    - Add transitional packages to deprecate the -updates flavour.
  * debian/dkms/patches/buildfix_kernel_4.3.patch:
    - Refresh the patch.
  * debian/templates/nvidia-graphics-drivers.postinst.in:
    - Do not fail if update-initramfs is not available (LP: #1629274).

 -- Alberto Milone <email address hidden> Thu, 13 Oct 2016 17:23:23 +0200

1629274 nvidia-367 fails to install on buildds
CVE-2016-7382 RESERVED



About   -   Send Feedback to @ubuntu_updates