UbuntuUpdates.org

Package "libwebkit2gtk-4.0-37"

Name: libwebkit2gtk-4.0-37

Description:

Web content engine library for GTK+

Latest version: 2.20.5-0ubuntu0.16.04.1
Release: xenial (16.04)
Level: updates
Repository: main
Head package: webkit2gtk
Homepage: http://webkitgtk.org/

Links

Save this URL for the latest version of "libwebkit2gtk-4.0-37": https://www.ubuntuupdates.org/libwebkit2gtk-4.0-37


Download "libwebkit2gtk-4.0-37"


Other versions of "libwebkit2gtk-4.0-37" in Xenial

Repository Area Version
base main 2.10.9-1ubuntu1
security main 2.20.5-0ubuntu0.16.04.1
PPA: Webkit Team 2.14.2-0ubuntu0.16.04.1~webkitteam1

Changelog

Version: 2.20.5-0ubuntu0.16.04.1 2018-08-17 02:33:30 UTC

  webkit2gtk (2.20.5-0ubuntu0.16.04.1) xenial-security; urgency=medium

  * Updated to 2.20.5 to fix security issues.
    - CVE-2018-4246, CVE-2018-4261, CVE-2018-4262, CVE-2018-4263,
      CVE-2018-4264, CVE-2018-4265, CVE-2018-4266, CVE-2018-4267,
      CVE-2018-4270, CVE-2018-4272, CVE-2018-4273, CVE-2018-4278,
      CVE-2018-4284, CVE-2018-12911
  * debian/patches/fix-ftbfs-m68k.patch: refreshed with new version.

 -- Marc Deslauriers <email address hidden> Wed, 15 Aug 2018 07:49:35 -0400

Source diff to previous version
CVE-2018-4246 An issue was discovered in certain Apple products. iOS before 11.4 is affected. Safari before 11.1.1 is affected. iCloud before 7.5 on Windows is aff
CVE-2018-12911 WebKitGTK+ 2.20.3 has an off-by-one error, with a resultant out-of-bounds write, in the get_simple_globs functions in ThirdParty/xdgmime/src/xdgmimec

Version: 2.20.3-0ubuntu0.16.04.1 2018-06-18 13:06:51 UTC

  webkit2gtk (2.20.3-0ubuntu0.16.04.1) xenial-security; urgency=medium

  * Updated to 2.20.3 to fix security issues.
    - CVE-2018-4190, CVE-2018-4199, CVE-2018-4218, CVE-2018-4222,
      CVE-2018-4232, CVE-2018-4233, CVE-2018-12293
  * debian/patches/fix-atomics-build.patch: refreshed with new version.
  * debian/{rules,compat}: Show Ubuntu in user agent (LP: #1770868)
    - Thanks to Jeremy Bicha for the patch!

 -- Marc Deslauriers <email address hidden> Thu, 14 Jun 2018 13:06:02 -0400

Source diff to previous version
1770868 Show Ubuntu in webkit2gtk user agent for 16.04 LTS
CVE-2018-4190 An issue was discovered in certain Apple products. iOS before 11.4 is affected. Safari before 11.1.1 is affected. iCloud before 7.5 on Windows is aff
CVE-2018-4199 An issue was discovered in certain Apple products. iOS before 11.4 is affected. Safari before 11.1.1 is affected. iCloud before 7.5 on Windows is aff
CVE-2018-4218 An issue was discovered in certain Apple products. iOS before 11.4 is affected. Safari before 11.1.1 is affected. iCloud before 7.5 on Windows is aff
CVE-2018-4222 An issue was discovered in certain Apple products. iOS before 11.4 is affected. Safari before 11.1.1 is affected. iCloud before 7.5 on Windows is aff
CVE-2018-4232 An issue was discovered in certain Apple products. iOS before 11.4 is affected. Safari before 11.1.1 is affected. iCloud before 7.5 on Windows is aff
CVE-2018-4233 An issue was discovered in certain Apple products. iOS before 11.4 is affected. Safari before 11.1.1 is affected. iCloud before 7.5 on Windows is aff

Version: 2.20.2-0ubuntu0.16.04.1 2018-05-08 16:07:02 UTC

  webkit2gtk (2.20.2-0ubuntu0.16.04.1) xenial-security; urgency=medium

  * Updated to 2.20.2 to fix security issue.
    - CVE-2018-4200

 -- Marc Deslauriers <email address hidden> Mon, 07 May 2018 14:58:07 -0400

Source diff to previous version

Version: 2.20.1-0ubuntu0.16.04.1 2018-04-30 17:06:56 UTC

  webkit2gtk (2.20.1-0ubuntu0.16.04.1) xenial-security; urgency=medium

  * Updated to 2.20.1 to fix multiple security issues. (LP: #1761289)
    - CVE-2018-4101, CVE-2018-4113, CVE-2018-4114, CVE-2018-4117,
      CVE-2018-4118, CVE-2018-4119, CVE-2018-4120, CVE-2018-4122,
      CVE-2018-4125, CVE-2018-4127, CVE-2018-4128, CVE-2018-4129,
      CVE-2018-4133, CVE-2018-4146, CVE-2018-4161, CVE-2018-4162,
      CVE-2018-4163, CVE-2018-4165
  * debian/patches/*.patch: refreshed.
  * debian/rules: disable WOFF2, disabe GEOLOCATION.
  * debian/libwebkit2gtk-4.0-37.symbols: updated for new version.

 -- Marc Deslauriers <email address hidden> Fri, 27 Apr 2018 12:29:15 -0400

Source diff to previous version
1761289 WSA-2018-0003 security update
CVE-2018-4101 An issue was discovered in certain Apple products. iOS before 11.3 is affected. Safari before 11.1 is affected. iCloud before 7.4 on Windows is affec
CVE-2018-4113 An issue was discovered in certain Apple products. iOS before 11.3 is affected. Safari before 11.1 is affected. iCloud before 7.4 on Windows is affec
CVE-2018-4114 An issue was discovered in certain Apple products. iOS before 11.3 is affected. Safari before 11.1 is affected. iCloud before 7.4 on Windows is affec
CVE-2018-4117 An issue was discovered in certain Apple products. iOS before 11.3 is affected. Safari before 11.1 is affected. iCloud before 7.4 on Windows is affec
CVE-2018-4118 An issue was discovered in certain Apple products. iOS before 11.3 is affected. Safari before 11.1 is affected. iCloud before 7.4 on Windows is affec
CVE-2018-4119 An issue was discovered in certain Apple products. iOS before 11.3 is affected. Safari before 11.1 is affected. iCloud before 7.4 on Windows is affec
CVE-2018-4120 An issue was discovered in certain Apple products. iOS before 11.3 is affected. Safari before 11.1 is affected. iCloud before 7.4 on Windows is affec
CVE-2018-4122 An issue was discovered in certain Apple products. iOS before 11.3 is affected. Safari before 11.1 is affected. iCloud before 7.4 on Windows is affec
CVE-2018-4125 An issue was discovered in certain Apple products. iOS before 11.3 is affected. Safari before 11.1 is affected. iCloud before 7.4 on Windows is affec
CVE-2018-4127 An issue was discovered in certain Apple products. iOS before 11.3 is affected. Safari before 11.1 is affected. iCloud before 7.4 on Windows is affec
CVE-2018-4128 An issue was discovered in certain Apple products. iOS before 11.3 is affected. Safari before 11.1 is affected. iCloud before 7.4 on Windows is affec
CVE-2018-4129 An issue was discovered in certain Apple products. iOS before 11.3 is affected. Safari before 11.1 is affected. iCloud before 7.4 on Windows is affec
CVE-2018-4133 An issue was discovered in certain Apple products. Safari before 11.1 is affected. The issue involves the "WebKit" component. A Safari cross-site scr
CVE-2018-4146 An issue was discovered in certain Apple products. iOS before 11.3 is affected. Safari before 11.1 is affected. iCloud before 7.4 on Windows is affec
CVE-2018-4161 An issue was discovered in certain Apple products. iOS before 11.3 is affected. Safari before 11.1 is affected. iCloud before 7.4 on Windows is affec
CVE-2018-4162 An issue was discovered in certain Apple products. iOS before 11.3 is affected. Safari before 11.1 is affected. iCloud before 7.4 on Windows is affec
CVE-2018-4163 An issue was discovered in certain Apple products. iOS before 11.3 is affected. Safari before 11.1 is affected. iCloud before 7.4 on Windows is affec
CVE-2018-4165 An issue was discovered in certain Apple products. iOS before 11.3 is affected. Safari before 11.1 is affected. iCloud before 7.4 on Windows is affec

Version: 2.18.6-0ubuntu0.16.04.1 2018-01-31 00:06:11 UTC

  webkit2gtk (2.18.6-0ubuntu0.16.04.1) xenial-security; urgency=medium

  * Updated to 2.18.6 to fix multiple security issues.
    - CVE-2017-7153, CVE-2017-7160, CVE-2017-7161, CVE-2017-7165,
      CVE-2017-13884, CVE-2017-13885, CVE-2018-4088, CVE-2018-4096

 -- Chris Coulson <email address hidden> Mon, 29 Jan 2018 20:44:08 +0000

CVE-2017-7153 RESERVED
CVE-2017-7160 An issue was discovered in certain Apple products. iOS before 11.2 is affected. Safari before 11.0.2 is affected. iCloud before 7.2 on Windows is aff



About   -   Send Feedback to @ubuntu_updates