UbuntuUpdates.org

Package "policykit-1"

Name: policykit-1

Description:

framework for managing administrative policies and privileges

Latest version: 0.105-14.1ubuntu0.4
Release: xenial (16.04)
Level: security
Repository: main
Homepage: http://www.freedesktop.org/wiki/Software/polkit/

Links

Save this URL for the latest version of "policykit-1": https://www.ubuntuupdates.org/policykit-1


Download "policykit-1"


Other versions of "policykit-1" in Xenial

Repository Area Version
base main 0.105-14.1
updates main 0.105-14.1ubuntu0.4

Packages in group

Deleted packages are displayed in grey.


Changelog

Version: 0.105-14.1ubuntu0.4 2019-01-16 14:06:30 UTC

  policykit-1 (0.105-14.1ubuntu0.4) xenial-security; urgency=medium

  * SECURITY UPDATE: authorization bypass with large uid
    - debian/patches/CVE-2018-19788-1.patch: allow negative uids/gids in
      PolkitUnixUser and Group objects in src/polkit/polkitunixgroup.c,
      src/polkit/polkitunixprocess.c, src/polkit/polkitunixuser.c.
    - debian/patches/CVE-2018-19788-2.patch: add tests to
      test/data/etc/group, test/data/etc/passwd,
      test/data/etc/polkit-1/localauthority/10-test/com.example.pkla,
      test/polkitbackend/polkitbackendlocalauthoritytest.c.
    - debian/patches/CVE-2018-19788-3.patch: allow uid of -1 for a
      PolkitUnixProcess in src/polkit/polkitunixprocess.c.
    - CVE-2018-19788

 -- Marc Deslauriers <email address hidden> Tue, 15 Jan 2019 08:19:19 -0500

Source diff to previous version
CVE-2018-19788 A flaw was found in PolicyKit (aka polkit) 0.115 that allows a user with a uid greater than INT_MAX to successfully execute any systemctl command.

Version: 0.105-14.1ubuntu0.1 2018-07-16 17:06:50 UTC

  policykit-1 (0.105-14.1ubuntu0.1) xenial-security; urgency=medium

  * SECURITY UPDATE: DoS and information disclosure
    - debian/patches/CVE-2018-1116.patch: properly check UID in
      src/polkit/polkitprivate.h, src/polkit/polkitunixprocess.c,
      src/polkitbackend/polkitbackendinteractiveauthority.c,
      src/polkitbackend/polkitbackendsessionmonitor-systemd.c,
      src/polkitbackend/polkitbackendsessionmonitor.c,
      src/polkitbackend/polkitbackendsessionmonitor.h.
    - debian/libpolkit-gobject-1-0.symbols: updated for new private symbol.
    - CVE-2018-1116

 -- Marc Deslauriers <email address hidden> Fri, 13 Jul 2018 07:44:06 -0400

CVE-2018-1116 A flaw was found in polkit before version 0.116. The implementation of the polkit_backend_interactive_authority_check_authorization function in polki



About   -   Send Feedback to @ubuntu_updates