UbuntuUpdates.org

Package "grub-pc"

Name: grub-pc

Description:

GRand Unified Bootloader, version 2 (PC/BIOS version)

Latest version: 2.02~beta2-36ubuntu3.17
Release: xenial (16.04)
Level: proposed
Repository: main
Head package: grub2
Homepage: http://www.gnu.org/software/grub/

Links

Save this URL for the latest version of "grub-pc": https://www.ubuntuupdates.org/grub-pc


Download "grub-pc"


Other versions of "grub-pc" in Xenial

Repository Area Version
base main 2.02~beta2-36ubuntu3
updates main 2.02~beta2-36ubuntu3.16
PPA: Mint upstream 2.02~beta2-36ubuntu3.9+linuxmint1
PPA: Mint upstream 2.02~beta2-36ubuntu3.14+linuxmint1

Changelog

Version: *DELETED* 2017-10-30 23:06:39 UTC
No changelog for deleted or moved packages.

Version: 2.02~beta2-36ubuntu3.14 2017-10-12 22:06:52 UTC

  grub2 (2.02~beta2-36ubuntu3.14) xenial; urgency=medium

  * Add grub2/update_nvram template to allow users to disable NVRAM
    updates during package upgrades (LP: #1642298).

 -- dann frazier <email address hidden> Thu, 14 Sep 2017 16:13:39 -0600

Source diff to previous version

Version: 2.02~beta2-36ubuntu3.13 2017-09-11 18:06:49 UTC

  grub2 (2.02~beta2-36ubuntu3.13) xenial; urgency=medium

  * Fix EFIPersistentMemory (PMEM) support; incorrectly handled as "standard"
    reserved memory without really marking it reserved: (LP: #1716424)
    - debian/patches/git_pmem_really_mark_mem_reserved_3d2c8048.patch
    - debian/patches/git_pmem_translate_persistent_type_76ce1de7.patch
    - debian/patches/git_pmem_mmap_handle_pmem_c79c59f1.patch
    - debian/patches/git_pmem_efiemu_handle_pmem_ae3b83a4.patch

 -- Mathieu Trudel-Lapierre <email address hidden> Sun, 10 Sep 2017 20:08:16 -0400


Version: *DELETED* 2017-07-31 11:06:44 UTC
No changelog for deleted or moved packages.

Version: 2.02~beta2-36ubuntu3.12 2017-06-21 06:06:41 UTC

  grub2 (2.02~beta2-36ubuntu3.12) xenial; urgency=medium

  * debian/patches: Rework linuxefi/SecureBoot support and sync with upstream
    SB patch set: (LP: #1696599)
    - linuxefi_backport_arm64.patch: backport basic arm64 chainload/linux
      command support from 17.04.
    - linuxefi_arm_sb_support.patch: add Secure Boot support for arm for its
      chainloader.
    - linuxefi_fix_validation_race.patch: Fix a race in validating images.
    - linuxefi_chainloader_path.patch: honor the starting path for grub, so
      images do not need to be started from $root.
    - linuxefi_chainloader_sb.patch: Fix some more issues in chainloader use
      when Secure Boot is enabled.
    - linuxefi_loaders_enforce_sb.patch: Enforce Secure Boot policy for all
      loaders: don't load the commands when Secure Boot is enabled.
    - linuxefi_re-enable_linux_cmd.patch: Since we rely on the linux and
      initrd commands to automatically hand-off to linuxefi/initrdefi; re-
      enable the linux loader.
    - linuxefi_chainloader_pe_fixes.patch: PE parsing fixes for chainloading
      "special" PE images, such as Windows'.
    - linuxefi_rework_non-sb_cases.patch: rework cases where Secure Boot is
      disabled or shim validation is disabled so loading works as EFI binaries
      when it is supposed to.
    - Removed linuxefi_require_shim.patch; superseded by the above.
      (LP: #1689687)
  * debian/patches/git_tsc_use_alt_delay_sources_d43a5ee6.patch: refreshed.
  * debian/patches/arm64-set-correct-length-of-device-path-end-entry.patch:
    dropped; included in linuxefi_backport_arm64.patch.

 -- Mathieu Trudel-Lapierre <email address hidden> Thu, 08 Jun 2017 10:16:17 -0700

1689687 pass validation if shim protocol is not installed



About   -   Send Feedback to @ubuntu_updates