UbuntuUpdates.org

Package "gce-compute-image-packages"

Name: gce-compute-image-packages

Description:

GCE's compute-image-packages for use in their guest environment

Latest version: 20190124+dfsg1-0ubuntu1~14.04.0
Release: trusty (14.04)
Level: updates
Repository: universe
Homepage: https://github.com/GoogleCloudPlatform/compute-image-packages

Links

Save this URL for the latest version of "gce-compute-image-packages": https://www.ubuntuupdates.org/gce-compute-image-packages


Download "gce-compute-image-packages"


Other versions of "gce-compute-image-packages" in Trusty

Repository Area Version
proposed universe 20190315-0ubuntu1~14.04.0

Packages in group

Deleted packages are displayed in grey.


Changelog

Version: 20190124+dfsg1-0ubuntu1~14.04.0 2019-02-14 18:06:29 UTC

  gce-compute-image-packages (20190124+dfsg1-0ubuntu1~14.04.0) trusty; urgency=medium

  * Rebuild for Trusty

Source diff to previous version

Version: 20180905+dfsg1-0ubuntu1~14.04.1 2018-10-22 16:06:32 UTC

  gce-compute-image-packages (20180905+dfsg1-0ubuntu1~14.04.1) trusty; urgency=medium

  * debian/patches/set-LDFLAGS-for-PAM.patch: Fix missing symbols
    when using oslogin due to misording of the boost regex library
    in linking the PAM modules. (LP: #1798706)

Source diff to previous version
1798706 Incomplete linking with boost_regex

Version: 20180905+dfsg1-0ubuntu1~14.04.0 2018-10-05 00:06:54 UTC

  gce-compute-image-packages (20180905+dfsg1-0ubuntu1~14.04.0) trusty; urgency=medium

  * Backport to Trusty
    - Revert ordering shutdown scripts after snapd.service.
    - Revert adding /snap/bin to PATH for startup/shutdown scripts
    - Revert to using dh-systemd because Xenial does not have the debhelper
  * Revert "Build depend on debhelper (>= 9.20160709) instead of on dh-systemd"
    This reverts commit 1afdbde3f27ab4d1712b1a0d4cc14df3a0528bdc.
    Xenial does not have that debhelper version thus dh-systemd is needed there.
  * Build-depend on libboost-regex-dev for regex support
  * Choose std:: or boost:: regex based on support for C++11
  * Set LDFLAGS at the end of the the c++ command line right before libs.
    This fixes passig additional libs to make, namely -lboost_regex
  * Link with boost for regex support
  * Free tests from C++11 constructs to let them being compiled without C++11 support

Source diff to previous version

Version: 20180510+dfsg1-0ubuntu3~14.04.3 2018-06-14 16:06:51 UTC

  gce-compute-image-packages (20180510+dfsg1-0ubuntu3~14.04.3) trusty; urgency=medium

  * Restart services upon upgrade with upstart, too
  * Remove handling the systemd cases from maintainer scripts

Source diff to previous version

Version: 20180129+dfsg1-0ubuntu1~14.04.0 2018-02-09 04:06:43 UTC

  gce-compute-image-packages (20180129+dfsg1-0ubuntu1~14.04.0) trusty; urgency=medium

  [ Balint Reczey ]
  * Override false positive maintainer-script-empty Lintian warning
  * Suggest libpam-cracklib instead of recommending it
    libpam-cracklib was not installed on cloud images before due to using
    --no-install-recommends when installing gce-compute-image-packages, but this
    state could have been surprising for users. (LP: #1741989)
  * New upstream version 20180129+dfsg1 (LP: #1746588)
    - Close socket connections when requesting metadata.
    - Change the OS Login uid restriction to allow uid 1000.
    - Improve hostname setting, including restarting rsyslog
  * Backport to Trusty

  [ Zach Marano from Google Cloud Team ]
  * Update symlink to shared library with updated revision
  * Depend on rsyslog
  * Force IPv4 for Debian apt configs

 -- Balint Reczey <email address hidden> Wed, 31 Jan 2018 20:14:23 +0100

1741989 Drop libpam-cracklib from gce-compute-image-packages Recommends
1746588 Update google compute-image-packages to 20180129



About   -   Send Feedback to @ubuntu_updates