UbuntuUpdates.org

Package "pgbouncer"

Name: pgbouncer

Description:

lightweight connection pooler for PostgreSQL

Latest version: 1.4.2-2ubuntu0.1
Release: precise (12.04)
Level: updates
Repository: universe
Homepage: http://pgfoundry.org/projects/pgbouncer/

Links


Download "pgbouncer"


Other versions of "pgbouncer" in Precise

Repository Area Version
base universe 1.4.2-2build1
security universe 1.4.2-2ubuntu0.1
PPA: Postgresql 1.5.4-7.pgdg10.4+1
PPA: Postgresql 1.7.2-2.pgdg12.4+1
PPA: Postgresql 1.9.0-2.pgdg14.04+1
PPA: Postgresql 1.15.0-1.pgdg16.04+1
PPA: Postgresql 1.19.1-1.pgdg18.04+1
PPA: Postgresql 1.23.0-1.pgdg20.04+1
PPA: Postgresql 1.23.0-1.pgdg22.04+1

Changelog

Version: 1.4.2-2ubuntu0.1 2012-12-08 15:06:55 UTC

  pgbouncer (1.4.2-2ubuntu0.1) precise-security; urgency=low

  * SECURITY UPDATE: denial of service when too long db name is provided
    (LP: #1083414)
    - debian/patches/2-CVE-2012-4575.patch: objects.c(add_database): fail
      gracefully if too long db name. Based on upstream patch.
    - CVE-2012-4575
 -- Christian Kuersteiner <email address hidden> Tue, 04 Dec 2012 22:21:56 +0700

1083414 DoS-Vulnerability in pgbouncer
CVE-2012-4575 The add_database function in objects.c in the pgbouncer pooler 1.5.2 for PostgreSQL allows remote attackers to cause a denial of service (daemon outa



About   -   Send Feedback to @ubuntu_updates