UbuntuUpdates.org

Package "glib2.0"

Name: glib2.0

Description:

This package is just an umbrella for a group of other packages, it has no description.
Description samples from packages in group:

  • GLib library of C routines
  • Debugging symbols for the GLib libraries
  • Programs for the GLib library
  • Common files for GLib library

Latest version: 2.32.1-0ubuntu2
Release: precise (12.04)
Level: base
Repository: main

Links

Save this URL for the latest version of "glib2.0": https://www.ubuntuupdates.org/glib2.0



Other versions of "glib2.0" in Precise

Repository Area Version
base universe 2.32.1-0ubuntu2
updates main 2.32.4-0ubuntu1
updates universe 2.32.4-0ubuntu1

Packages in group

Deleted packages are displayed in grey.


Changelog

Version: 2.32.1-0ubuntu2 2012-04-16 19:07:10 UTC

glib2.0 (2.32.1-0ubuntu2) precise-proposed; urgency=low

  * Add revert_schema_path_warning.patch: Revert
    http://git.gnome.org/browse/glib/commit/?id=6560b3. Final freeze is not
    the time to start fixing the gsettings paths of all packages. This avoids
    tons of spewage from the gsettings trigger during package installation.

 -- Martin Pitt Mon, 16 Apr 2012 15:33:44 +0200

Source diff to previous version

Version: 2.32.0-1ubuntu3 2012-04-12 03:07:00 UTC

glib2.0 (2.32.0-1ubuntu3) precise-proposed; urgency=low

  * debian/patches/git_gdbus_messages_decoding.patch,
    debian/patches/git_gdbus_messages_decoding_test.patch:
    - upstream patch to fix a gdbus message decoding issue, include the
      next commit which has the testcase for the issue
  * debian/patches/git_powerpc_gresources.patch:
    - upstream fix for gresource on big endian archs, i.e powerpc
      (lp: #961512)

 -- Sebastien Bacher Wed, 11 Apr 2012 18:15:42 +0200

Source diff to previous version
961512 gresource is broken on powerpc

Version: 2.32.0-1ubuntu2 2012-04-10 16:06:57 UTC

glib2.0 (2.32.0-1ubuntu2) precise; urgency=low

  * 03_revert_git_single_include_error.patch: Don't enforce single include for
    glib/gversionmacros.h since this header is included from glib/gtypes.h
    which is widely used. Fixes several FTBFS.

 -- Martin Pitt Tue, 10 Apr 2012 13:05:15 +0200

Source diff to previous version

Version: 2.32.0-1ubuntu1 2012-03-30 16:06:50 UTC

glib2.0 (2.32.0-1ubuntu1) precise; urgency=low

  * Merge with Debian unstable. Remaining Ubuntu changes:
    - debian/control.in: Add Conflicts to obsolete libzeitgeist-gio,
      wncksyncdaemon, and old bamfdaemon, to clean them up on upgrades and
      avoid crashes due to incompatibilities. This can be dropped after the
      12.04 LTS release.
    - debian/control.in, debian/libglib2.0-bin.maintscript,
      debian/libglib2.0-bin.postinst: Remove /etc/etc/bash_completion.d/ files
      on upgrade, to clean up after LP #911191. This can be dropped after the
      12.04 LTS release.
    - 01_gettext-desktopfiles.patch: Use official "Keywords" key (lp #949864).
      Change now also committed to Debian SVN.
    - debian/libglib2.0-0.postrm.in: Only remove the compiled schemas on
      purge, not during upgrades. Otherwise we have no schemas available until
      the new postinst is run, which leads to applications aborting on missing
      schemas. Change now also committed to Debian SVN.
  * The new merge now makes packages which build depend on glib
    cross-buildable. (LP: #950967)

 -- Martin Pitt Fri, 30 Mar 2012 15:38:01 +0200

Source diff to previous version
911191 Package incorrectly puts bash_completion files in /etc/etc subdirectory
949864 Keywords
950967 glib2.0:armel uninstallable on systems that don't ...

Version: 2.32.0-0ubuntu1 2012-03-29 17:06:55 UTC

glib2.0 (2.32.0-0ubuntu1) precise-proposed; urgency=low

  * New upstream version
  * debian/libglib2.0-0.symbols:
    - dropped debug symbol which is enabled only in unstable series
  * debian/patches/git_gdbus_avoid_assert_bug.patch:
    - dropped, the fix is in the new version

 -- Sebastien Bacher Mon, 26 Mar 2012 19:52:08 +0200




About   -   Send Feedback to @ubuntu_updates