UbuntuUpdates.org

Package "apt"

Name: apt

Description:

This package is just an umbrella for a group of other packages, it has no description.
Description samples from packages in group:

  • transitional package for https support

Latest version: 2.4.8
Release: jammy (22.04)
Level: updates
Repository: universe

Links



Other versions of "apt" in Jammy

Repository Area Version
base main 2.4.5
base universe 2.4.5
updates main 2.4.8

Packages in group

Deleted packages are displayed in grey.


Changelog

Version: 2.4.8 2022-10-03 10:07:03 UTC

  apt (2.4.8) jammy; urgency=medium

  * edsp: Add support for phased updates (test in LP#1990586)
  * Check state of dependency, not dependee in dependency keep back
    (LP: #1990684)
  * full-upgrade: Mark phased upgrades for keep before anything else
    (LP: #1990586)

 -- Julian Andres Klode <email address hidden> Wed, 28 Sep 2022 17:37:51 +0200

Source diff to previous version
1990586 22.04: python3* mismatched phasing breaks dist-upgrades
1990684 grub-efi-arm64-signed : Depends: grub-efi-arm64 (= 2.06-2ubuntu7) but 2.06-2ubuntu10 is to be installed

Version: 2.4.7 2022-08-11 18:07:23 UTC

  apt (2.4.7) jammy; urgency=medium

  * Mark broken reverse depends for upgrade (LP: #1974196)

 -- Julian Andres Klode <email address hidden> Thu, 28 Jul 2022 09:26:24 +0200

Source diff to previous version
1974196 Installing libudev1 on a new Jammy installation uninstalls many packages.

Version: 2.4.6 2022-07-28 11:06:23 UTC

  apt (2.4.6) jammy; urgency=medium

  * (Temporarily) Rewrite phased updates using a keep-back approach
    (LP: #1979244)
  * policy: Do not override negative pins with 1 due to phasing (LP: #1978125)
  * Point branch to 2.4.y and use jammy in gitlab-ci

 -- Julian Andres Klode <email address hidden> Thu, 30 Jun 2022 15:33:22 +0200

1979244 libssl-dev : Depends: libssl3 (= 3.0.2-0ubuntu1.1) but 3.0.2-0ubuntu1.2 is to be installed
1978125 apt ignoring pin/block/hold files in preferences.d for snapd



About   -   Send Feedback to @ubuntu_updates