UbuntuUpdates.org

Package "libldap-common"

Name: libldap-common

Description:

OpenLDAP common files for libraries

Latest version: 2.5.18+dfsg-0ubuntu0.22.04.1
Release: jammy (22.04)
Level: updates
Repository: main
Head package: openldap
Homepage: https://www.openldap.org/

Links


Download "libldap-common"


Other versions of "libldap-common" in Jammy

Repository Area Version
base main 2.5.11+dfsg-1~exp1ubuntu3
security main 2.5.16+dfsg-0ubuntu0.22.04.2
proposed main 2.5.18+dfsg-0ubuntu0.22.04.2

Changelog

Version: 2.5.14+dfsg-0ubuntu0.22.04.2 2023-04-12 00:06:52 UTC

  openldap (2.5.14+dfsg-0ubuntu0.22.04.2) jammy; urgency=medium

  * Build the passwd/sha2 contrib module with -fno-strict-aliasing to
    avoid computing an incorrect SHA256 hash with some versions of the
    compiler (LP: #2000817):
    - d/t/{control,sha2-contrib}: test to verify the SHA256 hash
      produced by passwd/sha2
    - d/rules: set -fno-strict-aliasing only when building the
      passwd/sha2 contrib module

 -- Andreas Hasenack <email address hidden> Sun, 12 Mar 2023 14:11:53 -0300

Source diff to previous version
2000817 Wrong SHA256-value computed on kinetic

Version: 2.5.14+dfsg-0ubuntu0.22.04.1 2023-03-17 11:06:51 UTC

  openldap (2.5.14+dfsg-0ubuntu0.22.04.1) jammy; urgency=medium

  * New upstream version (LP: #2007625).
    - Several fixes, including memory leaks that affect slapd and
      certain slapo modules.

 -- Sergio Durigan Junior <email address hidden> Fri, 17 Feb 2023 16:12:43 -0500

Source diff to previous version
2007625 New upstream microrelease 2.5.14

Version: 2.5.13+dfsg-0ubuntu0.22.04.1 2022-08-31 19:07:04 UTC

  openldap (2.5.13+dfsg-0ubuntu0.22.04.1) jammy; urgency=medium

  * New upstream version (LP: #1983618).
    - Several fixes, including memory leaks that affected libldap.
    - Added slapo-emptyds contrib module (ITS#8882).

 -- Sergio Durigan Junior <email address hidden> Fri, 05 Aug 2022 10:51:52 -0400

Source diff to previous version
1983618 New upstream microrelease 2.5.13

Version: 2.5.12+dfsg-0ubuntu0.22.04.1 2022-06-21 23:06:25 UTC

  openldap (2.5.12+dfsg-0ubuntu0.22.04.1) jammy; urgency=medium

  * New upstream version (LP: #1977627).
    - Fixed slapd syncrepl handling of new sessions (ITS#9584)
    - Fixed slapd-sql to properly escape filter value (ITS#9815)
      (CVE-2022-29155)
      [ Already included in 2.5.11+dfsg-1~exp1ubuntu3.1 ]
    - More details about this release can be found at:
      https://git.openldap.org/openldap/openldap/-/blob/2bda1fa98fbcedc6cd5995ea905427b8bef89f9d/CHANGES
  * d/p/CVE-2022-29155.patch: Dropped patch; included in this new upstream
    version.

 -- Sergio Durigan Junior <email address hidden> Mon, 13 Jun 2022 13:19:52 -0400

Source diff to previous version
1977627 New upstream microrelease 2.5.12
CVE-2022-29155 In OpenLDAP 2.x before 2.5.12 and 2.6.x before 2.6.2, a SQL injection vulnerability exists in the experimental back-sql backend to slapd, via a SQL s

Version: 2.5.11+dfsg-1~exp1ubuntu3.1 2022-05-17 16:06:45 UTC

  openldap (2.5.11+dfsg-1~exp1ubuntu3.1) jammy-security; urgency=medium

  * SECURITY UPDATE: SQL injection in experimental back-sql backend
    - debian/patches/CVE-2022-29155.patch: escape filter values in
      servers/slapd/back-sql/search.c.
    - CVE-2022-29155

 -- Marc Deslauriers <email address hidden> Thu, 12 May 2022 09:07:41 -0400

CVE-2022-29155 In OpenLDAP 2.x before 2.5.12 and 2.6.x before 2.6.2, a SQL injection vulnerability exists in the experimental back-sql backend to slapd, via a SQL s



About   -   Send Feedback to @ubuntu_updates