UbuntuUpdates.org

Package "python3.10-examples"

Name: python3.10-examples

Description:

Examples for the Python language (v3.10)

Latest version: 3.10.12-1~22.04.4
Release: jammy (22.04)
Level: security
Repository: main
Head package: python3.10

Links


Download "python3.10-examples"


Other versions of "python3.10-examples" in Jammy

Repository Area Version
base main 3.10.4-3
updates main 3.10.12-1~22.04.4

Changelog

Version: 3.10.12-1~22.04.4 2024-07-09 17:07:11 UTC

  python3.10 (3.10.12-1~22.04.4) jammy-security; urgency=medium

  * SECURITY UPDATE: incorrect permission assignment
    - debian/patches/CVE-2023-6597.patch: fix symlink bug in cleanup.
    - CVE-2023-6597
  * SECURITY UPDATE: zipbomb DoS attack
    - debian/patches/CVE-2024-0450.patch: raise BadZipFile when trying
      to read an entry that overlaps with other entry or central
      directory.
    - CVE-2024-0450

 -- Allen Huang <email address hidden> Fri, 22 Mar 2024 16:50:05 +0000

Source diff to previous version
CVE-2023-6597 An issue was found in the CPython `tempfile.TemporaryDirectory` class affecting versions 3.12.1, 3.11.7, 3.10.13, 3.9.18, and 3.8.18 and prior. The
CVE-2024-0450 An issue was found in the CPython `zipfile` module affecting versions 3.12.1, 3.11.7, 3.10.13, 3.9.18, and 3.8.18 and prior. The zipfile module is v

Version: 3.10.12-1~22.04.3 2023-11-27 20:06:58 UTC

  python3.10 (3.10.12-1~22.04.3) jammy-security; urgency=medium

  * SECURITY UPDATE: TLS handshake bypass
    - debian/patches/CVE-2023-40217.patch: avoid ssl pre-close flaw in ssl.py.
    - CVE-2023-40217

 -- Fabian Toepfer <email address hidden> Mon, 20 Nov 2023 16:14:05 +0100

Source diff to previous version
CVE-2023-40217 An issue was discovered in Python before 3.8.18, 3.9.x before 3.9.18, 3.10.x before 3.10.13, and 3.11.x before 3.11.5. It primarily affects servers (

Version: 3.10.12-1~22.04.2 2023-07-31 15:07:37 UTC

  python3.10 (3.10.12-1~22.04.2) jammy-proposed; urgency=medium

  * SRU: LP: #1995504: Backport the 3.10.12 release to 22.04 LTS.
  * Revert:
    - autopkgtests: Support python3-setuptools >= 64, which does PEP-660
      editable installs.

Source diff to previous version
1995504 SRU: update python3.10 to the 3.10.8 release in 22.04 LTS and 22.10

Version: 3.10.6-1~22.04.2ubuntu1.1 2023-06-05 19:07:07 UTC

  python3.10 (3.10.6-1~22.04.2ubuntu1.1) jammy-security; urgency=medium

  * SECURITY UPDATE: Possible Bypass Blocklisting
    - debian/patches/CVE-2023-24329-2.patch: adds a complementary patch/fix
      for CVE-2023-24329 that was partially fixed before. This patch starts
      stripping C0 control and space chars in 'urlsplit' in Lib/urllib/parse.py,
      Lib/test/test_urlparse.py.
    - CVE-2023-24329

 -- Leonidas Da Silva Barbosa <email address hidden> Mon, 29 May 2023 08:10:38 -0300

Source diff to previous version
CVE-2023-24329 An issue in the urllib.parse component of Python before v3.11 allows attackers to bypass blocklisting methods by supplying a URL that starts with bla

Version: 3.10.6-1~22.04.2ubuntu1 2023-03-20 12:06:58 UTC

  python3.10 (3.10.6-1~22.04.2ubuntu1) jammy-security; urgency=medium

  * SECURITY UPDATE: Possible Bypass Blocklisting
    - debian/patches/CVE-2023-24329.patch: enforce
      that a scheme must begin with an alphabetical ASCII character
      in Lib/urllib/parse.py, Lib/test/test_urlparse.py.
    - CVE-2023-24329

 -- Leonidas Da Silva Barbosa <email address hidden> Fri, 10 Mar 2023 07:55:28 -0300

CVE-2023-24329 An issue in the urllib.parse component of Python before v3.11 allows attackers to bypass blocklisting methods by supplying a URL that starts with bla



About   -   Send Feedback to @ubuntu_updates