UbuntuUpdates.org

Package "isc-dhcp"

Name: isc-dhcp

Description:

This package is just an umbrella for a group of other packages, it has no description.
Description samples from packages in group:

  • Dynamic DNS (DDNS) enabled DHCP client
  • ISC DHCP relay daemon
  • DHCP server that uses LDAP as its backend

Latest version: 4.4.1-2.1ubuntu5.20.04.4
Release: focal (20.04)
Level: updates
Repository: universe

Links



Other versions of "isc-dhcp" in Focal

Repository Area Version
base main 4.4.1-2.1ubuntu5
security main 4.4.1-2.1ubuntu5.20.04.4
security universe 4.4.1-2.1ubuntu5.20.04.4
updates main 4.4.1-2.1ubuntu5.20.04.4

Packages in group

Deleted packages are displayed in grey.


Changelog

Version: 4.4.1-2.1ubuntu5.20.04.4 2022-10-05 19:06:23 UTC

  isc-dhcp (4.4.1-2.1ubuntu5.20.04.4) focal-security; urgency=medium

  * SECURITY UPDATE: option refcount overflow
    - debian/patches/CVE-2022-2928.patch: correct reference counts in
      common/options.c, common/tests/option_unittest.c.
    - CVE-2022-2928
  * SECURITY UPDATE: DHCP memory leak
    - debian/patches/CVE-2022-2929.patch: properly free memory when hitting
      errors in common/options.c.
    - CVE-2022-2929

 -- Marc Deslauriers <email address hidden> Tue, 04 Oct 2022 08:36:23 -0400

Source diff to previous version
CVE-2022-2928 RESERVED
CVE-2022-2929 RESERVED

Version: 4.4.1-2.1ubuntu5.20.04.3 2022-07-05 21:46:12 UTC

  isc-dhcp (4.4.1-2.1ubuntu5.20.04.3) focal; urgency=medium

  * d/apparmor/sbin.dhclient: fix apparmor="DENIED" errors (LP: #1918410)

 -- Lukas Märdian <email address hidden> Tue, 21 Jun 2022 12:44:45 +0200

Source diff to previous version
1918410 isc-dhcp-client denied by apparmor

Version: 4.4.1-2.1ubuntu5.20.04.2 2021-05-27 12:06:24 UTC

  isc-dhcp (4.4.1-2.1ubuntu5.20.04.2) focal-security; urgency=medium

  * SECURITY UPDATE: DoS via incorrect option information parsing
    - debian/patches/CVE-2021-25217.patch: fix parsing in common/parse.c.
    - CVE-2021-25217

 -- Marc Deslauriers <email address hidden> Tue, 25 May 2021 06:50:22 -0400

Source diff to previous version
CVE-2021-25217 In ISC DHCP 4.1-ESV-R1 -&gt; 4.1-ESV-R16, ISC DHCP 4.4.0 -&gt; 4.4.2 ( ...

Version: 4.4.1-2.1ubuntu5.20.04.1 2021-03-23 21:06:47 UTC

  isc-dhcp (4.4.1-2.1ubuntu5.20.04.1) focal; urgency=medium

  * Fix env variable for INTERFACES (LP: #1894172)
    - d/isc-dhcp-server.isc-dhcp-server{,6}.service: Replace $INTERFACES
      variable with $INTERFACEv4 and $INTERFACESv6, respectively, for
      respective services file.

 -- Utkarsh Gupta <email address hidden> Tue, 09 Mar 2021 20:49:45 +0530

1894172 isc-dhcp-server using wrong env variable for INTERFACES



About   -   Send Feedback to @ubuntu_updates